<!DOCTYPE html>
<html lang="en" dir="ltr">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<meta charset="utf-8"><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1039.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>21 Notable People Who Came Out in 2017 (So Far) | PRIDE.com</title>
<meta name="mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-title" content="Pride">
<meta property="fb:app_id" content="1660320884278138"/>
<meta property="fb:page_id" content="858821697507267" />
<link rel="shortcut icon" sizes="152x152" href="/sites/www.pride.com/themes/pride/images/apple-touch-icon-152.jpg">
<link rel="apple-touch-icon-precomposed" href="/sites/www.pride.com/themes/pride/images/apple-touch-icon-152.jpg">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="https://www.pride.com/sites/www.pride.com/themes/pride/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="shortlink" href="/node/158346" />
<link rel="canonical" href="https://www.pride.com/comingout/2017/7/17/21-notable-people-who-came-out-2017-so-far" />
<meta property="fb:pages" content="858821697507267" />
<script type="text/javascript">dataLayer = [{"drupalLanguage":"en","drupalCountry":"US","heremediaAuthor":"Raffy Ermac","heremediaContributor":"Raffy Ermac","heremediaContentType":"media_gallery","entityType":"node","entityBundle":"media_gallery","entityId":"158346","entityLabel":"21 Notable People Who Came Out in 2017 (So Far)","userUid":0}];</script>
<script type="text/javascript">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</script>
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.pride.com/comingout/2017/7/17/21-notable-people-who-came-out-2017-so-far" />
<meta property="og:title" content="21 Notable People Who Came Out in 2017 (So Far)" />
<meta property="og:description" content="2017 may be only half-way over, but so far, so many celebs have decided to publicly live their truths! " />
<meta property="og:updated_time" content="2017-07-17T13:39:21-04:00" />
<meta property="og:image" content="https://www.pride.com/sites/www.pride.com/files/2017/07/17/celebrities-who-came-out-in-2017-so-far.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="pride_site" />
<meta name="twitter:site:id" content="16616067" />
<meta name="twitter:creator" content="pride_site" />
<meta name="twitter:creator:id" content="16616067" />
<meta name="twitter:title" content="21 Notable People Who Came Out in 2017 (So Far)" />
<meta name="twitter:image:src" content="https://www.pride.com/sites/www.pride.com/files/2017/07/17/celebrities-who-came-out-in-2017-so-far.jpg" />
<meta property="article:published_time" content="2017-07-17T12:39:53-04:00" />
<meta property="article:modified_time" content="2017-07-17T12:39:53-04:00" />

<script type="text/javascript">
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "11464276" });

(function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=11464276&cv=2.0&cj=1" />
</noscript>

<!-- True Anthem script -->
<script type="text/javascript">
    (function (w, d) {
        var s1 = d.getElementsByTagName('script')[0],
            s = d.createElement('script'),
            cid = '510';
        s.src = '//tru.am/scripts/ta-pagesocial-sdk.js';
        if (s.addEventListener) {
            s.addEventListener('load', function () {
                w.TRUE_ANTHEM.configure(cid);
            }, false);
        } else {
            s.onreadystatechange = function () {
                if (s.readyState in {loaded: 1, complete: 1}) {
                    s.onreadystatechange = null;
                    w.TRUE_ANTHEM.configure(cid);
                }
            };
        }
        s1.parentNode.insertBefore(s, s1);
    }(window, document));
</script>
<!-- End True Anthem script -->
<!-- Lotame script -->
<script type="text/javascript" src="https://tags.crwdcntrl.net/c/6978/cc.js?ns=_cc6978" id="LOTCC_6978"></script>
<script type="text/javascript" language="javascript">_cc6978.bcp();</script>
<!-- End Lotame script -->
<link type="text/css" rel="stylesheet" href="https://www.pride.com/sites/www.pride.com/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.pride.com/sites/www.pride.com/files/css/css_tP8YPUzDtPEk1LtW5gf-KbY4F2ECdlBtLLy_GVrz1Io.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.pride.com/sites/www.pride.com/files/css/css_liQF1kIaofRP9koRu5L0Y1HC3ZwkigsuUKlI_YWFWXI.css" media="all" />

<!--[if lt IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.pride.com/sites/www.pride.com/files/css/css_VyKHcoC2vkE6vSZy1096yGnGRXchk2qXI7pn80r5cvw.css" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://www.pride.com/sites/www.pride.com/files/css/css_XlZZnIS4gM_Zc76ZEgipqZdbvySZkucj66eVP7TSQOU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat:400,700|Open+Sans+Condensed:300,700italic,700" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.pride.com/sites/www.pride.com/files/css/css_0G8naY0kMH9PdEnOgq1Zy4jVNJ5YEVzMdYqj1elL60Q.css" media="all" />
<script type="text/javascript" src="https://www.pride.com/sites/www.pride.com/files/js/js_SDrWB7XkDgjpXXPZhqE0gi6BBOlRMPjLGwSx40REXUg.js"></script>
<script type="text/javascript" src="https://www.pride.com/sites/www.pride.com/files/js/js_MpKfe1sTh5JIVGCZ17DsAuT1rqAC38MLLlkjqjQ1X_k.js"></script>
<script type="text/javascript" src="https://www.pride.com/sites/www.pride.com/files/js/js_R9UbiVw2xuTUI0GZoaqMDOdX0lrZtgX-ono8RVOUEVc.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="https://www.pride.com/sites/www.pride.com/files/js/js_sFWE3xcUzc7iLA-6edV8I5dOp5qBSDlZGpoKr5wR_iI.js"></script>
<script type="text/javascript" src="https://sadmin.brightcove.com/js/BrightcoveExperiences.js"></script>
<script type="text/javascript" src="//native.sharethrough.com/assets/tag.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var addthis_share = { url: "http://www.pride.com/comingout/2017/7/17/21-notable-people-who-came-out-2017-so-far" }
//--><!]]>
</script>
<script type="text/javascript" src="https://www.pride.com/sites/www.pride.com/files/js/js_F23xuUVofpPeXn4VHyogU1s6i1ONufh0sp0elCA4wmk.js"></script>
<script type="text/javascript" src="https://www.pride.com/sites/www.pride.com/files/js/js_OsUgQkJObe1uggA9k0D2Fw5J_70rcliZILi6nK4JpSs.js"></script>
<script type="text/javascript">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</script>
<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!--[if lt IE 9]>
    <script src="/sites/www.pride.com/themes/pride/js/html5shiv.js"></script>
    <script src="/sites/www.pride.com/themes/pride/js/respond.js"></script>
  <![endif]-->
<script type="text/javascript">
    setTimeout(function(){var a=document.createElement("script");
        var b=document.getElementsByTagName("script")[0];
        a.src=document.location.protocol+"//script.crazyegg.com/pages/scripts/0050/6735.js?"+Math.floor(new Date().getTime()/3600000);
        a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
</script>
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-158346 node-type-media-gallery"  >
<!-- Facebook Pixel Code -->
<script>
    !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
    n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
    document,'script','https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1586530151593576');
    fbq('track', "PageView");
</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1586530151593576&ev=PageView&noscript=1"/></noscript>
<!-- End Facebook Pixel Code -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-K5RNFPW" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <div class="navmenu navmenu-default navmenu-fixed-left offcanvas"> <ul class="nav navmenu-nav out"><li class="0 first"><a href="/identities">#Identities</a></li>
<li class="1"><a href="/style">#Style</a></li>
<li class="2"><a href="/taxonomy/term/15101/">#GoingOut</a></li>
<li class="3"><a href="/gay-celebrities">#Celebs</a></li>
<li class="4"><a href="/gay-music">#Music</a></li>
<li class="5"><a href="/money">#Money</a></li>
<li class="6"><a href="/gay-travel">#Travel</a></li>
<li class="7"><a href="/hiv">#HIV</a></li>
<li class="8 last"><a href="/first-person">#FirstPerson</a></li>
</ul><ul class="nav navmenu-nav sites"><li class="0 first"><a href="https://www.advocate.com" target="_blank">Advocate</a></li>
<li class="1"><a href="https://www.out.com" target="_blank">Out</a></li>
<li class="2"><a href="https://www.outtraveler.com" target="_blank">Out Traveler</a></li>
<li class="3"><a href="https://www.hivplusmag.com" target="_blank">Plus</a></li>
<li class="4 last"><a href="https://www.here.tv" target="_blank">Here TV</a></li>
</ul><ul class="nav navmenu-nav order"><li class="0 first"><a href="https://heremediamagazines.com/index.php" target="_blank">Subscribe</a></li>
<li class="1"><a href="https://service.qfie.com/HERE/clsOUTLookup.asp?strAspReason=106&amp;strLookFormControl=1" target="_blank">Subscriber Services</a></li>
<li class="2 last"><a href="/signup" class="order">Email Newsletter Signup</a></li>
</ul><ul class="nav navmenu-nav terms"><li class="0 first"><a href="/contact">Contact</a></li>
<li class="1"><a href="https://www.heremedia.com/company/careers/" target="_blank">Career Opportunities</a></li>
<li class="2"><a href="https://www.heremedia.com/sales/" target="_blank">Advertise With Us</a></li>
<li class="3"><a href="https://www.heremedia.com/privacy-policy" target="_blank">Privacy Policy</a></li>
<li class="4"><a href="https://www.heremedia.com/terms-of-use" target="_blank">Terms of Use</a></li>
<li class="5 last"><a href="https://www.heremedia.com/legal-notice" target="_blank">Legal Notice</a></li>
</ul>  <ul class="nav navmenu-nav copyright">
    <li>&copy; 2017 Here Media Inc.<br>
      All Rights Reserved</li>
  </ul>
</div>
<div class="desktopHeader box-shadow">
  <div class="container-fluid">
    <div class="navbar navbar-default">
      <button type="button" class="navbar-toggle" data-toggle="offcanvas" data-target=".navmenu" data-canvas="body"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </button>
      <div class="topLogoHeader"><a href="/"><img src="/sites/www.pride.com/themes/pride/images/logo.png" class="mainLogo" alt=""> <img src="/sites/www.pride.com/themes/pride/images/pride-mobile.svg" class="mobileLogo" style="display:none;" alt=""></a>
              </div>
    </div>
  </div>
</div>
<div id="body-inner" class="container-fluid slideshowWrap">
  <div class="row">
    <div class="col-xs-12 col-sm-12 col-md-12">                         <div class="tabs"></div>
                        <div class="page galleryDetailSection" >    <h1 class="articleTitle mobile">21 Notable People Who Came Out in 2017 (So Far)</h1>
<div class="slideshowAuthor mobile">By <span><a href="/authors/raffy-ermac">Raffy Ermac</a></span></div>
<div id="media-gallery-view" class="node node-media-gallery yellow clearfix" >
    <div class="galleryWrap">
    <div class="owl-carousel carousel-large" data-slider-id="1">
            <div class="item" data-hash="slide-0" data-title="21 Notable People Who Came Out in 2017 (So Far)" data-pos="0">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/14/00-celebs-750x750.jpg" alt="21 Notable People Who Came Out in 2017 (So Far)"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">21 Notable People Who Came Out in 2017 (So Far)</span></div>
          <div> <p>2017 is still far from being done, but so far, there have been plenty of celebrities and public figures who have used their platforms to live their truths and add some much-needed visibility to the LGBT community! </p>
<p>Here are 21 notable people who have made 2017 the year they came out! </p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-1" data-title="ILoveMakonnen" data-pos="1">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/12/01-ap-ilovemakonnen.jpg" alt="ILoveMakonnen"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">ILoveMakonnen</span></div>
          <div> <p>The 28-year-old Atlanta rapper (known mostly for his hit song “Tuesday”) <a href="http://www.pride.com/comingout/2017/1/20/ilovemakonnen-just-came-out-gay" target="_blank">came out as gay back in January</a> during a heartfelt string of tweets. His coming out added much needed queer visibility to the genre of hip-hop, but it wasn’t without some backlash, the most notable being <a href="http://pitchfork.com/news/71471-migos-not-cool-with-support-of-ilovemakonnens-homosexuality-thats-wack-bro/" target="_blank">homophobic criticism from rap group Migos</a>.</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-2" data-title="Gia Gunn" data-pos="2">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/06/04-gia-gunn-ig.jpg" alt="Gia Gunn"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Gia Gunn</span></div>
          <div> <p>Season 6 <em>RuPaul’s Drag Race</em> contestant Gia Gunn <a href="http://www.pride.com/comingout/2017/4/03/season-6-drag-race-alum-just-came-out-trans" target="_blank">came out as trans in an April Instagram post</a>. The emotional video coincided with International Transgender Day of Visibility. </p>
<p>"I can only hope the best for each and every single one of my trans brothers and sisters," Gia said. "Let's be visible."</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-3" data-title="Cody Alan" data-pos="3">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/06/02-cody-alan-ig.jpg" alt="Cody Alan"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Cody Alan</span></div>
          <div> <p>The beloved Country Music Television personality <a href="http://www.pride.com/comingout/2017/1/12/cmt-host-just-came-out-gay" target="_blank">came out as gay in a January interview</a> with <a href="http://people.com/country/cmt-cody-alan-comes-out-as-gay/" target="_blank"><em>People</em> magazine</a>. </p>
<p>"Country music is so diverse and perhaps the most supportive music industry that exists," Alan told <em>People</em>. "My story’s very real, and that’s what country music is: I live a real life that’s had twists and turns, ups and downs, and it’s kind of a country song in and of itself!"</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-4" data-title="Anthony Bowens" data-pos="4">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/06/03-anthony-bowens-ig.jpg" alt="Anthony Bowens"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Anthony Bowens</span></div>
          <div> <p>With the help of his YouTuber boyfriend Michael Pavano (right), professional WWE wrestler Anthony Bowens (left) was able to confront the oppressive hypermasculinity and heteronormativity of the athletic world and <a href="http://www.pride.com/comingout/2017/3/15/adorable-youtube-video-helped-pro-wrestler-come-out-closet" target="_blank">come out as bisexual in March</a>.</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-5" data-title="Alia Shawkat" data-pos="5">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/06/08-alia-shawkat-ig.jpg" alt="Alia Shawkat"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Alia Shawkat</span></div>
          <div> <p><a href="http://www.pride.com/comingout/2017/5/15/these-3-stars-casually-opened-about-their-sexualities-weekend" target="_blank">In a May interview with <em>Out Magazine</em></a>, <em>Arrested Development</em> actress Alia Shawkat came out as bi. </p>
<p>"How do you identify with these [queer] characters [you've played]?" <em>Out</em> asked her in the interview. </p>
<p>"I was a tomboy growing up, and I remember my mom asking me when I was 10, 'Are you attracted to boys or girls?' I said I don’t know. Now I consider myself bisexual, and I think balancing my male and female energies has been a big part of me growing as an actor,” Alia answered.</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-6" data-title="Zeke Smith" data-pos="6">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/06/05-zeke-smith-ig.jpg" alt="Zeke Smith"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Zeke Smith</span></div>
          <div> <p>Although <em>Survivor: Game Changers</em> contestant Zeke Smith’s public coming out wasn’t on his own terms (<a href="http://www.pride.com/transgender/2017/4/13/trans-survivor-contestant-who-was-outed-national-tv-shares-his-inspiring-story" target="_blank">he was outed on national TV back in April</a> by a petty cast member who was trying to save himself from elimination), he has found some good in the experience, <a href="https://www.hollywoodreporter.com/live-feed/survivor-zeke-smith-outed-as-transgender-guest-column-991514" target="_blank">teaching people in an op-ed for <em>The Hollywood Reporter</em></a> that gender identity is very personal, and that people should be allowed to live as privately as they want to be.</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-7" data-title="Shawn Barber" data-pos="7">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/06/06-shawn-barber-ig.jpg" alt="Shawn Barber"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Shawn Barber</span></div>
          <div> <p>Shawn Barber, Olympian and Canadian pole vaulting champion, <a href="http://www.pride.com/comingout/2017/4/24/olympic-pole-vaulting-champion-shawn-barber-comes-out-gay" target="_blank">came out as gay in a Facebook post back in April</a>.</p>
<p>"Gay and proud!” Shawn said in the post. “Thank you to my parents for being such a great support. I continue to grow as a person and have a great support group. My parents are my greatest support and have helped me through a lot recently. To my friends, you are always my friends and I love you too!"</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-8" data-title="Keiynan Lonsdale" data-pos="8">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/06/07-keiynan-lonsdale-ig.jpg" alt="Keiynan Lonsdale"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Keiynan Lonsdale</span></div>
          <div> <p>Actor Keiynan Lonsdale (known for playing Wally West on The CW’s hit superhero show <em>The Flash</em>) <a href="http://www.pride.com/comingout/2017/5/15/these-3-stars-casually-opened-about-their-sexualities-weekend" target="_blank">came out as bisexual on Instagram in May</a>. </p>
<p>"I like to change my hair, I like to take risks with how I dress, I like girls, &amp; I like guys" the Australian actor said. "I gotta take the next step &amp; actually embrace who I am, which is pretty exciting. Not faking shit anymore, not apologising for falling in love with people no matter their gender." </p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-9" data-title="Barry Manilow" data-pos="9">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/06/09-barry-manilow-shutterstock.jpg" alt="Barry Manilow"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Barry Manilow</span></div>
          <div> <p>The very private singing legend finally opened up about his sexuality and <a href="https://variety.com/2017/music/news/barry-manilow-sexuality-marriage-1202023472/" target="_blank">revealed that he is gay</a> in <a href="http://people.com/music/barry-manilow-hid-sexuality-thought-being-gay-would-disappoint-fans/" target="_blank">an April interview with <em>People</em> magazine</a>.</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-10" data-title="Kristen Stewart" data-pos="10">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/06/11-kristen-stewart-shutterstock.jpg" alt="Kristen Stewart"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Kristen Stewart</span></div>
          <div> <p>Although Kristen Stewart talked about her relationship with Alicia Cargile in an interview in 2016, it wasn’t until her <em>Saturday Night Live</em> appearance back in February of this year that the <em>Personal Shopper</em> and <em>Café Society</em> actress <a href="http://time.com/4698857/kristen-stewart-snl-coming-out/" target="_blank">actually called herself “so gay.”</a> Then, <a href="https://www.theguardian.com/film/2017/mar/09/kristen-stewart-bisexual-personal-shopper-trump-tweets" target="_blank">in a March interview with <em>The Guardian</em></a>, she talked more about sexuality fluidity, and how being bisexual isn't confusing for her. </p>
<p>"People still have some horrendous fucking experiences. But it’s cool that you don’t have to nail everything down anymore. That whole certainty about whether you’re straight or gay or whatever," she said. "You’re not confused if you’re bisexual. It’s not confusing at all. For me, it’s quite the opposite."</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-11" data-title="Daniel Newman" data-pos="11">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/06/19/10-daniel-newman-shutterstock.jpg" alt="Daniel Newman"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Daniel Newman</span></div>
          <div> <p>Daniel Newman, one of the stars on the smash AMC show <em>The Walking Dead</em>, <a href="http://people.com/tv/walking-dead-daniel-newman-hopes-inspire-lgbt-youth-opens-up-sexuality/" target="_blank">came out as bisexual in March</a> after posting <a href="https://www.youtube.com/watch?v=jLcmrXhYgwU" target="_blank">a YouTube video</a> talking about his sexuality. </p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-12" data-title="Shannon Purser" data-pos="12">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/14/12-shannon-purser-ig.jpg" alt="Shannon Purser"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Shannon Purser</span></div>
          <div> <p>Shannon Purser, <em>Stranger Things</em> and <em>Riverdale</em> actress, <a href="http://people.com/tv/shannon-purser-bisexual/" target="_blank">came out as bisexual</a> on <a href="https://twitter.com/shannonpurser/status/854538329546780678" target="_blank">Twitter</a> back in April. </p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-13" data-title="Taylor Bennett" data-pos="13">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/14/14-taylor-bennett-ig.jpg" alt="Taylor Bennett"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Taylor Bennett</span></div>
          <div> <p>Taylor Bennett, Chance the Rapper’s brother who also happens to be a fellow MC, <a href="http://www.teenvogue.com/story/chance-the-rapper-brother-taylor-bennett-bisexual" target="_blank">took to Twitter in January to come out as bisexual</a>. </p>
<p>"Growing up I've always felt indifferent about my sexuality &amp; being attracted 2 one sex &amp; today I would like to openly come out to my fans,” he said. “I do recognize myself as a bisexual male &amp; do &amp; have always openly supported the gay community &amp; will keep doing so in 2017. #ThankYou."</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-14" data-title="Diora Baird" data-pos="14">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/14/13-diora-baird-ig.jpg" alt="Diora Baird"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Diora Baird</span></div>
          <div> <p>The <em>Shameless</em> actress <a href="https://www.instagram.com/p/BUdE-s7jRBZ/?taken-by=diorabaird&amp;hl=en" target="_blank">came out as lesbian</a> to <a href="http://www.advocate.com/television/2017/5/23/shameless-wedding-crashers-actress-diora-baird-comes-out" target="_blank"><em>The Advocate</em> in May</a>, and opened up about her relationship with comedian Mav Viola.</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-15" data-title="Jill Soloway" data-pos="15">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/14/15-jill-soloway-shutterstock.jpg" alt="Jill Soloway"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Jill Soloway</span></div>
          <div> <p>The creator of the critically-acclaimed Amazon series <em>Transparent</em> and the new show <em>I Love Dick</em> <a href="https://www.lgbtqnation.com/2017/05/transparent-creator-jill-soloway-comes-trans-non-binary/" target="_blank">came out as trans</a> in <a href="https://www.theguardian.com/tv-and-radio/2017/may/21/transparents-jill-soloway-the-words-male-and-female-describe-who-we-used-to-be" target="_blank">a May interview with <em>The Guardian</em></a>. </p>
<p>“I identify as trans, which means that I am not seeking to synthesize my appearance with the label assigned to me at birth and instead am opting to live in a space where a label other than male or female is used to define me,” Soloway, <a href="http://www.advocate.com/love-and-sex/2016/10/27/love-story-jill-soloway-and-eileen-myles" target="_blank">who prefers gender-neutral pronouns</a>, said. </p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-16" data-title="Thomas Dekker" data-pos="16">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/17/16-thomas-dekker-ap_0.jpg" alt="Thomas Dekker"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Thomas Dekker</span></div>
          <div> <p>After being outed by <em>Hannibal</em> and <em>American Gods</em> creator Bryan Fuller (who was speaking on a panel at the LGBT film festival Outfest), <a href="http://www.vulture.com/2017/07/heroes-actor-thomas-dekker-comes-out-as-gay-and-married.html" target="_blank"><em>Heroes</em> actor Thomas Dekker came out as gay</a> in an emotional July 13 <a href="https://www.instagram.com/p/BWghACthQER/" target="_blank">Instagram post</a>.</p>
<p>“My sexual orientation once again came into question this week when a prominent gay man used an awards acceptance speech to ‘out’ me,” Dekker said on Instagram. “While he did not mention me by name, the explicit details of his reference made it easy for the public and media to connect the dots. While it is an odd situation, I thank him because it presents a prime opportunity for me to publicly say that I am indeed a man who proudly loves other men. In fact, this April, I married my husband and I could not be happier.”</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-17" data-title="Jordan Gavaris" data-pos="17">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/17/17-jordan-gavaris-ap_0.jpg" alt="Jordan Gavaris"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Jordan Gavaris</span></div>
          <div> <p>Although he’s been out to his family since he was 19, 27-year-old <a href="http://www.huffingtonpost.com/entry/orphan-black-jordan-gavaris-gay_us_5941718de4b0d3185486ab9f" target="_blank"><em>Orphan Black</em> actor Jordan Garavis waited until June of 2017 to publicly come out as gay</a>.</p>
<p><a href="http://www.vulture.com/2017/06/jordan-gavaris-explains-it-all.html" target="_blank">In an interview with <em>Vulture</em></a>, Garavis offered this explanation:</p>
<p>“I guess that’s where I’m at in terms of coming out publicly: I had this position when I started on the show that it shouldn’t matter. And I believe that. I hope that one day, the world gets to a place where you don’t need to politicize your sexuality any more than someone needs to politicize their race — that we can just act and we can exist in this Zeitgeist, telling stories about one another. And that no one’s afraid, maybe, to come out. But also that no one’s really hyperobsessed with knowing whether or not someone’s gay. That would be an amazing world to live in, where people don’t feel the need to protect themselves and other people don’t feel the need to launch an inquisition.”</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-18" data-title="Jake Zyrus" data-pos="18">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/17/18-jake-zyrus-ig_0.jpg" alt="Jake Zyrus"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Jake Zyrus</span></div>
          <div> <p>Jake Zyrus, the Filipino singer formerly known as Charice, <a href="https://www.pride.com/comingout/2017/6/21/jake-zyrus-formerly-known-charice-comes-out-transgender" target="_blank">came out as a trans man in mid-June</a> with <a href="https://www.instagram.com/p/BVeBRAqgNbo/" target="_blank">a simple “Thank You” note on Instagram</a>.</p>
<p>“From the bottom of my heart, thank you for the love and respect,” Jake wrote on Instagram. “I love you back and I'm sending peace to everyone.”</p>
<p>He had <a href="http://people.com/celebrity/charice-pempengco-is-a-lesbian-glee-star-comes-out/" target="_blank">previously come out as a lesbian in 2013</a>, and <a href="https://www.youtube.com/watch?v=QjNtzPXorL0" target="_blank">in a 2014 interview with Oprah</a>, talked about his gender identity and about how his “soul is male.”</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-19" data-title="Ryan O'Callaghan" data-pos="19">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/17/19-ryan-ocallaghan-ap_0.jpg" alt="Ryan O'Callaghan"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Ryan O'Callaghan</span></div>
          <div> <p>The former New England Patriots and Kansas City Chiefs player <a href="https://www.outsports.com/2017/6/20/15835374/ryan-ocallaghan-gay-nfl-new-england-patriots-kansas-city-chiefs" target="_blank">came out as gay in June during an emotional interview with <em>Outsports</em></a>.</p>
<p>“People need to understand that we are everywhere. We’re your sons, your daughters, your teammates, your neighbors. And honestly, even some of your husbands and wives. You just don’t know it yet,” he said. “It’s not always easy being honest, but I can tell you it’s much easier and more enjoyable being yourself and not living a lie.”</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-20" data-title="Gavin Russom" data-pos="20">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/17/20-gavin-russom-ig_0.jpg" alt="Gavin Russom"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Gavin Russom</span></div>
          <div> <p>The founding member of the band LCD Soundsystem <a href="https://www.pride.com/transgender/2017/7/06/lcd-soundsystems-gavin-russom-comes-out-trans-woman" target="_blank">came out as a trans woman in early July</a>.</p>
<p>“Over the last year and a half, I went from my trans identity being something I was in touch with and worked through in one way or another, to suddenly this shift where it’s on the front burner,” Russom, who uses female pronouns and her old name, <a href="http://pitchfork.com/thepitch/lcd-soundsystems-gavin-russom-comes-out-as-transgender-interview/" target="_blank">told <em>Pitchfork</em></a>. “Now it's time to become a whole person.”</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="slide-21" data-title="Scott Frantz" data-pos="21">
        <div class=""> <img class="owl-lazy" data-src="https://www.pride.com/sites/www.pride.com/files/2017/07/17/21-scott-frantz-ss_0.jpg" alt="Scott Frantz"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">Scott Frantz</span></div>
          <div> <p>NCAA Division I college football player Scott Frantz <a href="http://www.espn.com/college-football/story/_/id/19983391/scott-frantz-kansas-state-wildcats-details-telling-teammates-gay" target="_blank">came out as gay in an interview with ESPN in July</a>.</p>
<p><a href="https://www.outsports.com/2017/7/13/15963472/scott-frantz-kansas-state-gay" target="_blank">As <em>Outsports</em> points out</a>, he is only the third active Division I player in history to publicly come out of the closet.</p>
<p>“I’ve never felt so loved and so accepted ever in my life than when I did that,” Frantz said about his coming out. “And ever since then it’s been great. I’ve grown so much closer to my teammates since then.”</p>
</div>
        </div>
              </div>
            <div class="item" data-hash="related-slideshow" data-title="related slideshows" data-pos="22">
        <div class=""> <img class="owl-lazy" data-src="" alt="related slideshows"> </div>
                <div class="captionMobile">
          <div class="introBar"><span class="introText">related slideshows</span></div>
          <div> related slideshows</div>
        </div>
              </div>
          </div>
    <div class="gridicon"><img src="/sites/www.pride.com/modules/features/heremedia/heremedia_gallery/images/icon.gif" style="cursor:pointer;" alt=""/></div>
  </div>
    <div class="bottomStacked">
    <div class="shareSlideshowButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="http://www.pride.com/comingout/2017/7/17/21-notable-people-who-came-out-2017-so-far"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=21 Notable People Who Came Out in 2017 (So Far)&url=http://www.pride.com/comingout/2017/7/17/21-notable-people-who-came-out-2017-so-far" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=http://www.pride.com/comingout/2017/7/17/21-notable-people-who-came-out-2017-so-far&title=21 Notable People Who Came Out in 2017 (So Far)" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
      </div>
    </div>
<div id="adBottom"> <div id="dfp-ad-slideshow_leaderboard-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-slideshow_leaderboard" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-slideshow_leaderboard");
    });
  </script>
</div>
</div> </div>
<div class="tags"> <span>Tags:</span> <a href="/coming-out" class="yellow">#ComingOut</a>, <a href="/gay-celebrities" class="blue">#Celebrities</a>, <a href="/gay-entertainment" class="green">#Entertainment</a>, <a href="/gay-men" class="green">#Men</a>, <a href="/gay-guys" class="black">#Guys</a>, <a href="/women" class="blue">#Women</a>, <a href="/lgbt" class="teal">#LGBT</a> </div>
<div id="comments" class="facebookComments">
    <h5>READER COMMENTS (<fb:comments-count href='http://www.pride.com/comingout/2017/7/17/21-notable-people-who-came-out-2017-so-far'></fb:comments-count>)</h5>
    <fb:comments class="fb-comments" data-href="http://www.pride.com/comingout/2017/7/17/21-notable-people-who-came-out-2017-so-far" data-numposts="10" data-width="auto"></fb:comments>
</div>
 </div>
            <div class="spacer">&nbsp;</div>
    </div>
  </div>
</div>
<div class="deviceClass"></div>
 <script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-99s4-uKAk3J7g"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-99s4-uKAk3J7g.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>

<script type="text/javascript">
  var _sf_async_config = { uid: 9748, domain: 'pride.com'};
  _sf_async_config.path = "/comingout/2017/7/17/21-notable-people-who-came-out-2017-so-far";
  (function() {
    function loadChartbeat() {
      window._sf_endpt = (new Date()).getTime();
      var e = document.createElement('script');
      e.setAttribute('language', 'javascript');
      e.setAttribute('type', 'text/javascript');
      e.setAttribute('src','//static.chartbeat.com/js/chartbeat.js');
      document.body.appendChild(e);
    };
    var oldonload = window.onload;
    window.onload = (typeof window.onload != 'function') ?
      loadChartbeat : function() { oldonload(); loadChartbeat(); };
  })();
</script>
<div id="dfp-ad-slideshow_interstitial-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-slideshow_interstitial" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-slideshow_interstitial");
    });
  </script>
</div>
</div><script type="text/javascript" src="https://www.pride.com/sites/www.pride.com/files/js/js_My9v51QEDX9sP_DdQN-wAzes7bcmNCP6LGZGZvWn6zs.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-55c93dd3eed0db31"></script>
<script type="text/javascript" src="https://www.pride.com/sites/www.pride.com/files/js/js_3H9L5PfA1onW0O6qCBBKLS5YABXbP-XrEFbTJbjrj6A.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.fbAsyncInit = function() {
  FB.init({
    appId    :  '1660320884278138',
    xfbml    :  true,
    version  :  'v2.8'
  });
};
(function(d, s, id){
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) {return;}
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));

//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"d13870c224","applicationID":"65778905,65778872","transactionName":"NlJUMERRCBVSAk1ZWQ8YdwdCWQkIHA9WVFM+R1cDU28QD1YW","queueTime":0,"applicationTime":722,"atts":"GhVXRgxLGxs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>