<!DOCTYPE html>
<html lang="en" dir="ltr">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<meta charset="utf-8"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>These 'She-Ra' Cosplayers Got Engaged & Now We Believe in Love Again</title>
<meta name="mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-title" content="Pride">
<meta property="fb:app_id" content="1660320884278138"/>
<meta property="fb:page_id" content="858821697507267" />
<link rel="shortcut icon" sizes="152x152" href="/sites/www.pride.com/themes/pride/images/apple-touch-icon-152.jpg">
<link rel="apple-touch-icon-precomposed" href="/sites/www.pride.com/themes/pride/images/apple-touch-icon-152.jpg">
<!--[if IE]><![endif]-->
<link rel="preconnect" href="//fonts.googleapis.com" />
<link rel="dns-prefetch" href="//fonts.googleapis.com" />
<link rel="preconnect" href="//fonts.gstatic.com" crossorigin="" />
<link rel="dns-prefetch" href="//fonts.gstatic.com" />
<link rel="preconnect" href="//s7.addthis.com" />
<link rel="dns-prefetch" href="//s7.addthis.com" />
<link rel="preconnect" href="//sadmin.brightcove.com" />
<link rel="dns-prefetch" href="//sadmin.brightcove.com" />
<link rel="preconnect" href="//native.sharethrough.com" />
<link rel="dns-prefetch" href="//native.sharethrough.com" />
<link rel="preconnect" href="//cdnapisec.kaltura.com" />
<link rel="dns-prefetch" href="//cdnapisec.kaltura.com" />
<link rel="preconnect" href="//google_tag" />
<link rel="dns-prefetch" href="//google_tag" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="drupal_parsely_version" id="drupal_parsely_version" content="0.1" />
<script type="application/ld+json" content="Parsely metadata">{"@context":"http:\/\/schema.org","@type":"NewsArticle","articleId":"174061","creator":"Raffy Ermac","dateCreated":"2019-02-19T19:24:39Z","headline":"These 'She-Ra' Cosplayers Got Engaged & Now We Believe in Love Again","url":"https:\/\/www.pride.com\/geek\/2019\/2\/19\/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again","keywords":["#TV","#Entertainment","#Women","#Netflix","#Love","#Cosplay"],"articleSection":"#Geek","thumbnailUrl":"https:\/\/www.pride.com\/sites\/www.pride.com\/files\/2019\/02\/19\/she-ra-cosplayers-engagement-video.jpg"}</script>
<link rel="canonical" href="https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again" />
<link rel="shortlink" href="/node/174061" />
<link rel="shortcut icon" href="https://www.pride.com/sites/www.pride.com/themes/pride/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="amphtml" href="https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again?amp" />
<script type="text/javascript">dataLayer = [{"drupalLanguage":"en","drupalCountry":"US","heremediaAuthor":"Raffy Ermac","heremediaContributor":"Raffy Ermac","heremediaContentType":"article","entityLanguage":"und","entityTnid":"0","entityVid":"349421","entityName":"Raffy Ermac","entityUid":"10711","entityCreated":"1550604279","entityStatus":"1","entityType":"node","entityBundle":"article","entityId":"174061","entityLabel":"These \u0027She-Ra\u0027 Cosplayers Got Engaged \u0026 Now We Believe in Love Again","userUid":0}];</script>
<meta property="fb:pages" content="858821697507267" />
<meta name="description" content="WHO&#039;S CUTTING ONIONS IN HERE??!" />
<script type="text/javascript">

//load GPT library here
(function () {
  var gads = document.createElement('script');
  gads.async = true;
  gads.type = 'text/javascript';
  var useSSL = 'https:' == document.location.protocol;
  gads.src = (useSSL ? 'https:' : 'http:') +
    '//www.googletagservices.com/tag/js/gpt.js';
  var node = document.getElementsByTagName('script')[0];
  node.parentNode.insertBefore(gads, node);
})();

var referrer = 'none';
if (document.referrer) {
  url = document.referrer;
  referrer = url.match(/:\/\/(.[^/]+)/)[1];
}

var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};
var browser_width= window.innerWidth && document.documentElement.clientWidth ? Math.min(window.innerWidth, document.documentElement.clientWidth) : window.innerWidth || document.documentElement.clientWidth || document.getElementsByTagName('body')[0].clientWidth;



googletag.cmd.push(function () {

var mapping = googletag.sizeMapping()
  .addSize([1, 1], [320, 50])
  .addSize([481, 1], [320, 50])
  .addSize([768, 1], [[728, 90], [970, 90], [970, 60], [970, 66]])
  .addSize([992, 1], [[728, 90], [970, 250], [970, 90], [970, 60], [970, 66]])
  .build();
googletag.slots["article_leaderboard"] = googletag.defineSlot("/6850/here.pride/article/leaderboard", [[728, 90], [970, 250], [970, 90], [970, 60], [970, 66]], "dfp-ad-article_leaderboard")
  .addService(googletag.pubads())
  .setTargeting("pos", ["top"])
  .defineSizeMapping(mapping);

var mapping = googletag.sizeMapping()
  .addSize([1, 1], [300, 250])
  .addSize([481, 1], [300, 250])
  .addSize([768, 1], [[300, 250], [300, 600]])
  .addSize([992, 1], [[300, 250], [300, 600]])
  .build();
googletag.slots["article_bigbox_top"] = googletag.defineSlot("/6850/here.pride/article/bigbox_top", [[300, 250], [300, 600]], "dfp-ad-article_bigbox_top")
  .addService(googletag.pubads())
  .setTargeting("pos", ["top"])
  .defineSizeMapping(mapping);

var mapping = googletag.sizeMapping()
  .addSize([1, 1], [[300, 250], [300, 600]])
  .addSize([481, 1], [[300, 250], [300, 600]])
  .addSize([768, 1], [[300, 250], [300, 600]])
  .addSize([992, 1], [[300, 250], [300, 600]])
  .build();
googletag.slots["article_bigbox_mid"] = googletag.defineSlot("/6850/here.pride/article/bigbox_mid", [[300, 250], [300, 600]], "dfp-ad-article_bigbox_mid")
  .addService(googletag.pubads())
  .setTargeting("pos", ["right"])
  .defineSizeMapping(mapping);

var mapping = googletag.sizeMapping()
  .addSize([1, 1], [300, 250])
  .addSize([481, 1], [300, 250])
  .addSize([768, 1], [300, 250])
  .addSize([992, 1], [300, 250])
  .build();
googletag.slots["article_native_1"] = googletag.defineSlot("/6850/here.pride/article/native_1", [300, 250], "dfp-ad-article_native_1")
  .addService(googletag.pubads())
  .setTargeting("strnativekey", ["AWP3MqHxX6qAGRWkMfmsZPRU"])
  .defineSizeMapping(mapping);

var mapping = googletag.sizeMapping()
  .addSize([1, 1], [300, 250])
  .addSize([481, 1], [300, 250])
  .addSize([768, 1], [300, 250])
  .addSize([992, 1], [300, 250])
  .build();
googletag.slots["article_native_2"] = googletag.defineSlot("/6850/here.pride/article/native_2", [300, 250], "dfp-ad-article_native_2")
  .addService(googletag.pubads())
  .setTargeting("strnativekey", ["z6pvBvUykfio1XprLeot2ELq"])
  .defineSizeMapping(mapping);

var mapping = googletag.sizeMapping()
  .addSize([1, 1], [[300, 250], [300, 600]])
  .addSize([481, 1], [[300, 250], [300, 600]])
  .addSize([768, 1], [[300, 250], [300, 600]])
  .addSize([992, 1], [[300, 250], [300, 600]])
  .build();
googletag.slots["article_latest_initial_right"] = googletag.defineSlot("/6850/here.pride/article/latest_initial_right", [[300, 250], [300, 600]], "dfp-ad-article_latest_initial_right")
  .addService(googletag.pubads())
  .setTargeting("strnativekey", ["4hfR4LYaESek6Jkg9KsTRArx"])
  .defineSizeMapping(mapping);

var mapping = googletag.sizeMapping()
  .addSize([1, 1], [[300, 600], [300, 250]])
  .addSize([481, 1], [[300, 600], [300, 250]])
  .addSize([768, 1], [[300, 600], [300, 250]])
  .addSize([992, 1], [[300, 600], [300, 250]])
  .build();
googletag.slots["article_latest_initial_left"] = googletag.defineSlot("/6850/here.pride/article/latest_initial_left", [[300, 600], [300, 250]], "dfp-ad-article_latest_initial_left")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);

  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
  googletag.pubads().setTargeting("referrer",referrer);

  googletag.pubads().setTargeting("cat", ["geek","tv","entertainment","women","netflix","love","cosplay"]);
  googletag.pubads().setTargeting("title", ["these_she_ra_cosplayers_got_engaged_now_we_believe_love_again"]);
  googletag.pubads().setTargeting("aid", ["174061"]);
  googletag.enableServices();

});
</script><meta property="og:type" content="article" />
<meta property="og:url" content="https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again" />
<meta property="og:title" content="These &#039;She-Ra&#039; Cosplayers Got Engaged &amp; Now We Believe in Love Again" />
<meta property="og:updated_time" content="2019-02-19T14:28:12-05:00" />
<meta property="og:image" content="https://www.pride.com/sites/www.pride.com/files/2019/02/19/she-ra-cosplayers-engagement-video.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="TheAdvocateMag" />
<meta name="twitter:site:id" content="21692297" />
<meta name="twitter:creator" content="pride_site" />
<meta name="twitter:creator:id" content="21692297" />
<meta name="twitter:title" content="These &#039;She-Ra&#039; Cosplayers Got Engaged &amp; Now We Believe in Love Again" />
<meta name="twitter:description" content="WHO&#039;S CUTTING ONIONS IN HERE??!" />
<meta property="article:published_time" content="2019-02-19T14:24:39-05:00" />
<meta property="article:modified_time" content="2019-02-19T14:24:39-05:00" />
<script type="application/ld+json">{ "@context": "http://schema.org", "@type": "NewsArticle", "mainEntityOfPage": "https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again", "headline": "These 'She-Ra' Cosplayers Got Engaged & Now We Believe in Love Again", "image": {  "@type": "ImageObject",  "url": "https://www.pride.com/sites/www.pride.com/files/styles/amp_metadata_content_image_min_696px_wide/public/2019/02/19/she-ra-cosplayers-engagement-video.jpg?itok=kJOSt95I",  "width": "696",  "height": "392" }, "datePublished": "2019-02-19T14:24:39-05:00", "dateModified": "2019-02-19T14:28:12-05:00", "author": {  "@type": "Person",  "name": "Raffy Ermac" }, "publisher": {  "@type": "Organization",  "name": "PRIDE.com",  "logo": {  "@type": "ImageObject",  "url": "https://www.pride.com/sites/www.pride.com/files/styles/amp_metadata_logo_600x60/public/2017/07/20/prideamplogo.gif?itok=0wkRXwik",  "width": "178",  "height": "60"  } }, "description": "WHO'S CUTTING ONIONS IN HERE??!", "articleBody": "Sometimes it's nice to take a break from all of the bad, shitty news that's going on in the world and focus our energies on things that spark joy—like this incredibly adorable video of two She-Ra cosplayers getting engaged!When your otp gets engaged for real @radicalkev @guilianf congratulations to the beautiful couple! pic.twitter.com/HzePS38AVF— HAPPY TURKEY (@omystephanie) February 15, 2019It all happened over the weekend at Katsucon (an annual anime and pop culture convention held in Washington, D.C.) when cosplayer Guilian, who was dressed as the titular hero from Netflix's super-queer animated series She-Ra and the Princesses of Power, popped the question to their partner Kevin, who was cosplaying She-Ra's best friend turned rival Catra.\"I finally got to ask the girl of my dreams to be my wife,\" Guilian captioned in an Instagram post about their proposal. \"I’ve been waiting so so long to ask her and this was the perfect moment. Thank you to everyone who made this special moment possible.\"    View this post on Instagram         I finally got to ask the girl of my dreams to be my wife. I’ve been waiting so so long to ask her and this was the perfect moment. Thank you to everyone who made this special moment possible. If you got a video or picture PLEASE send it my way! Picture taken by: @bakamonocosplay Big big forever thank you to @k2_cosplay @ollie.opm @allthesedangpancakes @etoile_ami @bakamonocosplay @kineticcosplay @ann_mossy @kellykirstein And everyone who has been so supportive of us. Thank you! #katsuconproposal #sheracosplay #adoracosplay #shera #katsucon #katsu #propsal #catracosplay #catra #catradoraA post shared by Guilian Cosplay (@guilianf) on Feb 15, 2019 at 3:10pm PSTAt the time of reporting, the video of Guilian and Kevin's proposal that a friend of theirs posted on Twitter had over 24,000+ likes! And their viral proposal even got the attention of She-Ra and the Princesses of Power creator/showrunner Noelle Stevenson!hello i am fully crying https://t.co/x5ocicTAzL— Noelle Stevenson (@Gingerhazing) February 15, 2019Do you hear that? That's the sound of our cold, icy hearts melting and believing in love again!!" }</script>


<!-- GetAdmiral script -->
<script>(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//receptivereaction.com/246200ca9b0a6c2082693d0b6f9d0d3faa93d66923a64fefba653f0f1d8cbcd6ea34d6d4428372734c77ff1116424000bef2e6d806a1d06d5e31157b2831');</script>
<!-- End GetAdmiral script -->
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__yp4wzhxWjCW7duExKmwTE_soNWIAKtY1LPypusgc7-Q__xQyxBKEvS2NwelE5CaPCOB6a2WZUL8As57akp8cKdYk__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__Uro0xdUVSImgiJmrjrHq6zMlE71uYJi5DWE640XkT7c__hG-bFXEfy_6ZwPpLQjNJaRgaaSKpIY0p2SaD6zrPp7k__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__1Z7wgD4v7w888uvVOUY6ALD6JKpBdv9EIJLSV4a6Ehk__tO9YvajbEy2vlJoYbyathoSDikw0V77dZppjEkf8EXE__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__rxlkNswgFNTxNaSPriAIXx4ZlwBOB3RlBPezSG6R9_M__VHgdJ4r9tHl_YrvPjndJ9qh877SF9D0BV0kuzFGik7Y__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__54MFi8FkyGaHGYd5ZdzyudsaptrAaR6nC8-2d5gRGIE__DZHVtZ9vnQ_nAfnDj-ZCEzijsy9gIMMi5lXK_gmq84c__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__UjpsJAPU8laR8ahZaR7mDTrTIbEUfx6ojtntXO4DDMg__XzxbfvF62JIagzPQvJTYUOB8YCyfSpjpBIo6Rw5I9Lo__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__QIsY78ejFUWd8_1WhPPUQqmlhBp10Tco4VOz-PcKrkI__B17CN2p8y9_5NI_q_duUIjYzJaZyaT1gKiLbRN3Cjsg__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__MuoIiho4tXsD6GNyCC5loToVJ2DU7Ury3W9OL-q0MYI__Zd1Th3FyAzZMsKET3nZSYW5geMB7PSo5Gx_wJsdYz48__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__Irf_gwb-Pq8mHOWu1TP1HcgM0-G_n2aM6hh2T7HrP9w__wq2cMTqH2xzpUaajNK-ntVjmRA-Umb0bp3Uq5h5tINo__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__kg7S0dNHB51gTPALGAOAOThnISlBjTi_y7Sso2n2qOg__BTWp3W9drSse25DdWVDqOTveyoc3yVq9LWdACeGI4Aw__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__DJVWsB9CJVs_1IGdy-_cGuq4r6SVVaWbEnbS1U2p6y4__7g40UeM74r8hkrzDC6Hbb7RReIGNu-Jsb5XAbAPKIeA__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__ULnubjQ_PipfFUoQ3i8sGypunPrRy8Yp89AwoPlLNmA__KTo3VYwHPlf_TtmVRdgXiFZnCEbjf003cfm1XS_7u4Y__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__vXQUIHBaPKzn0YE4Q1zri2zxOtg4y052f5YxcvkiF6k__aOGajsb_n0AkZXXPuM6YDMsvswMRVjyHQKmMblT0hew__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat:400,700|Open+Sans+Condensed:300,700italic,700" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__fXEh4RTH6o0M2OCyxrtqP4HT-RvznJIrEN5Na7EG-Ik__HPeUpOXeHYk5iQgi5fRH02AaV-X6seRbrZMb5kXZrpQ__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/www.pride.com/files/advagg_css/css__oTGO7wpfsjLCM4Y8aVBVfqT1bKiHHLPuNn1LQnmE0Do__axElAHA9-0cKY6aIEqyLVtzmyc5DmTWMO-DwKyGR4CA__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.css" media="all" />
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__SlxZR0T0y0knhPGspoKKlEQqbk_RdNNsHwLrlCQRTSo__J-uYUEz5R6JBvrH_XB90DPHvh4o7_ckJSz2wp2rnC5o__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__gpBHymPy0cZtGflAX-HtnXpqjdz3SFOq1ifLomZkVgI__dpraG3ksIfWtSoV_HQmrLzw-0oyXIBaj27mKny_LovU__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.migrateMute=true;jQuery.migrateTrace=false;
//--><!]]>
</script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__AcENBly4RrRAWynwaclo1QKy_CXPwJLXHacQhjHGi8c__XOQX-DnFmBt30PfpR-N47XlN0TWxBQe1cb1aBIebUDg__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__P3ER6aBJWRT0gwCuCwxJJBGcRpyoPxvBTwmExELajfg__6lirxbTdH7loCG7BGjvM9lYACQY3pzS-55Nwvn6e3jo__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__3vwOA0BwlnyBkt9H4CLg6FgNyKAh--OmfOxFOIu_5S4__14jAFRiS2WG9seuuVvkrazGaW7kLmmXyNFKpx92Mnko__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__dcZDfpBdRmjCW0vKa_r5K07i0bhzXpAke8IwZrpL92Y__xruSkbHzxgPSpx1WPgV8Fv4M2ONWi_CbIi779Jl3wfM__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__Yt2TC25ehjkPkDpceDvjwjGS1DVmERyW-tCCyHZ5Ghc__HzE-QbtLcixyNVqwE9YVhk_AG-nXU5P7e_4rS7OlfxM__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__7AdtCxnod_LOQv_mGNSoVjH5Rc2C1UGwxGbVZztRPXc__Etsk9U9CSk2Nx0FMB2lpSupX5DnvH0wTelINAYToORo__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__FwyyYi5YU4GK-uIFJv754po_NHyXgQxhrUIDQptKq10__zqbUy6oe0EBhlBW_evb6YBSL__cBLwLb9eH7aO7tGPg__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="//cdnapisec.kaltura.com/p/2197371/sp/219737100/embedIframeJs/uiconf_id/37028752/partner_id/2197371"></script>
<script type="text/javascript" src="//cdnapisec.kaltura.com/p/2197371/sp/219737100/embedIframeJs/uiconf_id/37493671/partner_id/2197371"></script>
<script type="text/javascript" src="//cdnapisec.kaltura.com/p/2197371/sp/219737100/embedIframeJs/uiconf_id/37658961/partner_id/2197371"></script>
<script type="text/javascript" src="//cdnapisec.kaltura.com/p/2197371/sp/219737100/embedIframeJs/uiconf_id/41167732/partner_id/2197371"></script>
<script type="text/javascript" src="//cdnapisec.kaltura.com/p/2197371/sp/219737100/embedIframeJs/uiconf_id/41087642/partner_id/2197371"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__tQ0kheEdx0pmH0iWtgDATpayuZ88pMGy_K9nDhp7TmU__5FUn2G9VaWiJa7Wi7Uc3YnPQH3UZM0T3yEX2Ka-ZJWA__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="https://sadmin.brightcove.com/js/BrightcoveExperiences.js"></script>
<script type="text/javascript" src="//native.sharethrough.com/assets/tag.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var addthis_share = { url: "http://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again" }
//--><!]]>
</script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__Tf-78NpoVoLlLaIMdFd4t-zj2WpBD71T_6QZ95etiGk__aAB7ynASdOCrMltPnfPuB7BO5GCisjBTWt1yr1Ag4_8__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var this_site=window.location.hostname.split(".");this_site=this_site[this_site.length-2];var sites={advocate:{pageID:13011},out:{pageID:13016},pride:{pageID:13047},outtraveler:{pageID:13022},hivplusmag:{pageID:13037},chill:{pageID:80857}},site_ttf=sites[this_site];(function(d,p){var js,s=d.getElementsByTagName('script')[0];js=d.createElement('script');js.async=true;js.defer=true;js.setAttribute("class","teads");js.src='//a.teads.tv/page/'+p+'/tag';s.parentNode.insertBefore(js,s)})(window.document,site_ttf.pageID);
//--><!]]>
</script>
<script type="text/javascript" src="https://cdnapisec.kaltura.com/p/2197371/sp/219737100/embedIframeJs/uiconf_id/37028752/partner_id/2197371"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__eZU2j1BNsp_jBUWhrUXPY31KbSTg7_oLmO0sU8lNeDY__V2_qhRZSGNcxlBV1RynyOlSM8PdWaBkO6M81VT7t6X4__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__N4I1jI78C3jZzG7pXOuRhV8PUtFKcPPvNYI53M5_NPw__hXrAQjLUiv4fowC2-Z7NbHFgVe7a8i39x5Eebzt9X1Y__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__yna7vlWFxyPZD0H7NXK-cSRvCYO9321VyDTbyotgiRI__o9RYDIBT2zq4_HXgHHtk1DRgtiBcx385XwhxpnEpROg__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript">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</script>
<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!--[if lt IE 9]>
    <script src="/sites/www.pride.com/themes/pride/js/html5shiv.js"></script>
    <script src="/sites/www.pride.com/themes/pride/js/respond.js"></script>
  <![endif]-->
<script type="text/javascript">
    setTimeout(function(){var a=document.createElement("script");
        var b=document.getElementsByTagName("script")[0];
        a.src=document.location.protocol+"//script.crazyegg.com/pages/scripts/0050/6735.js?"+Math.floor(new Date().getTime()/3600000);
        a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
</script>
  <!-- Start Cookie Consent -->
  <link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.css" />
  <script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.js"></script>
  <script>
    window.addEventListener("load", function(){
      window.cookieconsent.initialise({
        "palette": {
          "popup": {
            "background": "#000000",
            "text": "#ffffff"
          },
          "button": {
            "background": "#980000",
            "text": "#ffffff"
          }
        },
        "content": {
          "message": "By continuing to use our site, you agree to our <a href=\"https://www.pridemedia.com/privacy-policy\" target=\"_blank\" class=\"cc-link\">Private Policy</a> and",
          "dismiss": "Accept",
          "link": "Terms of Use.",
          "href": "https://www.pridemedia.com/terms-of-use"
        }
      })});
  </script>
  <!-- End Cookie Consent -->
  <!-- Facebook Pixel Code Old-->
  <script>
    !function (f, b, e, v, n, t, s) {
      if (f.fbq) return;
      n = f.fbq = function () {
        n.callMethod ?
          n.callMethod.apply(n, arguments) : n.queue.push(arguments)
      };
      if (!f._fbq) f._fbq = n;
      n.push = n;
      n.loaded = !0;
      n.version = '2.0';
      n.queue = [];
      t = b.createElement(e);
      t.async = !0;
      t.src = v;
      s = b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t, s)
    }(window,
      document, 'script', 'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1586530151593576');
    fbq('track', "PageView");
  </script>
  <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1586530151593576&ev=PageView&noscript=1"/></noscript>
  <!-- End Facebook Pixel Code -->
  <!-- Facebook Pixel Code -->
  <script>
    !function (f, b, e, v, n, t, s) {
      if (f.fbq) return;
      n = f.fbq = function () {
        n.callMethod ?
          n.callMethod.apply(n, arguments) : n.queue.push(arguments)
      };
      if (!f._fbq) f._fbq = n;
      n.push = n;
      n.loaded = !0;
      n.version = '2.0';
      n.queue = [];
      t = b.createElement(e);
      t.async = !0;
      t.src = v;
      s = b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t, s)
    }(window, document, 'script',
      'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '259124211325942');
    fbq('track', 'PageView');
  </script>
  <noscript><img height="1" width="1" src="https://www.facebook.com/tr?id=259124211325942&ev=PageView&noscript=1"/></noscript>
  <!-- End Facebook Pixel Code -->
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-174061 node-type-article"  >
<noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-K5RNFPW" height="0" width="0" style="display:none;visibility:hidden" title="Google Tag Manager">Google Tag Manager</iframe></noscript> <div class="navmenu navmenu-default navmenu-fixed-left offcanvas"> <ul class="nav navmenu-nav out"><li class="0 first"><a href="/identities">#Identities</a></li>
<li class="1"><a href="/style">#Style</a></li>
<li class="2"><a href="/taxonomy/term/15101/">#GoingOut</a></li>
<li class="3"><a href="/gay-celebrities">#Celebs</a></li>
<li class="4"><a href="/gay-music">#Music</a></li>
<li class="5"><a href="/money">#Money</a></li>
<li class="6"><a href="/gay-travel">#Travel</a></li>
<li class="7"><a href="/hiv">#HIV</a></li>
<li class="8 last"><a href="/first-person">#FirstPerson</a></li>
</ul><ul class="nav navmenu-nav sites"><li class="0 first"><a href="https://www.advocate.com" target="_blank">Advocate</a></li>
<li class="1"><a href="https://www.out.com" target="_blank">Out</a></li>
<li class="2"><a href="https://www.chill.us/" target="_blank">Chill.us</a></li>
<li class="3"><a href="https://www.outtraveler.com" target="_blank">Out Traveler</a></li>
<li class="4 last"><a href="https://www.hivplusmag.com" target="_blank">Plus</a></li>
</ul><ul class="nav navmenu-nav order"><li class="0 first"><a href="https://subscribe.herepublishing.com/" target="_blank">Subscribe</a></li>
<li class="1"><a href="https://service.qfie.com/HERE/clsOUTLookup.asp?strAspReason=106&amp;strLookFormControl=1" target="_blank">Subscriber Services</a></li>
<li class="2 last"><a href="/signup" class="order">Email Newsletter Signup</a></li>
</ul><ul class="nav navmenu-nav terms"><li class="0 first"><a href="/contact">Contact</a></li>
<li class="1"><a href="https://www.pridemedia.com/careers/" target="_blank">Career Opportunities</a></li>
<li class="2"><a href="https://www.pridemedia.com/sales/" target="_blank">Advertise With Us</a></li>
<li class="3"><a href="https://www.pridemedia.com/privacy-policy" target="_blank">Privacy Policy</a></li>
<li class="4"><a href="https://www.pridemedia.com/terms-of-use" target="_blank">Terms of Use</a></li>
<li class="5 last"><a href="https://www.pridemedia.com/legal-notice" target="_blank">Legal Notice</a></li>
</ul>  <ul class="nav navmenu-nav copyright">
    <li>&copy; 2019 Here Publishing Inc.<br>
      All Rights Reserved
    </li>
  </ul>
</div>
<div class="desktopHeader">
  <div class="container topHeader">
    <div class="magazines">
          </div>
    <div class="navbar navbar-default">
      <button type="button" class="navbar-toggle" data-toggle="offcanvas" data-target=".navmenu" data-canvas="body">
        <span class="icon-bar"></span> <span class="icon-bar"></span>
        <span class="icon-bar"></span></button>
      <div class="topLogoHeader"><a href="/">
          <img src="https://www.pride.com/sites/www.pride.com/themes/pride/logo.png" class="mainLogo" alt="">
                      <img src="/sites/www.pride.com/themes/pride/images/pride-mobile.svg" class="mobileLogo" style="display:none;" alt="PRIDE">
                  </a></div>
    </div>
    <div class="expand-trending">
      <a class="icon-flame collapsed" href="#"><img src="/sites/www.pride.com/themes/pride/images/pride-logo-icon.gif" alt="Pride Expand"></a>
    </div>
    <div class="socialButtons">
      <ul class="socialList">
        <li class="searchBox">
          <a href="javascript: void(0);"><img src="/sites/www.pride.com/themes/pride/images/social-search.svg" width="29" height="20" alt="Search" class="search">
          </a>
          <div class="searchForm"> <form action="/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-ywGElGWq3ytyY_sQnrWmKBGjL3bdOnuPZJbpHm17-Rs" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form> </div>
        </li>
        <li class="fbButton">
          <a href="https://www.facebook.com/pridesite" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-facebook.gif" width="29" height="20" alt="Facebook"></a>
        </li>
        <li class="twButton">
          <a href="https://twitter.com/pride_site" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-twitter.gif" width="29" height="20" alt="Twitter"></a>
        </li>
        <li class="instaButton">
          <a href="https://www.instagram.com/pride_site/" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-instagram.gif" width="29" height="20" alt="Instagram"></a>
        </li>
        <li class="tumblrButton">
          <a href="http://pridesite.tumblr.com/" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-tumblr.gif" width="29" height="20" alt="Tumblr"></a>
        </li>
        <li class="youtubeButton">
          <a href="https://www.youtube.com/channel/UCCB-yLpR8jydfUM9rquJcnA" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-youtube.gif" width="29" height="20" alt="YouTube"></a>
        </li>
        <li class="mailButton">
          <a href="/signup"><img src="/sites/www.pride.com/themes/pride/images/social-mail.gif" width="29" height="20" alt="Mail"></a>
        </li>
      </ul>
    </div>
  </div>
  <div class="band">
    <div class="container">
      <!--TREND NAV BAR-->
      <div class="trendBar">
  <ul>
    <li class="trend"><span>Editor's Pick</span></li>
        <li id="" class="teal" style=""> <a href="/gay-activist">#Activism</a> </li>
        <li id="" class="orange" style=""> <a href="/gay-tv">#TV</a> </li>
        <li id="" class="yellow" style=""> <a href="/geek">#Geek</a> </li>
        <li id="" class="purple" style=""> <a href="/gay-music">#Music</a> </li>
        <li id="" class="red" style=""> <a href="/gay-movies">#Movies</a> </li>
        <li id="" class="blue" style=""> <a href="/commyounity">#CommYOUnity</a> </li>
        <li id="" class="teal" style=""> <a href="/politics">#Politics</a> </li>
        <li id="" class="orange" style=""> <a href="/identities">#Identities</a> </li>
      </ul>
</div>

 </div>
  </div>
</div>
<div class="container adWindow">
      <div class="leaderboard">    <div id="block-heremedia-ads-article-leaderboard" class="block block-heremedia-ads">

      
  <div class="content">
    <div id="dfp-ad-article_leaderboard-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_leaderboard" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_leaderboard");
    });
  </script>
</div>
</div>  </div>
</div>
 </div>
  </div>
<div class="trendbar-overlay" style="display:none;">
  <ul>
  </ul>
</div>
<div id="body-inner" class="container"><a href="#" class="scrollToTop"></a>
  <div class="row">
    <div class="col-xs-12 col-sm-12 col-md-12">                           <div class="tabs"></div>
                          <div class="page articleDetailSection" >
          <div class="row">
            <div class="col-md-8 col-sm-12 col-xs-12">    <div class="articleStatus node node-article yellow">
  <div class="articleCategory"><a href="/geek">#Geek</a></div>
    <h1 class="articleTitle"><p>These <em>She-Ra</em> Cosplayers Got Engaged &amp; Now We Believe in Love Again</p>
</h1>
  <div class="leadImageArticle">
    <div class="articleImg ">
            <img src="https://www.pride.com/sites/www.pride.com/files/2019/02/19/she-ra-cosplayers-engagement-video.jpg" alt="she-ra-cosplayers-engagement-video.jpg" title="These She-Ra Cosplayers Got Engaged &amp;amp; Now We Believe in Love Again
" />    </div>
        <div class="authorBox">
      <div class="box">
                        <div class="articleTeaser"><p>WHO'S CUTTING ONIONS IN HERE??!</p>
</div>
                <div class="articledivder"></div>
                <div class="authorAvatar"> <a href="/authors/raffy-ermac"><img src="https://www.pride.com/sites/www.pride.com/files/2018/03/18/raffy-ermac-headshot-2018-v2.jpg" alt="Raffy Ermac" title="Raffy Ermac" /></a> </div>
                <div class="articleAuthor"> By <span><a href="/authors/raffy-ermac">Raffy Ermac</a></span>
                    <span class="twitter-handle"> <a href="https://twitter.com/byraffy">@byraffy</a> </span>
                  </div>
        <div class="articleDate"> <span class="date">February 19 2019 2:24 PM EST</span>
                  </div>
      </div>
    </div>
  </div>
    <div class="shareArticleButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=These+%27She-Ra%27+Cosplayers+Got+Engaged+%26+Now+We+Believe+in+Love+Again&url=https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again&title=These+%27She-Ra%27+Cosplayers+Got+Engaged+%26+Now+We+Believe+in+Love+Again" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
    <div class="textArticle" id="article-content"> <p>Sometimes it's nice to take a break from all of the bad, shitty news that's going on in the world and focus our energies on things that spark joy—like this incredibly adorable video of two <a href="https://www.pride.com/geek/2018/10/05/yup-new-she-ra-reboot-will-have-lgbt-characters-it" target="_blank"><em>She-Ra</em></a> cosplayers getting engaged!</p>
<blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en" xml:lang="en">When your otp gets engaged for real @radicalkev <a href="https://twitter.com/GuilianF?ref_src=twsrc%5Etfw">@guilianf</a> congratulations to the beautiful couple! <a href="https://t.co/HzePS38AVF">pic.twitter.com/HzePS38AVF</a></p>
<p>— HAPPY TURKEY (@omystephanie) <a href="https://twitter.com/omystephanie/status/1096516437684965376?ref_src=twsrc%5Etfw">February 15, 2019</a></p></blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p>It all happened over the weekend at <a href="https://www.katsucon.org/" target="_blank">Katsucon</a> (an annual anime and pop culture convention held in Washington, D.C.) when cosplayer <a href="https://www.instagram.com/guilianf/" target="_blank">Guilian</a>, who was dressed as the titular hero from Netflix's <a href="https://www.pride.com/geek/2018/12/19/13-geeky-af-lgbt-shows-you-can-stream-right-now#media-gallery-media-4" target="_blank">super-queer</a> animated series <a href="https://www.netflix.com/title/80179762" target="_blank"><em>She-Ra and the Princesses of Power</em></a>, popped the question to their partner <a href="https://www.instagram.com/radicalkev/" target="_blank">Kevin</a>, who was cosplaying She-Ra's best friend turned rival Catra.</p>
<p>"I finally got to ask the girl of my dreams to be my wife," Guilian captioned in an Instagram post about their proposal. "I’ve been waiting so so long to ask her and this was the perfect moment. Thank you to everyone who made this special moment possible."</p>
<blockquote class="instagram-media" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/Bt654mfAQOL/?utm_source=ig_embed&amp;utm_medium=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:540px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;">
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"> </div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"> </div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"> </div>
</div>
</div>
<div style="padding: 19% 0;"> </div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><a href="https://www.instagram.com/p/Bt654mfAQOL/?utm_source=ig_embed&amp;utm_medium=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><svg height="50px" version="1.1" viewbox="0 0 60 60" width="50px" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g fill="none" fill-rule="evenodd" stroke="none" stroke-width="1"><g fill="#000000" transform="translate(-511.000000, -20.000000)"><g><br /><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></a></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"><a href="https://www.instagram.com/p/Bt654mfAQOL/?utm_source=ig_embed&amp;utm_medium=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank">View this post on Instagram</a></div>
</div>
<div style="padding: 12.5% 0;"> </div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"> </div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"> </div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"> </div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"> </div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"> </div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"> </div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"> </div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"> </div>
</div>
</div>
<p style=" margin:8px 0 0 0; padding:0 4px;"><a href="https://www.instagram.com/p/Bt654mfAQOL/?utm_source=ig_embed&amp;utm_medium=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">I finally got to ask the girl of my dreams to be my wife. I’ve been waiting so so long to ask her and this was the perfect moment. Thank you to everyone who made this special moment possible. If you got a video or picture PLEASE send it my way! Picture taken by: @bakamonocosplay Big big forever thank you to @k2_cosplay @ollie.opm @allthesedangpancakes @etoile_ami @bakamonocosplay @kineticcosplay @ann_mossy @kellykirstein And everyone who has been so supportive of us. Thank you! #katsuconproposal #sheracosplay #adoracosplay #shera #katsucon #katsu #propsal #catracosplay #catra #catradora</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/guilianf/?utm_source=ig_embed&amp;utm_medium=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Guilian Cosplay</a> (@guilianf) on <time datetime="2019-02-15T23:10:44+00:00" style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;">Feb 15, 2019 at 3:10pm PST</time></p>
</div>
</blockquote>
<script async="" src="//www.instagram.com/embed.js"></script><p>At the time of reporting, the video of Guilian and Kevin's proposal that a friend of theirs posted on Twitter had over 24,000+ likes! And their viral proposal even got the attention of <em>She-Ra and the Princesses of Power</em> creator/showrunner Noelle Stevenson!</p>
<blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en" xml:lang="en">hello i am fully crying <a href="https://t.co/x5ocicTAzL">https://t.co/x5ocicTAzL</a></p>
<p>— Noelle Stevenson (@Gingerhazing) <a href="https://twitter.com/Gingerhazing/status/1096552008750755840?ref_src=twsrc%5Etfw">February 15, 2019</a></p></blockquote>
<p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Do you hear that? That's the sound of our cold, icy hearts melting and believing in love again!!</p>
<p><iframe allowfullscreen="" class="giphy-embed" frameborder="0" height="362" src="https://giphy.com/embed/IsvH45UsLv6AU" width="480"></iframe></p>
      </div>
</div>

<div class="tags"> <span>Tags:</span> <a href="/geek" class="yellow">#Geek</a>, <a href="/gay-tv" class="orange">#TV</a>, <a href="/gay-entertainment" class="green">#Entertainment</a>, <a href="/women" class="blue">#Women</a>, <a href="/netflix" class="green">#Netflix</a>, <a href="/gay-love" class="red">#Love</a>, <a href="/cosplay" class="green">#Cosplay</a> </div>

<h2 class="col-xs-12 ourSponsors">
  <span>From our Sponsors</span>
</h2>
<div class="row nativeCustomAds">
  <div class="col-md-6 col-sm-6 col-xs-12">
    <div id="dfp-ad-article_native_1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_native_1" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_native_1");
    });
  </script>
</div>
</div>  </div>
  <div class="col-md-6 col-sm-6 col-xs-12">
    <div id="dfp-ad-article_native_2-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_native_2" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_native_2");
    });
  </script>
</div>
</div>  </div>
</div>

    <div class="pubexchange_module" id="pubexchange_below_content" data-pubexchange-module-id="2849"></div>



<div id="comments" class="facebookComments">
    <h5>READER COMMENTS (<fb:comments-count href='https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again'></fb:comments-count>)</h5>
    <fb:comments class="fb-comments" data-href="https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again" data-numposts="10" data-width="auto"></fb:comments>
</div>
 </div>
            <div class="col-md-4 col-sm-12 col-xs-12">    <div id="block-heremedia-ads-article-bigbox-top" class="block block-heremedia-ads">

      
  <div class="content">
    <div id="dfp-ad-article_bigbox_top-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_bigbox_top" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_bigbox_top");
    });
  </script>
</div>
</div>  </div>
</div>
<div id="block-bean-single-video-embed" class="block block-bean">

    
  <div class="content">
    <div class="entity entity-bean bean-video-embed clearfix">
        <div class="content">
    <div class="field field-name-field-kaltura-video field-type-heremedia-kaltura-field field-label-hidden"><div class="field-items"><div class="field-item even"><div class="title"></div>
<div class="videoWrapper">
  <div id="kaltura_player_0_2xbalhhv" style="width: 750px; height: 421px;">&nbsp;</div>
  <script>
    kWidget.embed({
      "targetId": "kaltura_player_0_2xbalhhv",
      "wid": "_2197371",
      "uiconf_id": 37028752,
      "flashvars": {
                "doubleClick": {
          "plugin": true,
          "adTagUrl": "https://pubads.g.doubleclick.net/gampad/ads?sz=480x360|640x480&iu=/6850/here.pride/video/rightrail_player&impl=s&gdfp_req=1&env=vp&output=vast&unviewed_position_start=1&url=[referrer_url]&description_url={utility.referrer_url}&correlator=[timestamp]&cust_params=cat%3Dgeek%2Ctv%2Centertainment%2Cwomen%2Cnetflix%2Clove%2Ccosplay%26title%3Dthese_she_ra_cosplayers_got_engaged_now_we_believe_love_again%26aid%3D174061&cmsid=4285&vid={mediaProxy.entry.id}",
          "leadWithFlash": false,
          "disableCompanionAds": true,
          "debugMode": false
        },
                        "googleAnalytics": {
          "plugin": true,
          "position": "before",
          "urchinCode": "UA-4789315-22",
          "trackEventMonitor": "trackFunc",
          "customEvent": "doPlay,relatedVideoSelect,playerReady,NoSourcesCustomError,bufferEndEvent,mediaError,embedPlayerError",
          "trackingCategory": "Kaltura Video Events",
          "optionalLabel": "{mediaProxy.entry.referenceId}|{mediaProxy.entry.name}|{mediaProxy.entry.id}|{configProxy.kw.id}|{configProxy.kw.uiConfId}",
          "anonymizeIp": false,
          "relativeTo": "video",
          "doPlayCategory": "Custom Events",
          "doPlayAction": "playing",
          "doPlayValue": "1",
          "doPlayLabel": "My custom play label: {mediaProxy.entry.id}",
          "relatedVideoSelectCategory": "Related Fulfillment",
          "relatedVideoSelectAction": "{related.selectedEntryId}",
          "playerReadyCategory": "My entry tags",
          "playerReadyAction": "{mediaProxy.entry.tags}",
          "mediaErrorCategory": "Error events",
          "mediaErrorAction": " MediaError event",
          "embedPlayerErrorCategory": "Error events",
          "embedPlayerErrorAction": "Streaming Error",
          "NoSourcesCustomErrorCategory": "Error events",
          "NoSourcesCustomErrorAction": "No Sources Error",
          "bufferEndEventCategory": "Buffer events",
          "bufferEndEventAction": "bufferEnd",
          "bufferEndEventValue": "{video.buffer.lastBufferDurationMs}",
          "sendRefId": true
        },
                        "IframeCustomPluginCss1": '/sites/www.pride.com/themes/pride/css/kaltura/kaltura-custom-pride.css'
              },
      "entry_id": "0_2xbalhhv"
    });
  </script>
</div>
</div></div></div>  </div>
</div>
  </div>
</div>
<div id="block-heremedia-ads-article-bigbox-mid" class="block block-heremedia-ads">

      
  <div class="content">
    <div id="dfp-ad-article_bigbox_mid-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_bigbox_mid" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_bigbox_mid");
    });
  </script>
</div>
</div>  </div>
</div>
 </div>
          </div>
        </div>
               <div id="block-heremedia-article-3" class="block block-heremedia-article">

    
  <div class="content">
    <h2 class="col-xs-12 latestNewsTitle"><span>Latest News</span></h2>
<div class="row latestNewsSection" id="columns" data-columns>
  <div class="panel panel-primary node node-article node-teaser icon-video icon-article blue">
      <div class="panel-image"> <a href="/celebrities/2019/2/19/cardi-b-jussie-smollett-fcked-black-history-month" ><picture  title="Cardi B: Jussie Smollett &amp;#039;F*cked Up Black History Month&amp;#039;">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2019/02/19/cardi-jussie750x422.jpg?itok=mJYoBE9g&amp;timestamp=1550615559 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2019/02/19/cardi-jussie750x422.jpg?itok=475ypGVv&amp;timestamp=1550615559 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2019/02/19/cardi-jussie750x422.jpg?itok=xHKUgNNA&amp;timestamp=1550615559 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/cardi-jussie750x422.jpg?itok=rn9lVt0q&amp;timestamp=1550615559 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/cardi-jussie750x422.jpg?itok=rn9lVt0q&amp;timestamp=1550615559" alt="Cardi B: &#039;Jussie Smollett F*cked Up Black History Month&#039;" title="Cardi B: Jussie Smollett &amp;#039;F*cked Up Black History Month&amp;#039;" />
</picture></a>
        <div class="imgText"><a href="/gay-celebrities">#Celebrities</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/celebrities/2019/2/19/cardi-b-jussie-smollett-fcked-black-history-month" >Cardi B: Jussie Smollett &#039;F*cked Up Black History Month&#039;</a></div>
        <div class="timeShare"> <span class="time">February 19 2019 5:55 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/celebrities/2019/2/19/cardi-b-jussie-smollett-fcked-black-history-month"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Cardi+B%3A+Jussie+Smollett+%27F%2Acked+Up+Black+History+Month%27&url=https://www.pride.com/celebrities/2019/2/19/cardi-b-jussie-smollett-fcked-black-history-month" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/celebrities/2019/2/19/cardi-b-jussie-smollett-fcked-black-history-month&title=Cardi+B%3A+Jussie+Smollett+%27F%2Acked+Up+Black+History+Month%27" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article green">
      <div class="panel-image"> <a href="/news/2019/2/19/brothers-jussie-smollett-case-were-instagram-friends-actor" ><picture  title="Brothers in Jussie Smollett Case Were Instagram Friends With the Actor">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2019/02/19/img_7608.jpg?itok=WHBYgSSz&amp;timestamp=1550611296 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2019/02/19/img_7608.jpg?itok=otKyP28f&amp;timestamp=1550611296 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2019/02/19/img_7608.jpg?itok=t08Zsu1s&amp;timestamp=1550611296 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/img_7608.jpg?itok=CDy7jyqK&amp;timestamp=1550611296 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/img_7608.jpg?itok=CDy7jyqK&amp;timestamp=1550611296" alt="Brothers in Smollett case" title="Brothers in Jussie Smollett Case Were Instagram Friends With the Actor" />
</picture></a>
        <div class="imgText"><a href="/gay-news">#News</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/news/2019/2/19/brothers-jussie-smollett-case-were-instagram-friends-actor" >Brothers in Jussie Smollett Case Were Instagram Friends With the Actor</a></div>
        <div class="timeShare"> <span class="time">February 19 2019 4:52 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/news/2019/2/19/brothers-jussie-smollett-case-were-instagram-friends-actor"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Brothers+in+Jussie+Smollett+Case+Were+Instagram+Friends+With+the+Actor&url=https://www.pride.com/news/2019/2/19/brothers-jussie-smollett-case-were-instagram-friends-actor" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/news/2019/2/19/brothers-jussie-smollett-case-were-instagram-friends-actor&title=Brothers+in+Jussie+Smollett+Case+Were+Instagram+Friends+With+the+Actor" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="adBox">
  <div id="dfp-ad-article_latest_initial_right" class="centerUnit">
  </div>
</div><div class="panel panel-primary node node-article node-teaser icon-video icon-article red">
      <div class="panel-image"> <a href="/movies/2019/2/19/taron-egerton-actually-sings-elton-johns-rocketman-sneak-peak" ><picture  title="Taron Egerton Actually Sings Elton John&amp;#039;s &amp;#039;Rocketman&amp;#039; in Sneak Peak">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2019/02/19/taron-egerton-rocketman-elton-john-trailer.jpg?itok=eBmfBEQw&amp;timestamp=1550609881 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2019/02/19/taron-egerton-rocketman-elton-john-trailer.jpg?itok=iq6luoq0&amp;timestamp=1550609881 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2019/02/19/taron-egerton-rocketman-elton-john-trailer.jpg?itok=iQz5oC0G&amp;timestamp=1550609881 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/taron-egerton-rocketman-elton-john-trailer.jpg?itok=w8syViAI&amp;timestamp=1550609881 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/taron-egerton-rocketman-elton-john-trailer.jpg?itok=w8syViAI&amp;timestamp=1550609881" alt="taron-egerton-rocketman-elton-john-trailer.jpg" title="Taron Egerton Actually Sings Elton John&amp;#039;s &amp;#039;Rocketman&amp;#039; in Sneak Peak" />
</picture></a>
        <div class="imgText"><a href="/gay-movies">#Movies</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/movies/2019/2/19/taron-egerton-actually-sings-elton-johns-rocketman-sneak-peak" >Taron Egerton Actually Sings Elton John&#039;s &#039;Rocketman&#039; in Sneak Peak</a></div>
        <div class="timeShare"> <span class="time">February 19 2019 4:13 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/movies/2019/2/19/taron-egerton-actually-sings-elton-johns-rocketman-sneak-peak"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Taron+Egerton+Actually+Sings+Elton+John%27s+%27Rocketman%27+in+Sneak+Peak&url=https://www.pride.com/movies/2019/2/19/taron-egerton-actually-sings-elton-johns-rocketman-sneak-peak" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/movies/2019/2/19/taron-egerton-actually-sings-elton-johns-rocketman-sneak-peak&title=Taron+Egerton+Actually+Sings+Elton+John%27s+%27Rocketman%27+in+Sneak+Peak" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article blue">
      <div class="panel-image"> <a href="/celebrities/2019/2/19/meghan-trainors-bizarrely-horny-press-release-has-everyone-confused" ><picture  title="Meghan Trainor&amp;#039;s Bizarrely Horny Press Release Has Everyone Confused">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2019/02/19/meghan-trainor-press-release.jpg?itok=8R90kJbz&amp;timestamp=1550603918 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2019/02/19/meghan-trainor-press-release.jpg?itok=gtoyhiip&amp;timestamp=1550603918 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2019/02/19/meghan-trainor-press-release.jpg?itok=b2LiD2iU&amp;timestamp=1550603918 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/meghan-trainor-press-release.jpg?itok=OZylInxD&amp;timestamp=1550603918 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/meghan-trainor-press-release.jpg?itok=OZylInxD&amp;timestamp=1550603918" alt="meghan-trainor-press-release.jpg" title="Meghan Trainor&amp;#039;s Bizarrely Horny Press Release Has Everyone Confused" />
</picture></a>
        <div class="imgText"><a href="/gay-celebrities">#Celebrities</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/celebrities/2019/2/19/meghan-trainors-bizarrely-horny-press-release-has-everyone-confused" >Meghan Trainor&#039;s Bizarrely Horny Press Release Has Everyone Confused</a></div>
        <div class="timeShare"> <span class="time">February 19 2019 3:11 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/celebrities/2019/2/19/meghan-trainors-bizarrely-horny-press-release-has-everyone-confused"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Meghan+Trainor%27s+Bizarrely+Horny+Press+Release+Has+Everyone+Confused&url=https://www.pride.com/celebrities/2019/2/19/meghan-trainors-bizarrely-horny-press-release-has-everyone-confused" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/celebrities/2019/2/19/meghan-trainors-bizarrely-horny-press-release-has-everyone-confused&title=Meghan+Trainor%27s+Bizarrely+Horny+Press+Release+Has+Everyone+Confused" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-video icon-article yellow">
      <div class="panel-image"> <a href="/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again" ><picture  title="These &amp;#039;She-Ra&amp;#039; Cosplayers Got Engaged &amp;amp; Now We Believe in Love Again">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2019/02/19/she-ra-cosplayers-engagement-video.jpg?itok=LhO7nthX&amp;timestamp=1550602467 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2019/02/19/she-ra-cosplayers-engagement-video.jpg?itok=JMz7ArU7&amp;timestamp=1550602467 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2019/02/19/she-ra-cosplayers-engagement-video.jpg?itok=eJNION_2&amp;timestamp=1550602467 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/she-ra-cosplayers-engagement-video.jpg?itok=dVaDmlGO&amp;timestamp=1550602467 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/she-ra-cosplayers-engagement-video.jpg?itok=dVaDmlGO&amp;timestamp=1550602467" alt="she-ra-cosplayers-engagement-video.jpg" title="These &amp;#039;She-Ra&amp;#039; Cosplayers Got Engaged &amp;amp; Now We Believe in Love Again" />
</picture></a>
        <div class="imgText"><a href="/geek">#Geek</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again" >These &#039;She-Ra&#039; Cosplayers Got Engaged &amp; Now We Believe in Love Again</a></div>
        <div class="timeShare"> <span class="time">February 19 2019 2:24 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=These+%27She-Ra%27+Cosplayers+Got+Engaged+%26+Now+We+Believe+in+Love+Again&url=https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/geek/2019/2/19/these-she-ra-cosplayers-got-engaged-now-we-believe-love-again&title=These+%27She-Ra%27+Cosplayers+Got+Engaged+%26+Now+We+Believe+in+Love+Again" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="adBox">
  <div id="dfp-ad-article_latest_initial_left" class="centerUnit">
  </div>
</div><div class="panel panel-primary node node-article node-teaser icon-article orange">
      <div class="panel-image"> <a href="/tv/2019/2/19/tiffany-pollard-troye-sivan-join-drag-race-season-11-judging-panel" ><picture  title="Tiffany Pollard, Troye Sivan Join &amp;#039;Drag Race&amp;#039; Season 11 Judging Panel">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2019/02/19/drag-race-season-11-guest-judges.jpg?itok=iR7grWe3&amp;timestamp=1550602302 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2019/02/19/drag-race-season-11-guest-judges.jpg?itok=IGNzrEwr&amp;timestamp=1550602302 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2019/02/19/drag-race-season-11-guest-judges.jpg?itok=6fWfHXRP&amp;timestamp=1550602302 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/drag-race-season-11-guest-judges.jpg?itok=MGnsZ0z3&amp;timestamp=1550602302 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/drag-race-season-11-guest-judges.jpg?itok=MGnsZ0z3&amp;timestamp=1550602302" alt="drag-race-season-11-guest-judges-tiffanny-pollard-troye-sivan.jpg" title="Tiffany Pollard, Troye Sivan Join &amp;#039;Drag Race&amp;#039; Season 11 Judging Panel" />
</picture></a>
        <div class="imgText"><a href="/gay-tv">#TV</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/tv/2019/2/19/tiffany-pollard-troye-sivan-join-drag-race-season-11-judging-panel" >Tiffany Pollard, Troye Sivan Join &#039;Drag Race&#039; Season 11 Judging Panel</a></div>
        <div class="timeShare"> <span class="time">February 19 2019 2:06 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/tv/2019/2/19/tiffany-pollard-troye-sivan-join-drag-race-season-11-judging-panel"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Tiffany+Pollard%2C+Troye+Sivan+Join+%27Drag+Race%27+Season+11+Judging+Panel&url=https://www.pride.com/tv/2019/2/19/tiffany-pollard-troye-sivan-join-drag-race-season-11-judging-panel" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/tv/2019/2/19/tiffany-pollard-troye-sivan-join-drag-race-season-11-judging-panel&title=Tiffany+Pollard%2C+Troye+Sivan+Join+%27Drag+Race%27+Season+11+Judging+Panel" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article blue">
      <div class="panel-image"> <a href="/entertainment/2019/2/19/netflix-scolded-tweet-about-gays-and-carly-rae-jepsen" ><picture  title="Netflix Scolded for Tweet About Gays and Carly Rae Jepsen...??">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2019/02/19/carlyraenetflix.jpg?itok=FCnRzveM&amp;timestamp=1550595859 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2019/02/19/carlyraenetflix.jpg?itok=MlTxgbF_&amp;timestamp=1550595859 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2019/02/19/carlyraenetflix.jpg?itok=suqMb3Zo&amp;timestamp=1550595859 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/carlyraenetflix.jpg?itok=-1LhfVDj&amp;timestamp=1550595859 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/carlyraenetflix.jpg?itok=-1LhfVDj&amp;timestamp=1550595859" alt="carlyraenetflix.jpg" title="Netflix Scolded for Tweet About Gays and Carly Rae Jepsen...??" />
</picture></a>
        <div class="imgText"><a href="/gay-celebrities">#Celebrities</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/entertainment/2019/2/19/netflix-scolded-tweet-about-gays-and-carly-rae-jepsen" >Netflix Scolded for Tweet About Gays and Carly Rae Jepsen...??</a></div>
        <div class="timeShare"> <span class="time">February 19 2019 12:05 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/entertainment/2019/2/19/netflix-scolded-tweet-about-gays-and-carly-rae-jepsen"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Netflix+Scolded+for+Tweet+About+Gays+and+Carly+Rae+Jepsen...%3F%3F&url=https://www.pride.com/entertainment/2019/2/19/netflix-scolded-tweet-about-gays-and-carly-rae-jepsen" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/entertainment/2019/2/19/netflix-scolded-tweet-about-gays-and-carly-rae-jepsen&title=Netflix+Scolded+for+Tweet+About+Gays+and+Carly+Rae+Jepsen...%3F%3F" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article green">
      <div class="panel-image"> <a href="/fashion/2019/2/19/iconic-fashion-designer-karl-lagerfeld-has-died" ><picture  title="Iconic Fashion Designer Karl Lagerfeld Has Died">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2019/02/19/karl_lagerfeld.jpg?itok=xGgRxbwZ&amp;timestamp=1550590798 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2019/02/19/karl_lagerfeld.jpg?itok=YVb2bDnO&amp;timestamp=1550590798 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2019/02/19/karl_lagerfeld.jpg?itok=zO-RPann&amp;timestamp=1550590798 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/karl_lagerfeld.jpg?itok=_8rnFVlR&amp;timestamp=1550590798 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/karl_lagerfeld.jpg?itok=_8rnFVlR&amp;timestamp=1550590798" alt="karl_lagerfeld.jpg" title="Iconic Fashion Designer Karl Lagerfeld Has Died" />
</picture></a>
        <div class="imgText"><a href="/gay-news">#News</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/fashion/2019/2/19/iconic-fashion-designer-karl-lagerfeld-has-died" >Iconic Fashion Designer Karl Lagerfeld Has Died</a></div>
        <div class="timeShare"> <span class="time">February 19 2019 10:41 AM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/fashion/2019/2/19/iconic-fashion-designer-karl-lagerfeld-has-died"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Iconic+Fashion+Designer+Karl+Lagerfeld+Has+Died&url=https://www.pride.com/fashion/2019/2/19/iconic-fashion-designer-karl-lagerfeld-has-died" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/fashion/2019/2/19/iconic-fashion-designer-karl-lagerfeld-has-died&title=Iconic+Fashion+Designer+Karl+Lagerfeld+Has+Died" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article blue">
      <div class="panel-image"> <a href="/celebrities/2019/2/19/internet-broke-over-shawn-mendes-calvin-klein-campaign" ><picture  title="The Internet Broke Over Shawn Mendes&amp;#039; Calvin Klein Campaign">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2019/02/19/shawn-mendes-calvin-klein-underwear-campaign-gay-twitter-reactions.jpg?itok=GeBXNtFA&amp;timestamp=1550605696 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2019/02/19/shawn-mendes-calvin-klein-underwear-campaign-gay-twitter-reactions.jpg?itok=nDvSivUf&amp;timestamp=1550605696 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2019/02/19/shawn-mendes-calvin-klein-underwear-campaign-gay-twitter-reactions.jpg?itok=lATcnAQW&amp;timestamp=1550605696 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/shawn-mendes-calvin-klein-underwear-campaign-gay-twitter-reactions.jpg?itok=8IaMMW2Q&amp;timestamp=1550605696 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2019/02/19/shawn-mendes-calvin-klein-underwear-campaign-gay-twitter-reactions.jpg?itok=8IaMMW2Q&amp;timestamp=1550605696" alt="shawn-mendes-calvin-klein-underwear-campaign-gay-twitter-reactions.jpg" title="The Internet Broke Over Shawn Mendes&amp;#039; Calvin Klein Campaign" />
</picture></a>
        <div class="imgText"><a href="/gay-celebrities">#Celebrities</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/celebrities/2019/2/19/internet-broke-over-shawn-mendes-calvin-klein-campaign" >The Internet Broke Over Shawn Mendes&#039; Calvin Klein Campaign</a></div>
        <div class="timeShare"> <span class="time">February 19 2019 10:15 AM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/celebrities/2019/2/19/internet-broke-over-shawn-mendes-calvin-klein-campaign"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=The+Internet+Broke+Over+Shawn+Mendes%27+Calvin+Klein+Campaign&url=https://www.pride.com/celebrities/2019/2/19/internet-broke-over-shawn-mendes-calvin-klein-campaign" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/celebrities/2019/2/19/internet-broke-over-shawn-mendes-calvin-klein-campaign&title=The+Internet+Broke+Over+Shawn+Mendes%27+Calvin+Klein+Campaign" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article purple">
      <div class="panel-image"> <a href="/comedy/2019/2/18/painfully-relatable-memes-people-who-grew-gay" ><picture  title="Painfully Relatable Memes for People Who Grew Up Gay">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_desktop_1x/public/2018/09/20/growing-up-gay-memes.jpg?itok=AgtaQ62E&amp;timestamp=1537466449 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_tablet_1x/public/2018/09/20/growing-up-gay-memes.jpg?itok=nZJsfUVN&amp;timestamp=1537466449 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mini_tablet_1x/public/2018/09/20/growing-up-gay-memes.jpg?itok=5obUa-EJ&amp;timestamp=1537466449 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2018/09/20/growing-up-gay-memes.jpg?itok=S7TScplk&amp;timestamp=1537466449 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/www.pride.com/files/styles/teaser_custom_user_mobile_1x/public/2018/09/20/growing-up-gay-memes.jpg?itok=S7TScplk&amp;timestamp=1537466449" alt="growing-up-gay-memes.jpg" title="Painfully Relatable Memes for People Who Grew Up Gay" />
</picture></a>
        <div class="imgText"><a href="/comedy">#Comedy</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/comedy/2019/2/18/painfully-relatable-memes-people-who-grew-gay" >Painfully Relatable Memes for People Who Grew Up Gay</a></div>
        <div class="timeShare"> <span class="time">February 18 2019 12:56 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow"> <span class="tableCell share-count" data-url="https://www.pride.com/comedy/2019/2/18/painfully-relatable-memes-people-who-grew-gay"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Painfully+Relatable+Memes+for+People+Who+Grew+Up+Gay&url=https://www.pride.com/comedy/2019/2/18/painfully-relatable-memes-people-who-grew-gay" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="https://www.facebook.com/sharer.php?u=https://www.pride.com/comedy/2019/2/18/painfully-relatable-memes-people-who-grew-gay&title=Painfully+Relatable+Memes+for+People+Who+Grew+Up+Gay" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
1</div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="deviceClass"></div>
 
<!-- START Parse.ly Include: Synchronous -->
<script id="parsely-cfg" data-parsely-site="pride.com" src="//cdn.parsely.com/keys/pride.com/p.js"></script>
<!-- END Parse.ly Include: Synchronous --><script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-99s4-uKAk3J7g"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-99s4-uKAk3J7g.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>

<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__GM3GJPR36rRIz0TRkjC5OQwrioSyN9aoYRivDhCO_AM__qAl84FcCv2jyN22yFGS5Oc85cjd9zKX6p_cFNLGhe-M__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js" async="async"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__Wc2QjC4OtPsUme7rfnYFK2ZLS2Pmg9JEmUp6tG2bulI__XUok23Tif72M0F1dUwuP7Me5IY_GidDk1xLFaZYPpKw__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__gPWf-R83hUsvs_4TpCuZIadqM9G_N1EV8KNuNjk5qOo__M3lwo0OWuZWhrPgTxqLNCLXiBGDfTG25mWrr1L0DJiw__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__KPSt-urSQiSdSfo6ZIX0JX3kMxVvknnSZtkg8F99hHc__Hl5txn8dILj58RpnF2S6jjS74WP8ODqYiji3kywo-QM__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-55c93dd3eed0db31"></script>
<script type="text/javascript" src="/sites/www.pride.com/files/advagg_js/js__lPz9A8965eWTWsE0Z2Yb_VBnEPQoLe-AERI2pgpwaS0__9meIjpEKYKrPz3HfNdXpiAVRGI_AVAO8OQR-uarrMfs__aTnEa_Homu3RvYAUtMGyw_StDLe6NWmg3KdGbFXgOWw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.fbAsyncInit=function(){FB.init({appId:'1660320884278138',xfbml:true,version:'v2.8'})};(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'));
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(w,d,s,id){w.PUBX=w.PUBX||{pub:"pride",discover:false,lazy:true};var js,pjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.async=true;js.src="//main.pubexchange.com/loader.min.js";pjs.parentNode.insertBefore(js,pjs)}(window,document,"script","pubexchange-jssdk"));
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"d13870c224","applicationID":"65778905,65778872","transactionName":"NlJUMERRCBVSAk1ZWQ8YdwdCWQkIHAVKb1MZQ0QFRW8ICVcEZkBXBlJpEl9VEQ==","queueTime":0,"applicationTime":924,"atts":"GhVXRgxLGxs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
