<!DOCTYPE html>
<html lang="en" dir="ltr">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<meta charset="utf-8"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>'Never Have I Ever' S2 Explores Teen Life After Coming Out as Lesbian</title>
<meta name="mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-title" content="Pride">
<meta property="fb:app_id" content="1660320884278138"/>
<meta property="fb:page_id" content="858821697507267" />
<link rel="shortcut icon" sizes="152x152" href="/sites/default/themes/pride/images/apple-touch-icon-152.jpg">
<link rel="apple-touch-icon-precomposed" href="/sites/default/themes/pride/images/apple-touch-icon-152.jpg">
<!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="https://www.pride.com/sites/www.pride.com/themes/pride/favicon.ico" type="image/vnd.microsoft.icon" />
<script type="text/javascript">dataLayer = [{"drupalLanguage":"en","drupalCountry":"US","heremediaAuthor":"Taylor Henderson","heremediaContributor":"Taylor Henderson","heremediaContentType":"article","entityLanguage":"und","entityTnid":"0","entityVid":"403253","entityName":"Taylor Henderson","entityUid":"24341","entityCreated":"1626293249","entityStatus":"1","entityType":"node","entityBundle":"article","entityId":"187431","entityLabel":"\u0027Never Have I Ever\u0027 S2 Explores Teen Life After Coming Out as Lesbian","userUid":0}];</script>
<meta property="fb:pages" content="858821697507267" />
<link rel="amphtml" href="https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian?amp" />
<link rel="shortlink" href="/node/187431" />
<link rel="canonical" href="https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian" />
<meta name="description" content="Star Lee Rodriguez talks to PRIDE about the future of Fabiola and Eve and the impact season one had on LGBTQ+ viewers." />
<script type="text/javascript">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</script>
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian" />
<meta property="og:title" content="&#039;Never Have I Ever&#039; S2 Explores Teen Life After Coming Out as Lesbian" />
<meta property="og:updated_time" content="2021-07-14T16:07:29-04:00" />
<meta property="og:image" content="https://www.pride.com/sites/default/files/never-have-i-ever-lee-rodriguez.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="TheAdvocateMag" />
<meta name="twitter:site:id" content="21692297" />
<meta name="twitter:creator" content="pride_site" />
<meta name="twitter:creator:id" content="21692297" />
<meta name="twitter:title" content="&#039;Never Have I Ever&#039; S2 Explores Teen Life After Coming Out as Lesbian" />
<meta name="twitter:description" content="Star Lee Rodriguez talks to PRIDE about the future of Fabiola and Eve and the impact season one had on LGBTQ+ viewers." />
<meta property="article:published_time" content="2021-07-14T16:07:29-04:00" />
<meta property="article:modified_time" content="2021-07-14T16:07:29-04:00" />
<script type="application/ld+json">{ "@context": "http://schema.org", "@type": "NewsArticle", "mainEntityOfPage": "https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian", "headline": "'Never Have I Ever' S2 Explores Teen Life After Coming Out as Lesbian", "image": {  "@type": "ImageObject",  "url": "https://www.pride.com/sites/default/files/styles/amp_metadata_content_image_min_696px_wide/public/never-have-i-ever-lee-rodriguez.jpg?itok=u0UtXi7i",  "width": "696",  "height": "392" }, "datePublished": "2021-07-14T16:07:29-04:00", "dateModified": "2021-07-14T16:07:29-04:00", "author": {  "@type": "Person",  "name": "Taylor Henderson" }, "publisher": {  "@type": "Organization",  "name": "PRIDE.com",  "logo": {  "@type": "ImageObject",  "url": "https://www.pride.com/sites/default/files/styles/amp_metadata_logo_600x60/public/2017/07/20/prideamplogo.gif?itok=FGs91P7C",  "width": "178",  "height": "60"  } }, "description": "Star Lee Rodriguez talks to PRIDE about the future of Fabiola and Eve and the impact season one had on LGBTQ+ viewers.", "articleBody": "From the mind of Mindy Kaling comes Never Have I Ever, Netflix's teen dramedy with a refreshing point of view. Season 2 picks up right where the first left off; a mourning Devi (Maitreyi Ramakrishnan) has just scattered her father's ashes in the ocean and emotionally locks lips with the well-meaning Ben Gross. Little does she know, she has a romantically charged voicemail from her lifelong crush, Paxton, waiting for her. Davi's best friend, the robotics-obsessed Fabiola (played by the charming Lee Rodriguez) developed a crush on a classmate named Eve last season, tenderly came out to her friends and family, and landed a date with her crush. But as all LGBTQ+ folks know, your problems don't stop once you're out.\"In her head, she kind of thought things would get easier after that but it doesn't,\" Rodriguez tells PRIDE at Devi’s Summer Kickback Netflix event on Tuesday. \"She's trying to navigate her new relationship with Eve and trying to fit into her friend group.\" In episode one of the new season, Fabiola is dropped into a group text with Eve's queer friends and struggles to understand cultural references that all assume she should know. \"What's a Bebe Rexha?\" she asks out loud to her friends. At another point, Eve invites her to a watch party for The L Word and Fabiola's confused response is absolutely hilarious. \"She just feels like she's trying to fit a certain mold that isn't her. You see her make a lot of un-Fabiola-like decisions but you know that as a viewer, you're just like, 'oh sweetheart.' She's very avoidant. She avoids her feelings and she just lets them blow up. You'll see a lot of that, you'll see her struggling.\"As the three leading ladies on the series are made up of Indian-American, Asian, and Afro-Latina actors, it means a lot to Rodriguez to be on this show. On a lesser show, characters like these would likely be relegated to sidelined best friend tropes. On Never Have I Ever, they shine, they aren't stereotyped, they have their own lives and storylines, and aren't made one-dimensional for a main white character's benefit. \"It's so refreshing,\" Rodriguez reflects. \"It really means a lot to me. Not only is it important to have that on-screen representation, but like offscreen. Seeing familiar faces, people of color, you just feel at home. There's this level of comfortability that you just can't get with a non-diverse cast.\" That, combined with Fabiola's queer identity, makes the character feels groundbreaking. \"It feels really special,\" says the 21-year-old. \"Representing a group of people is so important because everyone wants to feel seen. I feel like I'm in a very special position. I just want to do right by everyone. I just want to be good representation. It's an honor.\"Following last season's LGBTQ+ storylines, Rodriguez received an outpouring of love from many queer viewers who say her storyline helped them garner the courage to come out in their own lives. \"I wasn't really expecting it,\" she says.\"I actually got so many DMs, even from cast members. Somebody in their family felt really moved by Fabiola's coming out that it inspired them to come out.\"Rodriguez is grateful for the show and this storyline that has impacted people's lives in this profound way. \"I reached back out to a lot of those people and I was just telling them how proud I am of them. They have my support, my love. It wasn't something I was expecting or had in mind but I'm really glad Fabiola's storyline did that.\"Never Have I Ever Season 2 premieres tomorrow on Netflix. Watch the trailer below:" }</script>


<!-- GetAdmiral script -->
<script type="text/javascript">(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//receptivereaction.com/246200ca9b0a6c2082693d0b6f9d0d3faa93d66923a64fefba653f0f1d8cbcd6ea34d6d4428372734c77ff1116424000bef2e6d806a1d06d5e31157b2831');</script>
<!-- End GetAdmiral script -->
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__yp4wzhxWjCW7duExKmwTE_soNWIAKtY1LPypusgc7-Q__xQyxBKEvS2NwelE5CaPCOB6a2WZUL8As57akp8cKdYk__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__Uro0xdUVSImgiJmrjrHq6zMlE71uYJi5DWE640XkT7c__hG-bFXEfy_6ZwPpLQjNJaRgaaSKpIY0p2SaD6zrPp7k__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__gEYJxexPO6RQ-jLij_3HC9OsTwbiZxWpR9HwbbX52Os__dHFmdS-WTsd1RRY8aL_iGTzUWQp1YxU8pTPcgOAbqqM__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__54MFi8FkyGaHGYd5ZdzyudsaptrAaR6nC8-2d5gRGIE__DZHVtZ9vnQ_nAfnDj-ZCEzijsy9gIMMi5lXK_gmq84c__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__UjpsJAPU8laR8ahZaR7mDTrTIbEUfx6ojtntXO4DDMg__XzxbfvF62JIagzPQvJTYUOB8YCyfSpjpBIo6Rw5I9Lo__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__QIsY78ejFUWd8_1WhPPUQqmlhBp10Tco4VOz-PcKrkI__B17CN2p8y9_5NI_q_duUIjYzJaZyaT1gKiLbRN3Cjsg__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__MuoIiho4tXsD6GNyCC5loToVJ2DU7Ury3W9OL-q0MYI__Zd1Th3FyAzZMsKET3nZSYW5geMB7PSo5Gx_wJsdYz48__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__Irf_gwb-Pq8mHOWu1TP1HcgM0-G_n2aM6hh2T7HrP9w__wq2cMTqH2xzpUaajNK-ntVjmRA-Umb0bp3Uq5h5tINo__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__kg7S0dNHB51gTPALGAOAOThnISlBjTi_y7Sso2n2qOg__BTWp3W9drSse25DdWVDqOTveyoc3yVq9LWdACeGI4Aw__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__DJVWsB9CJVs_1IGdy-_cGuq4r6SVVaWbEnbS1U2p6y4__7g40UeM74r8hkrzDC6Hbb7RReIGNu-Jsb5XAbAPKIeA__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__TXHA7jvTEeqL82E22B7YM0Q0plNpa4Z6ctRlCHd6AIo__HKT8JCI7vEYoOeIG8Vt1Yuf5w4nXYPPgEHdwrxBV0Vo__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__pyBm59rI9muxGEBXE0NzuyoqPR_I5YlNhjx9F1mdxcM__vJp6KNhji7Wx6It0gDP7JGdWkAlOiq86CWeclqIH72Q__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />

<!--[if lt IE 8]>
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__8nh7ZZMpsZIXQKyk-b7qmtKChIgGUlgt0fMfe6P8kDc__WwdPWtQ37n5PhTUzshsj-X27EbYTSfnbXn6keNZjecY__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__BnvO0WlhgMlDJPZNN0hFztjI38qT4NYvgyYFAOudy2o__ly_iVEt0zPmy2eqbJgO_YV9ULMjQKrp7l1wEI1D3HtQ__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat:400,700|Open+Sans+Condensed:300,700italic,700" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__1Mi24oee0UoAzNDrrSdsPna8pRu3bAFtVviKVhmc6Yc__-0MKhyDOx5utr_tWD0sc-E1vnUzO8WpcvyhueQiauUY__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<script type="text/javascript" src="/sites/default/files/advagg_js/js__SlxZR0T0y0knhPGspoKKlEQqbk_RdNNsHwLrlCQRTSo__J-uYUEz5R6JBvrH_XB90DPHvh4o7_ckJSz2wp2rnC5o__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__gpBHymPy0cZtGflAX-HtnXpqjdz3SFOq1ifLomZkVgI__dpraG3ksIfWtSoV_HQmrLzw-0oyXIBaj27mKny_LovU__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.migrateMute=true;jQuery.migrateTrace=false;
//--><!]]>
</script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__sUQejFh5_mWnisJMnqxy1UIUGVixyv9rzsPIOkUTWyI__euCyFfbtQJUX7G1SYLzMGtrIsRYOW63455e0P4xPntg__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__P3ER6aBJWRT0gwCuCwxJJBGcRpyoPxvBTwmExELajfg__6lirxbTdH7loCG7BGjvM9lYACQY3pzS-55Nwvn6e3jo__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__3vwOA0BwlnyBkt9H4CLg6FgNyKAh--OmfOxFOIu_5S4__14jAFRiS2WG9seuuVvkrazGaW7kLmmXyNFKpx92Mnko__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__dcZDfpBdRmjCW0vKa_r5K07i0bhzXpAke8IwZrpL92Y__xruSkbHzxgPSpx1WPgV8Fv4M2ONWi_CbIi779Jl3wfM__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__eLavzkA9tsn6kZ-1iuFHxosydwMf_h328_C0pSaT0CM__Syn3HHsUrWR7asnv8UtQ8klhA0UbDC4RUiOTgIXSf0c__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="//native.sharethrough.com/assets/tag.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__liWFgt5FcZCFKSk8Ncvc4nUpgLsqOb-kiDgNBwR-pY4__bc40W1oW3qjMsCB3Hyp4_wHB7ZJO5pRbwwPwYficDTk__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__VwdETPizwyNK0wkgGTdMfB01HAlBYkI6Ek-nE-lbIok__D8QiP_LAUw_WWh9S2FdH1oCmQsOySoYxDdaRJ2OI9E4__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__I7mzR88JMssw6YRzO_eVKtE7IfE-SUsyMkNwL7GgMMQ__iVXJOOzEeZ3JZiPwtmkDVdEgw27FqQ_hs9n_8mSWWFY__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__lMCIO_gwoENlBigI2UOzOKkyG-EeUqOHrxnTec1I-HQ__C389Vc_zjTfBmrTqoRNGUK0zY_nSOyzn-bjDheR_WiY__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__Tf-78NpoVoLlLaIMdFd4t-zj2WpBD71T_6QZ95etiGk__aAB7ynASdOCrMltPnfPuB7BO5GCisjBTWt1yr1Ag4_8__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var this_site=window.location.hostname.split(".");this_site=this_site[this_site.length-2];var sites={advocate:{pageID:13011},out:{pageID:13016},pride:{pageID:13047},outtraveler:{pageID:13022},hivplusmag:{pageID:13037},chill:{pageID:80857}},site_ttf=sites[this_site];(function(d,p){var js,s=d.getElementsByTagName('script')[0];js=d.createElement('script');js.async=true;js.defer=true;js.setAttribute("class","teads");js.src='//a.teads.tv/page/'+p+'/tag';s.parentNode.insertBefore(js,s)})(window.document,site_ttf.pageID);
//--><!]]>
</script>
<script type="text/javascript" async="async" src="https://sadmin.brightcove.com/js/BrightcoveExperiences.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__eZU2j1BNsp_jBUWhrUXPY31KbSTg7_oLmO0sU8lNeDY__V2_qhRZSGNcxlBV1RynyOlSM8PdWaBkO6M81VT7t6X4__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__MjXNtxGz98fuedHhhBBsE2yr69DCMvIjOfcWk2bVDxA__S8W8hkV4Vwgr_qDC9AQbTPiXDRzuPqSYzqmFuZkeTDU__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">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</script>
<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!--[if lt IE 9]>
    <script type="text/javascript" src="/sites/default/themes/pride/js/html5shiv.js"></script>
    <script type="text/javascript" src="/sites/default/themes/pride/js/respond.js"></script>
  <![endif]-->
  <!-- Start Cookie Consent -->
  <link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.css" />
  <script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.js"></script>
  <script type="text/javascript">
    window.addEventListener("load", function(){
      window.cookieconsent.initialise({
        "palette": {
          "popup": {
            "background": "#000000",
            "text": "#ffffff"
          },
          "button": {
            "background": "#980000",
            "text": "#ffffff"
          }
        },
        "content": {
          "message": "By continuing to use our site, you agree to our <a href=\"https://www.pridemedia.com/privacy-policy\" target=\"_blank\" class=\"cc-link\">Private Policy</a> and",
          "dismiss": "Accept",
          "link": "Terms of Use.",
          "href": "https://www.pridemedia.com/terms-of-use"
        }
      })});
  </script>
  <!-- End Cookie Consent -->
  <!-- Facebook Pixel Code Old-->
  <script type="text/javascript">
    !function (f, b, e, v, n, t, s) {
      if (f.fbq) return;
      n = f.fbq = function () {
        n.callMethod ?
          n.callMethod.apply(n, arguments) : n.queue.push(arguments)
      };
      if (!f._fbq) f._fbq = n;
      n.push = n;
      n.loaded = !0;
      n.version = '2.0';
      n.queue = [];
      t = b.createElement(e);
      t.async = !0;
      t.src = v;
      s = b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t, s)
    }(window,
      document, 'script', 'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1586530151593576');
    fbq('track', "PageView");
  </script>
  <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1586530151593576&ev=PageView&noscript=1"/></noscript>
  <!-- End Facebook Pixel Code -->
  <!-- Facebook Pixel Code -->
  <script type="text/javascript">
    !function (f, b, e, v, n, t, s) {
      if (f.fbq) return;
      n = f.fbq = function () {
        n.callMethod ?
          n.callMethod.apply(n, arguments) : n.queue.push(arguments)
      };
      if (!f._fbq) f._fbq = n;
      n.push = n;
      n.loaded = !0;
      n.version = '2.0';
      n.queue = [];
      t = b.createElement(e);
      t.async = !0;
      t.src = v;
      s = b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t, s)
    }(window, document, 'script',
      'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '259124211325942');
    fbq('track', 'PageView');
  </script>
  <noscript><img height="1" width="1" src="https://www.facebook.com/tr?id=259124211325942&ev=PageView&noscript=1"/></noscript>
  <!-- End Facebook Pixel Code -->
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-187431 node-type-article"  >
<noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-K5RNFPW" height="0" width="0" style="display:none;visibility:hidden" title="Google Tag Manager">Google Tag Manager</iframe></noscript> <div class="navmenu navmenu-default navmenu-fixed-left offcanvas"> <ul class="nav navmenu-nav out"><li class="0 first"><a href="/gay-celebrities">#Celebs</a></li>
<li class="1"><a href="/geek">#Geek</a></li>
<li class="2"><a href="/gay-tv">#TV</a></li>
<li class="3"><a href="/gay-movies">#Movies</a></li>
<li class="4"><a href="/gay-music">#Music</a></li>
<li class="5"><a href="/coming-out">#ComingOut</a></li>
<li class="6"><a href="/love-and-sex">#Love&amp;Sex</a></li>
<li class="7"><a href="/first-person">#FirstPerson</a></li>
<li class="8 last"><a href="/gay-activist">#Activism</a></li>
</ul><ul class="nav navmenu-nav sites"><li class="0 first"><a href="https://www.advocate.com" target="_blank">Advocate</a></li>
<li class="1"><a href="https://www.out.com" target="_blank">Out</a></li>
<li class="2"><a href="https://www.outtraveler.com" target="_blank">Out Traveler</a></li>
<li class="3 last"><a href="https://www.hivplusmag.com" target="_blank">Plus</a></li>
</ul><ul class="nav navmenu-nav order"><li class="0 first"><a href="https://subscribe.herepublishing.com/" target="_blank">Subscribe</a></li>
<li class="1"><a href="https://service.qfie.com/HERE/clsOUTLookup.asp?strAspReason=106&amp;strLookFormControl=1" target="_blank">Subscriber Services</a></li>
<li class="2 last"><a href="/signup" class="order">Email Newsletter Signup</a></li>
</ul><ul class="nav navmenu-nav terms"><li class="0 first"><a href="/contact">Contact</a></li>
<li class="1"><a href="https://www.pridemedia.com/careers/" target="_blank">Career Opportunities</a></li>
<li class="2"><a href="https://www.pridemedia.com/sales/" target="_blank">Advertise With Us</a></li>
<li class="3"><a href="https://www.pridemedia.com/privacy-policy" target="_blank">Privacy Policy</a></li>
<li class="4"><a href="https://www.pridemedia.com/terms-of-use" target="_blank">Terms of Use</a></li>
<li class="5 last"><a href="https://www.pridemedia.com/legal-notice" target="_blank">Legal Notice</a></li>
</ul>  <ul class="nav navmenu-nav copyright">
    <li>&copy; 2021 Pride Publishing Inc.<br>
      All Rights Reserved
    </li>
  </ul>
</div>
<div class="desktopHeader">
  <div class="container topHeader">
    <div class="magazines">
          </div>
    <div class="navbar navbar-default">
      <button type="button" class="navbar-toggle" data-toggle="offcanvas" data-target=".navmenu" data-canvas="body" aria-label="Menu" name="Menu" title="Menu">
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </button>
      <div class="topLogoHeader"><a href="/">
          <img src="https://www.pride.com/sites/www.pride.com/themes/pride/logo.png" class="mainLogo" alt="">
                      <img src="/sites/default/themes/pride/images/pride-mobile.svg" class="mobileLogo" style="display:none;" alt="PRIDE">
                  </a></div>
    </div>
    <div class="expand-trending">
      <a class="icon-flame collapsed" href="#"><img src="/sites/www.pride.com/themes/pride/images/pride-logo-icon.gif" alt="Pride Expand"></a>
    </div>
    <div class="socialButtons">
      <ul class="socialList">
        <li class="searchBox">
          <a href="javascript: void(0);"><img src="/sites/default/themes/pride/images/social-search.svg" width="29" height="20" alt="Search" class="search">
          </a>
          <div class="searchForm"> <form action="/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-OFGPNV__Tl8BtsR_NSuCUDi_N__Aoqv3gSVestv3Iak" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form> </div>
        </li>
        <li class="fbButton">
          <a href="https://www.facebook.com/pridesite" target="_blank"><img src="/sites/default/themes/pride/images/social-facebook.gif" width="29" height="20" alt="Facebook"></a>
        </li>
        <li class="twButton">
          <a href="https://twitter.com/pride_site" target="_blank"><img src="/sites/default/themes/pride/images/social-twitter.gif" width="29" height="20" alt="Twitter"></a>
        </li>
        <li class="instaButton">
          <a href="https://www.instagram.com/pride_site/" target="_blank"><img src="/sites/default/themes/pride/images/social-instagram.gif" width="29" height="20" alt="Instagram"></a>
        </li>
        <li class="tumblrButton">
          <a href="http://pridesite.tumblr.com/" target="_blank"><img src="/sites/default/themes/pride/images/social-tumblr.gif" width="29" height="20" alt="Tumblr"></a>
        </li>
        <li class="youtubeButton">
          <a href="https://www.youtube.com/channel/UCCB-yLpR8jydfUM9rquJcnA" target="_blank"><img src="/sites/default/themes/pride/images/social-youtube.gif" width="29" height="20" alt="YouTube"></a>
        </li>
        <li class="mailButton">
          <a href="/signup"><img src="/sites/default/themes/pride/images/social-mail.gif" width="29" height="20" alt="Mail"></a>
        </li>
      </ul>
    </div>
  </div>
  <div class="band">
    <div class="container">
      <!--TREND NAV BAR-->
      <div class="trendBar">
  <ul>
    <li class="trend"><span>Editor's Pick</span></li>
        <li id="" class="black" style=""> <a href="/black-lives-matter">#BlackLivesMatter</a> </li>
        <li id="" class="yellow" style=""> <a href="/geek">#Geek</a> </li>
        <li id="" class="red" style=""> <a href="/gay-movies">#Movies</a> </li>
        <li id="" class="orange" style=""> <a href="/gay-tv">#TV</a> </li>
        <li id="" class="teal" style=""> <a href="/interviews">#Interviews</a> </li>
        <li id="" class="purple" style=""> <a href="/gay-music">#Music</a> </li>
        <li id="" class="green" style=""> <a href="/coming-out" class="black" target="_blank">#ComingOut</a> </li>
        <li id="" class="teal" style=""> <a href="/gay-activist">#Activism</a> </li>
        <li id="" class="blue" style=""> <a href="/gay-celebrities">#Celebs</a> </li>
      </ul>
</div>

 </div>
  </div>
</div>
<div class="container adWindow">
      <div class="leaderboard">    <div id="block-heremedia-ads-article-leaderboard" class="block block-heremedia-ads">

      
  <div class="content">
    <div id="dfp-ad-article_leaderboard-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_leaderboard" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_leaderboard");
    });
  </script>
</div>
</div>  </div>
</div>
 </div>
  </div>
<div class="trendbar-overlay" style="display:none;">
  <ul>
  </ul>
</div>
<div id="body-inner" class="container"><a href="#" class="scrollToTop" title="Scroll To Top">Scroll To Top</a>
  <div class="row">
    <div class="col-xs-12 col-sm-12 col-md-12">                           <div class="tabs"></div>
                          <div class="page articleDetailSection" >
          <div class="row">
            <div class="col-md-8 col-sm-12 col-xs-12">    <div class="articleStatus node node-article orange">
  <div class="articleCategory"><a href="/gay-tv">#TV</a></div>
    <h1 class="articleTitle"><p><em>Never Have I Ever</em> S2 Explores Teen Life After Coming Out as Lesbian</p>
</h1>
  <div class="leadImageArticle">
    <div class="articleImg ">
            <img src="https://www.pride.com/sites/default/files/nhie2_main_stairs_vertical_27x40_rgb_en-us-2.jpeg" alt="Never Have I Ever S2 Explores Teen Life After Coming Out as Lesbian
" title="Never Have I Ever S2 Explores Teen Life After Coming Out as Lesbian
" />    </div>
        <div class="authorBox">
      <div class="box">
                        <div class="articleTeaser"><p>Star Lee Rodriguez talks to <em>PRIDE</em> about the future of Fabiola and Eve and the impact season one had on LGBTQ+ viewers.</p>
</div>
                <div class="articledivder"></div>
                <div class="authorAvatar"> <a href="/authors/taylor-henderson"><img src="https://www.pride.com/sites/default/files/2019/01/03/taylr-henderson.jpg" alt="Taylor Henderson" title="Taylor Henderson" /></a> </div>
                <div class="articleAuthor"> By <span><a href="/authors/taylor-henderson">Taylor Henderson</a></span>
                    <span class="twitter-handle"> <a href="http://twitter.com/cornbreadsays">@cornbreadsays</a> </span>
                  </div>
        <div class="articleDate"> <span class="date">July 14 2021 4:07 PM EDT</span>
                  </div>
      </div>
    </div>
  </div>
    <div class="shareArticleButtons"> <div class="tableDiv">
  <div class="tableRow">
   <span class="tableCell share-count article-only" data-url="https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=%27Never+Have+I+Ever%27+S2+Explores+Teen+Life+After+Coming+Out+as+Lesbian&url=https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian&title=%27Never+Have+I+Ever%27+S2+Explores+Teen+Life+After+Coming+Out+as+Lesbian" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
    <div class="textArticle" id="article-content"> <p>From the mind of Mindy Kaling comes <em>Never Have I Ever</em>, Netflix's teen dramedy with a refreshing point of view. </p>
<p>Season 2 picks up right where the first left off; a mourning Devi (Maitreyi Ramakrishnan) has just scattered her father's ashes in the ocean and emotionally locks lips with the well-meaning Ben Gross. Little does she know, she has a romantically charged voicemail from her lifelong crush, Paxton, waiting for her. </p>
<p>Davi's best friend, the robotics-obsessed Fabiola (played by the charming Lee Rodriguez) <a href="https://www.pride.com/tv/2020/4/28/never-have-i-ever-has-coming-out-story-gay-girls-deserve" target="_blank">developed a crush on a classmate named Eve last season, tenderly came out to her friends and family</a>, and landed a date with her crush. But as all LGBTQ+ folks know, your problems don't stop once you're out.</p>
<p>"In her head, she kind of thought things would get easier after that but it doesn't," Rodriguez tells <em>PRIDE</em> at Devi’s Summer Kickback Netflix event on Tuesday. "She's trying to navigate her new relationship with Eve and trying to fit into her friend group."</p>
<p>
</p><blockquote id="instagram-widget" class="instagram-media" data-instgrm-captioned="" data-instgrm-version="6" style="width:100%;max-width:460px; ">
  <a href="https://www.instagram.com/p/CRT09_oCfLy/" rel="nofollow" target="_blank"></a>
</blockquote>
<p>In episode one of the new season, Fabiola is dropped into a group text with Eve's queer friends and struggles to understand cultural references that all assume she should know. "What's a Bebe Rexha?" she asks out loud to her friends. At another point, Eve invites her to a watch party for <em>The L Word</em> and Fabiola's confused response is absolutely hilarious. </p>
<p>"She just feels like she's trying to fit a certain mold that isn't her. You see her make a lot of un-Fabiola-like decisions but you know that as a viewer, you're just like, <em>'oh sweetheart.'</em> She's very avoidant. She avoids her feelings and she just lets them blow up. You'll see a lot of that, you'll see her struggling."</p>
<p>As the three leading ladies on the series are made up of Indian-American, Asian, and Afro-Latina actors, it means a lot to Rodriguez to be on this show. On a lesser show, characters like these would likely be relegated to sidelined best friend tropes. On <em>Never Have I Ever</em>, they shine, they aren't stereotyped, they have their own lives and storylines, and aren't made one-dimensional for a main white character's benefit. </p>
<p>"It's so refreshing," Rodriguez reflects. "It really means a lot to me. Not only is it important to have that on-screen representation, but like offscreen. Seeing familiar faces, people of color, you just feel at home. There's this level of comfortability that you just can't get with a non-diverse cast."</p>
<p>
</p><blockquote id="instagram-widget" class="instagram-media" data-instgrm-captioned="" data-instgrm-version="6" style="width:100%;max-width:460px; ">
  <a href="https://www.instagram.com/p/COgwooAgVED/" rel="nofollow" target="_blank"></a>
</blockquote>
<p>That, combined with Fabiola's queer identity, makes the character feels groundbreaking. "It feels really special," says the 21-year-old. "Representing a group of people is so important because everyone wants to feel seen. I feel like I'm in a very special position. I just want to do right by everyone. I just want to be good representation. It's an honor."</p>
<p>Following last season's LGBTQ+ storylines, Rodriguez received an outpouring of love from many queer viewers who say her storyline helped them garner the courage to come out in their own lives. "I wasn't really expecting it," she says.</p>
<p>"I actually got so many DMs, even from cast members. Somebody in their family felt really moved by Fabiola's coming out that it inspired them to come out."</p>
<p>Rodriguez is grateful for the show and this storyline that has impacted people's lives in this profound way. "I reached back out to a lot of those people and I was just telling them how proud I am of them. They have my support, my love. It wasn't something I was expecting or had in mind but I'm really glad Fabiola's storyline did that."</p>
<p><strong><em>Never Have I Ever</em> Season 2 premieres tomorrow on Netflix. Watch the trailer below:</strong></p>
<p><iframe allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="315" src="https://www.youtube.com/embed/FakCjoNnxik" title="YouTube video player" width="560"></iframe></p>
      </div>
</div>

<div class="tags"> <span>Tags:</span> <a href="/gay-tv" class="orange">#TV</a>, <a href="/gay-entertainment" class="green">#Entertainment</a>, <a href="/gay-celebrities" class="blue">#Celebrities</a>, <a href="/women" class="blue">#Women</a>, <a href="/lesbian" class="yellow">#Lesbian</a> </div>

  <div class="magazine-subscription-promo-banner">
    <div class="entity entity-bean bean-house-promo clearfix">
  <div class="subscription content">
          <a href="https://service.qfie.com/HERE/clsOUTNewOrdForm.asp?straspreason=210&pubcode=out&trackcode=JPO6XD"  target="_blank">
        <img src="https://www.pride.com/sites/default/files/outbanner_750x211_rickymartin.jpg" alt="Ricky Martin" />      </a>
      </div>
</div>
  </div>

<h2 class="col-xs-12 ourSponsors">
  <span>From our Sponsors</span>
</h2>
<div class="row nativeCustomAds">
  <div class="col-md-6 col-sm-6 col-xs-12">
    <div id="dfp-ad-article_native_1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_native_1" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_native_1");
    });
  </script>
</div>
</div>  </div>
  <div class="col-md-6 col-sm-6 col-xs-12">
    <div id="dfp-ad-article_native_2-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_native_2" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_native_2");
    });
  </script>
</div>
</div>  </div>
</div>

    <div class="pubexchange_module" id="pubexchange_below_content" data-pubexchange-module-id="2849"></div>



<div id="comments" class="facebookComments">
    <h5>READER COMMENTS (<fb:comments-count href='https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian'></fb:comments-count>)</h5>
    <fb:comments class="fb-comments" data-href="https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian" data-numposts="10" data-width="auto"></fb:comments>
</div>
 </div>
            <div class="col-md-4 col-sm-12 col-xs-12">    <div id="block-heremedia-ads-article-bigbox-top" class="block block-heremedia-ads">

      
  <div class="content">
    <div id="dfp-ad-article_bigbox_top-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_bigbox_top" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_bigbox_top");
    });
  </script>
</div>
</div>  </div>
</div>
<div id="block-bean-single-video-embed" class="block block-bean">

    
  <div class="content">
    <div class="entity entity-bean bean-video-embed clearfix">
        <div class="content">
    <div class="field field-name-field-kaltura-video field-type-heremedia-kaltura-field field-label-hidden"><div class="field-items"></div></div><link href="https://players.brightcove.net/videojs-pip/1/videojs-pip.css" rel="stylesheet">
<div class="vjs-pip-container">
  <div style="position: relative; display: block; max-width: 100%;">
    <div style="padding-top: 56.25%;">
      <video id="brightcove-rightrail-6055361165001" data-account="6001673517001" data-player="wGC05d5pG" data-embed="default" data-playlist-id="6055361165001" width="425" height="350" class="video-js" autoplay playsinline muted controls style="position: absolute; top: 0; right: 0; bottom: 0; left: 0; width: 100%; height: 100%;"></video>
    </div>
  </div>
</div>
  <ol class="vjs-playlist"></ol>
<script type="text/javascript" src="//players.brightcove.net/6001673517001/wGC05d5pG_default/index.min.js"></script>
  <script type="text/javascript">
    var playerBrightcove = bc('brightcove-rightrail-6055361165001');
    playerBrightcove.on('ready', function(){
            playerBrightcove.ima3.settings.serverUrl = "https://pubads.g.doubleclick.net/gampad/ads?iu=/6850/here.pride/video/rightrail_player&description_url={window.location.href}&env=vp&impl=s&correlator={random}&tfcd=0&npa=0&gdfp_req=1&output=vast&sz=480x360%7C640x480&unviewed_position_start=1&cust_params=cat%3Dtv%2Centertainment%2Ccelebrities%2Cwomen%2Clesbian%26title%3Dnever_have_i_ever_s2_explores_teen_life_after_coming_out_lesbian%26aid%3D187431&cmsid=2493821&vid={mediainfo.id}";
                  // Initialize the picture-in-picture plugin
      playerBrightcove.pip({scale: 1});
          });
  </script>
<!-- Script for the picture-in-picture plugin -->
<script type="text/javascript" src="https://players.brightcove.net/videojs-pip/1/videojs-pip.min.js"></script>
  </div>
</div>
  </div>
</div>
<div id="block-heremedia-ads-article-bigbox-mid" class="block block-heremedia-ads">

      
  <div class="content">
    <div id="dfp-ad-article_bigbox_mid-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_bigbox_mid" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_bigbox_mid");
    });
  </script>
</div>
</div>  </div>
</div>
 </div>
          </div>
        </div>
               <div id="block-heremedia-article-3" class="block block-heremedia-article">

    
  <div class="content">
    
<h2 class="col-xs-12 latestNewsTitle"><span>Latest News</span></h2>
<div class="row latestNewsSection" id="columns" data-columns>

  <div class="panel panel-primary node node-article node-teaser icon-article purple">
      <div class="panel-image"> <a href="/comedy/2021/7/16/pregnant-man-emoji-coming-so-prepare-yourselves-gay-jokes" ><picture  title="&amp;#039;Pregnant Man&amp;#039; Emoji Is Coming So Prepare Yourselves for the Gay Jokes">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/emoji.jpeg?itok=S24xm7jY&amp;timestamp=1626459603 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/emoji.jpeg?itok=3xiUJk8h&amp;timestamp=1626459603 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/emoji.jpeg?itok=S24xm7jY&amp;timestamp=1626459603 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/emoji.jpeg?itok=S24xm7jY&amp;timestamp=1626459603 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/emoji.jpeg?itok=S24xm7jY&amp;timestamp=1626459603" alt="emoji.jpeg" title="&amp;#039;Pregnant Man&amp;#039; Emoji Is Coming So Prepare Yourselves for the Gay Jokes" />
</picture></a>
        <div class="imgText"><a href="/comedy">#Comedy</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/comedy/2021/7/16/pregnant-man-emoji-coming-so-prepare-yourselves-gay-jokes" >&#039;Pregnant Man&#039; Emoji Is Coming So Prepare Yourselves for the Gay Jokes</a></div>
        <div class="timeShare"> <span class="time">2 hours 25 sec ago</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=%27Pregnant+Man%27+Emoji+Is+Coming+So+Prepare+Yourselves+for+the+Gay+Jokes&url=https://www.pride.com/comedy/2021/7/16/pregnant-man-emoji-coming-so-prepare-yourselves-gay-jokes" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/comedy/2021/7/16/pregnant-man-emoji-coming-so-prepare-yourselves-gay-jokes&title=%27Pregnant+Man%27+Emoji+Is+Coming+So+Prepare+Yourselves+for+the+Gay+Jokes" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-media-gallery node-teaser icon-media_gallery  mg-gallery mg-teaser"><div class="panel-image"><a href="/identities/2021/7/15/20-things-straight-people-think-are-totally-gay"><picture  title="20 Things Straight People Think Are Totally Gay">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/straight-people-are-wild_0.jpg?itok=CBfxqtDp&amp;timestamp=1626392327 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/straight-people-are-wild_0.jpg?itok=MLaMNVg3&amp;timestamp=1626392327 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/straight-people-are-wild_0.jpg?itok=CBfxqtDp&amp;timestamp=1626392327 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/straight-people-are-wild_0.jpg?itok=CBfxqtDp&amp;timestamp=1626392327 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/straight-people-are-wild_0.jpg?itok=CBfxqtDp&amp;timestamp=1626392327" alt="straight-people-are-wild.jpg" title="20 Things Straight People Think Are Totally Gay" />
</picture></a><div class="imgText orange"><a href="/identities" class="orange">#Identities</a></div></div><div class="panel-body"><div class="title"><a href="/identities/2021/7/15/20-things-straight-people-think-are-totally-gay">20 Things Straight People Think Are Totally Gay</a></div><div class="timeShare"><span class="time">July 15 2021 7:24 PM</span></div><div class="shareHomeButtons"><div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=20+Things+Straight+People+Think+Are+Totally+Gay&url=https://www.pride.com/identities/2021/7/15/20-things-straight-people-think-are-totally-gay" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/identities/2021/7/15/20-things-straight-people-think-are-totally-gay&title=20+Things+Straight+People+Think+Are+Totally+Gay" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
</div></div></div><div class="adBox">
  <div id="dfp-ad-article_latest_initial_right" class="centerUnit">
  </div>
</div><div class="panel panel-primary node node-article node-teaser icon-article orange">
      <div class="panel-image"> <a href="/tv/2021/7/15/british-bake-told-gay-sex-jokes-twitter-and-fans-were-living" ><picture  title="British Bake Off Told Gay Sex Jokes On Twitter and Fans Were Living">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/gbbo-laugh.jpeg?itok=0BmXVfWc&amp;timestamp=1626373170 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/gbbo-laugh.jpeg?itok=RlhtEdJF&amp;timestamp=1626373170 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/gbbo-laugh.jpeg?itok=0BmXVfWc&amp;timestamp=1626373170 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/gbbo-laugh.jpeg?itok=0BmXVfWc&amp;timestamp=1626373170 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/gbbo-laugh.jpeg?itok=0BmXVfWc&amp;timestamp=1626373170" alt="great British bake off" title="British Bake Off Told Gay Sex Jokes On Twitter and Fans Were Living" />
</picture></a>
        <div class="imgText"><a href="/gay-tv">#TV</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/tv/2021/7/15/british-bake-told-gay-sex-jokes-twitter-and-fans-were-living" >British Bake Off Told Gay Sex Jokes On Twitter and Fans Were Living</a></div>
        <div class="timeShare"> <span class="time">July 15 2021 2:30 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=British+Bake+Off+Told+Gay+Sex+Jokes+On+Twitter+and+Fans+Were+Living&url=https://www.pride.com/tv/2021/7/15/british-bake-told-gay-sex-jokes-twitter-and-fans-were-living" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/tv/2021/7/15/british-bake-told-gay-sex-jokes-twitter-and-fans-were-living&title=British+Bake+Off+Told+Gay+Sex+Jokes+On+Twitter+and+Fans+Were+Living" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article blue">
      <div class="panel-image"> <a href="/celebrities/2021/7/15/willow-smith-might-be-dating-rb-singer-raveena-were-screaming" ><picture  title="Willow Smith Might Be Dating R&amp;amp;B Singer Raveena &amp;amp; We&amp;#039;re Screaming">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/raveena-willow-smith-datingjpg.jpg?itok=OUGK-heh&amp;timestamp=1626368857 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/raveena-willow-smith-datingjpg.jpg?itok=VYFoPs8s&amp;timestamp=1626368857 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/raveena-willow-smith-datingjpg.jpg?itok=OUGK-heh&amp;timestamp=1626368857 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/raveena-willow-smith-datingjpg.jpg?itok=OUGK-heh&amp;timestamp=1626368857 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/raveena-willow-smith-datingjpg.jpg?itok=OUGK-heh&amp;timestamp=1626368857" alt="raveena-willow-smith-dating.jpg" title="Willow Smith Might Be Dating R&amp;amp;B Singer Raveena &amp;amp; We&amp;#039;re Screaming" />
</picture></a>
        <div class="imgText"><a href="/gay-celebrities">#Celebrities</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/celebrities/2021/7/15/willow-smith-might-be-dating-rb-singer-raveena-were-screaming" >Willow Smith Might Be Dating R&amp;B Singer Raveena &amp; We&#039;re Screaming</a></div>
        <div class="timeShare"> <span class="time">July 15 2021 1:09 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Willow+Smith+Might+Be+Dating+R%26B+Singer+Raveena+%26+We%27re+Screaming&url=https://www.pride.com/celebrities/2021/7/15/willow-smith-might-be-dating-rb-singer-raveena-were-screaming" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/celebrities/2021/7/15/willow-smith-might-be-dating-rb-singer-raveena-were-screaming&title=Willow+Smith+Might+Be+Dating+R%26B+Singer+Raveena+%26+We%27re+Screaming" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article purple">
      <div class="panel-image"> <a href="/music/2021/7/15/blew-velvet-scratches-cruising-itch-sexy-its-not-enough-vid" ><picture  title="Watch Blew Velvet Scratch Cruising Itch in Sexy &amp;#039;It&amp;#039;s Not Enough&amp;#039; Vid">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/blewvelvetnotenough.jpg?itok=niSzL8NI&amp;timestamp=1626367979 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/blewvelvetnotenough.jpg?itok=gtOtWcu0&amp;timestamp=1626367979 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/blewvelvetnotenough.jpg?itok=niSzL8NI&amp;timestamp=1626367979 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/blewvelvetnotenough.jpg?itok=niSzL8NI&amp;timestamp=1626367979 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/blewvelvetnotenough.jpg?itok=niSzL8NI&amp;timestamp=1626367979" alt="Blew Velvet in Not Enough music video." title="Watch Blew Velvet Scratch Cruising Itch in Sexy &amp;#039;It&amp;#039;s Not Enough&amp;#039; Vid" />
</picture></a>
        <div class="imgText"><a href="/gay-music">#Music</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/music/2021/7/15/blew-velvet-scratches-cruising-itch-sexy-its-not-enough-vid" >Watch Blew Velvet Scratch Cruising Itch in Sexy &#039;It&#039;s Not Enough&#039; Vid</a></div>
        <div class="timeShare"> <span class="time">July 15 2021 12:54 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Watch+Blew+Velvet+Scratch+Cruising+Itch+in+Sexy+%27It%27s+Not+Enough%27+Vid&url=https://www.pride.com/music/2021/7/15/blew-velvet-scratches-cruising-itch-sexy-its-not-enough-vid" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/music/2021/7/15/blew-velvet-scratches-cruising-itch-sexy-its-not-enough-vid&title=Watch+Blew+Velvet+Scratch+Cruising+Itch+in+Sexy+%27It%27s+Not+Enough%27+Vid" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="adBox">
  <div id="dfp-ad-article_latest_initial_left" class="centerUnit">
  </div>
</div><div class="panel panel-primary node node-article node-teaser icon-article orange">
      <div class="panel-image"> <a href="/tv/2021/7/14/other-two-gayest-show-tv-finally-returns-next-month" ><picture  title="&amp;#039;The Other Two&amp;#039; (the Gayest Show On TV) Finally Returns Next Month">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/the-other-two.jpg?itok=2jjY4Ieg&amp;timestamp=1626304040 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/the-other-two.jpg?itok=nPXH20P8&amp;timestamp=1626304040 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/the-other-two.jpg?itok=2jjY4Ieg&amp;timestamp=1626304040 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/the-other-two.jpg?itok=2jjY4Ieg&amp;timestamp=1626304040 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/the-other-two.jpg?itok=2jjY4Ieg&amp;timestamp=1626304040" alt="&amp;#039;The Other Two&amp;#039; (the Gayest Show On TV) Finally Returns Next Month" title="&amp;#039;The Other Two&amp;#039; (the Gayest Show On TV) Finally Returns Next Month" />
</picture></a>
        <div class="imgText"><a href="/gay-tv">#TV</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/tv/2021/7/14/other-two-gayest-show-tv-finally-returns-next-month" >&#039;The Other Two&#039; (the Gayest Show On TV) Finally Returns Next Month</a></div>
        <div class="timeShare"> <span class="time">July 14 2021 7:07 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=%27The+Other+Two%27+%28the+Gayest+Show+On+TV%29+Finally+Returns+Next+Month&url=https://www.pride.com/tv/2021/7/14/other-two-gayest-show-tv-finally-returns-next-month" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/tv/2021/7/14/other-two-gayest-show-tv-finally-returns-next-month&title=%27The+Other+Two%27+%28the+Gayest+Show+On+TV%29+Finally+Returns+Next+Month" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article orange">
      <div class="panel-image"> <a href="/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian" ><picture  title="&amp;#039;Never Have I Ever&amp;#039; S2 Explores Teen Life After Coming Out as Lesbian">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/never-have-i-ever-lee-rodriguez.jpg?itok=cq9XYI2c&amp;timestamp=1626288324 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/never-have-i-ever-lee-rodriguez.jpg?itok=pTMfr2IU&amp;timestamp=1626288324 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/never-have-i-ever-lee-rodriguez.jpg?itok=cq9XYI2c&amp;timestamp=1626288324 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/never-have-i-ever-lee-rodriguez.jpg?itok=cq9XYI2c&amp;timestamp=1626288324 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/never-have-i-ever-lee-rodriguez.jpg?itok=cq9XYI2c&amp;timestamp=1626288324" alt="&amp;#039;Never Have I Ever&amp;#039; S2 Explores Teen Life After Coming Out as Lesbian" title="&amp;#039;Never Have I Ever&amp;#039; S2 Explores Teen Life After Coming Out as Lesbian" />
</picture></a>
        <div class="imgText"><a href="/gay-tv">#TV</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian" >&#039;Never Have I Ever&#039; S2 Explores Teen Life After Coming Out as Lesbian</a></div>
        <div class="timeShare"> <span class="time">July 14 2021 4:07 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=%27Never+Have+I+Ever%27+S2+Explores+Teen+Life+After+Coming+Out+as+Lesbian&url=https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/tv/2021/7/14/never-have-i-ever-s2-explores-teen-life-after-coming-out-lesbian&title=%27Never+Have+I+Ever%27+S2+Explores+Teen+Life+After+Coming+Out+as+Lesbian" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article blue">
      <div class="panel-image"> <a href="/celebrities/2021/7/14/jojo-siwa-reveals-lip-sync-battle-was-her-gay-awakening" ><picture  title="JoJo Siwa Reveals This Lip Sync Battle Was Her &amp;#039;Gay Awakening &amp;#039;">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/jojo-demi_0.jpeg?itok=quSeG3uc&amp;timestamp=1626287252 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/jojo-demi_0.jpeg?itok=KzdNsX2H&amp;timestamp=1626287252 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/jojo-demi_0.jpeg?itok=quSeG3uc&amp;timestamp=1626287252 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/jojo-demi_0.jpeg?itok=quSeG3uc&amp;timestamp=1626287252 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/jojo-demi_0.jpeg?itok=quSeG3uc&amp;timestamp=1626287252" alt="JoJo Siwa Reveals This Lip Sync Battle Was Her &amp;#039;Gay Awakening &amp;#039;" title="JoJo Siwa Reveals This Lip Sync Battle Was Her &amp;#039;Gay Awakening &amp;#039;" />
</picture></a>
        <div class="imgText"><a href="/gay-celebrities">#Celebrities</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/celebrities/2021/7/14/jojo-siwa-reveals-lip-sync-battle-was-her-gay-awakening" >JoJo Siwa Reveals This Lip Sync Battle Was Her &#039;Gay Awakening &#039;</a></div>
        <div class="timeShare"> <span class="time">July 14 2021 2:26 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=JoJo+Siwa+Reveals+This+Lip+Sync+Battle+Was+Her+%27Gay+Awakening+%27&url=https://www.pride.com/celebrities/2021/7/14/jojo-siwa-reveals-lip-sync-battle-was-her-gay-awakening" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/celebrities/2021/7/14/jojo-siwa-reveals-lip-sync-battle-was-her-gay-awakening&title=JoJo+Siwa+Reveals+This+Lip+Sync+Battle+Was+Her+%27Gay+Awakening+%27" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-video icon-article purple">
      <div class="panel-image"> <a href="/music/2021/7/13/halsey-drops-trailer-imax-film-if-i-cant-have-love-i-want-power" ><picture  title="Halsey Drops Trailer for IMAX Film If I Can’t Have Love, I Want Power">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/halsey-imax_0.jpg?itok=vfTNefBZ&amp;timestamp=1626207390 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/halsey-imax_0.jpg?itok=MrasCk9y&amp;timestamp=1626207390 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/halsey-imax_0.jpg?itok=vfTNefBZ&amp;timestamp=1626207390 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/halsey-imax_0.jpg?itok=vfTNefBZ&amp;timestamp=1626207390 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/halsey-imax_0.jpg?itok=vfTNefBZ&amp;timestamp=1626207390" alt="Halsey Drops Trailer for IMAX Film If I Can’t Have Love, I Want Power" title="Halsey Drops Trailer for IMAX Film If I Can’t Have Love, I Want Power" />
</picture></a>
        <div class="imgText"><a href="/gay-music">#Music</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/music/2021/7/13/halsey-drops-trailer-imax-film-if-i-cant-have-love-i-want-power" >Halsey Drops Trailer for IMAX Film If I Can’t Have Love, I Want Power</a></div>
        <div class="timeShare"> <span class="time">July 13 2021 4:32 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Halsey+Drops+Trailer+for+IMAX+Film+If+I+Can%E2%80%99t+Have+Love%2C+I+Want+Power&url=https://www.pride.com/music/2021/7/13/halsey-drops-trailer-imax-film-if-i-cant-have-love-i-want-power" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/music/2021/7/13/halsey-drops-trailer-imax-film-if-i-cant-have-love-i-want-power&title=Halsey+Drops+Trailer+for+IMAX+Film+If+I+Can%E2%80%99t+Have+Love%2C+I+Want+Power" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article orange">
      <div class="panel-image"> <a href="/tv/2021/7/13/mj-rodriguez-makes-history-emmy-nomination-pose" ><picture  title="Mj Rodriguez Makes History with Emmy Nomination for &amp;#039;Pose&amp;#039;">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/p07s2t2d.jpeg?itok=6kvGNczl&amp;timestamp=1626192248 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/p07s2t2d.jpeg?itok=aEos-ZA4&amp;timestamp=1626192248 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/p07s2t2d.jpeg?itok=6kvGNczl&amp;timestamp=1626192248 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/p07s2t2d.jpeg?itok=6kvGNczl&amp;timestamp=1626192248 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/p07s2t2d.jpeg?itok=6kvGNczl&amp;timestamp=1626192248" alt="Mj Rodriguez Makes History with Emmy Nomination for &amp;#039;Pose&amp;#039;" title="Mj Rodriguez Makes History with Emmy Nomination for &amp;#039;Pose&amp;#039;" />
</picture></a>
        <div class="imgText"><a href="/gay-tv">#TV</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/tv/2021/7/13/mj-rodriguez-makes-history-emmy-nomination-pose" >Mj Rodriguez Makes History with Emmy Nomination for &#039;Pose&#039;</a></div>
        <div class="timeShare"> <span class="time">July 13 2021 12:04 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Mj+Rodriguez+Makes+History+with+Emmy+Nomination+for+%27Pose%27&url=https://www.pride.com/tv/2021/7/13/mj-rodriguez-makes-history-emmy-nomination-pose" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/tv/2021/7/13/mj-rodriguez-makes-history-emmy-nomination-pose&title=Mj+Rodriguez+Makes+History+with+Emmy+Nomination+for+%27Pose%27" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
1</div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="deviceClass"></div>
 <div id="dfp-ad-article_wallpaper-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_wallpaper" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_wallpaper");
    });
  </script>
</div>
</div><script type="text/javascript" src="/sites/default/files/advagg_js/js__GM3GJPR36rRIz0TRkjC5OQwrioSyN9aoYRivDhCO_AM__qAl84FcCv2jyN22yFGS5Oc85cjd9zKX6p_cFNLGhe-M__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js" async="async"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__Eqf_L4jATush8Oiw9PYt_w0McxJRNkcQcfy1vROG49A__kcaiFCI8Riwi_7JyowXqpfOFh6N4KZamP6lwSrLz2H8__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__KPSt-urSQiSdSfo6ZIX0JX3kMxVvknnSZtkg8F99hHc__js30cEpiQjO6RZE-VMZJN1eGHcHI4rq___hq7vwnp3s__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" async="async" src="//platform.instagram.com/en_US/embeds.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__lPz9A8965eWTWsE0Z2Yb_VBnEPQoLe-AERI2pgpwaS0__cEEVK7augXHoCQY632L4QiMkzZ5KJ1ZaR0knC1bEtEU__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.fbAsyncInit=function(){FB.init({appId:'1660320884278138',cookie:true,xfbml:true,version:'v5.0'});FB.AppEvents.logPageView()};(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="https://connect.facebook.net/en_US/sdk.js";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'));
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(w,d,s,id){w.PUBX=w.PUBX||{pub:"pride",discover:false,lazy:true};var js,pjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.async=true;js.src="//main.pubexchange.com/loader.min.js";pjs.parentNode.insertBefore(js,pjs)}(window,document,"script","pubexchange-jssdk"));
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"NRJS-69c0f434b8e77d4bb92","applicationID":"811104645","transactionName":"Z10EbEoDXxFZAERZC14XJ1tMC14MFwdDbwFITBRZSz1fDVwGb0AFV105TlEHRg==","queueTime":0,"applicationTime":722,"atts":"SxoHGgIZTB8=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>
</html>
