<!DOCTYPE html>
<html lang="en" dir="ltr">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<meta charset="utf-8"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>Brandy Talks New Music, a Moesha Reboot, & Loving Her Gay Fans</title>
<meta name="mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-title" content="Pride">
<meta property="fb:app_id" content="1660320884278138"/>
<meta property="fb:page_id" content="858821697507267" />
<link rel="shortcut icon" sizes="152x152" href="/sites/www.pride.com/themes/pride/images/apple-touch-icon-152.jpg">
<link rel="apple-touch-icon-precomposed" href="/sites/www.pride.com/themes/pride/images/apple-touch-icon-152.jpg">
<!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="https://www.pride.com/sites/www.pride.com/themes/pride/favicon.ico" type="image/vnd.microsoft.icon" />
<script type="text/javascript">dataLayer = [{"drupalLanguage":"en","drupalCountry":"US","heremediaAuthor":"Taylor Henderson \u0026amp; Raffy Ermac","heremediaContributor":"Taylor Henderson \u0026amp; Raffy Ermac","heremediaContentType":"article","entityLanguage":"und","entityTnid":"0","entityVid":"399247","entityName":"Raffy Ermac","entityUid":"10711","entityCreated":"1596214921","entityStatus":"1","entityType":"node","entityBundle":"article","entityId":"186314","entityLabel":"Brandy Talks New Music, a Moesha Reboot, \u0026 Loving Her Gay Fans","userUid":0}];</script>
<meta property="fb:pages" content="858821697507267" />
<link rel="amphtml" href="https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans?amp" />
<link rel="shortlink" href="/node/186314" />
<link rel="canonical" href="https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans" />
<meta name="description" content="The R&amp;B legend is back on the scene with B7, her first studio album in eight years. (And yes, she knows about the memes!)" />
<script type="text/javascript">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</script>
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans" />
<meta property="og:title" content="Brandy Talks New Music, a Moesha Reboot, &amp; Loving Her Gay Fans" />
<meta property="og:updated_time" content="2020-07-31T13:02:01-04:00" />
<meta property="og:image" content="https://www.pride.com/sites/default/files/brandy-pride-interview-lead.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="TheAdvocateMag" />
<meta name="twitter:site:id" content="21692297" />
<meta name="twitter:creator" content="pride_site" />
<meta name="twitter:creator:id" content="21692297" />
<meta name="twitter:title" content="Brandy Talks New Music, a Moesha Reboot, &amp; Loving Her Gay Fans" />
<meta name="twitter:description" content="The R&amp;B legend is back on the scene with B7, her first studio album in eight years. (And yes, she knows about the memes!)" />
<meta property="article:published_time" content="2020-07-31T13:02:01-04:00" />
<meta property="article:modified_time" content="2020-07-31T13:02:01-04:00" />
<script type="application/ld+json">{ "@context": "http://schema.org", "@type": "NewsArticle", "mainEntityOfPage": "https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans", "headline": "Brandy Talks New Music, a Moesha Reboot, & Loving Her Gay Fans", "image": {  "@type": "ImageObject",  "url": "https://www.pride.com/sites/default/files/styles/amp_metadata_content_image_min_696px_wide/public/brandy-pride-interview-lead.jpg?itok=QfczKQWB",  "width": "696",  "height": "392" }, "datePublished": "2020-07-31T13:02:01-04:00", "dateModified": "2020-07-31T13:02:01-04:00", "author": {  "@type": "Person",  "name": "Taylor Henderson & Raffy Ermac" }, "publisher": {  "@type": "Organization",  "name": "PRIDE.com",  "logo": {  "@type": "ImageObject",  "url": "https://www.pride.com/sites/default/files/styles/amp_metadata_logo_600x60/public/2017/07/20/prideamplogo.gif?itok=MW2yCfZr",  "width": "178",  "height": "60"  } }, "description": "The R&B legend is back on the scene with B7, her first studio album in eight years. (And yes, she knows about the memes!)", "articleBody": "After an eight-year wait, R&B fans were finally blessed with some new music from Brandy.  The Grammy-winning singer-songwriter calls B7 (her seventh full-length studio album and the first on her own music imprint Brand Nu) one of her most personal projects to date, chronicling her life, her love, her ups and downs, and what she's been up to since we last heard from her.  \"B7 is just a compilation of songs that expresses where I've been over the last eight years, just my ups and downs with love,\" she told PRIDE's Taylor Henderson and Raffy Ermac. \"It's a very personal, authentic album, a vibey album that I feel like you can press play and listen to from top to bottom. It has been very, very long for me to come back to music, it's been such a long time. But I feel like I haven't lost my passion and I absolutely love music. I'm just in a great place right now to share and I feel very strong and confident about the album, and just happy that I was able to put together a body of work that I could be proud of that represents me and so many others.\" Throughout her long and legendary career (she released her debut self-titled record back in 1994), Brandy has also amassed a huge and loyal following of LGBTQ+ listeners, and the proud ally is still grateful for all of the support her queer fans have given her over the years.\"Some of my best moments are performing at Pride,\" she said. \"The love that you guys have shown me has just been unmatched and I just absolutely love the energy and love being around just. You can't beat the love that you guys have given me. So I wanna do more Pride, I wanna do more performances. I wanna see everybody and I'm just glad that I'm loved the way I'm loved.\"During PRIDE's chat, Brandy also dove into some of her favorite deep cuts, whether or not she'd be down for a reboot of Moesha, and being an influence for R&B's current generation of hitmakers like SZA, H.E.R., and Daniel Caesar. And yes, she also knows about those iconic memes of her.  B7 is available wherever you stream music. " }</script>


<!-- GetAdmiral script -->
<script type="text/javascript">(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//receptivereaction.com/246200ca9b0a6c2082693d0b6f9d0d3faa93d66923a64fefba653f0f1d8cbcd6ea34d6d4428372734c77ff1116424000bef2e6d806a1d06d5e31157b2831');</script>
<!-- End GetAdmiral script -->
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__yp4wzhxWjCW7duExKmwTE_soNWIAKtY1LPypusgc7-Q__xQyxBKEvS2NwelE5CaPCOB6a2WZUL8As57akp8cKdYk__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__Uro0xdUVSImgiJmrjrHq6zMlE71uYJi5DWE640XkT7c__hG-bFXEfy_6ZwPpLQjNJaRgaaSKpIY0p2SaD6zrPp7k__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__gEYJxexPO6RQ-jLij_3HC9OsTwbiZxWpR9HwbbX52Os__dHFmdS-WTsd1RRY8aL_iGTzUWQp1YxU8pTPcgOAbqqM__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__54MFi8FkyGaHGYd5ZdzyudsaptrAaR6nC8-2d5gRGIE__DZHVtZ9vnQ_nAfnDj-ZCEzijsy9gIMMi5lXK_gmq84c__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__UjpsJAPU8laR8ahZaR7mDTrTIbEUfx6ojtntXO4DDMg__XzxbfvF62JIagzPQvJTYUOB8YCyfSpjpBIo6Rw5I9Lo__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__QIsY78ejFUWd8_1WhPPUQqmlhBp10Tco4VOz-PcKrkI__B17CN2p8y9_5NI_q_duUIjYzJaZyaT1gKiLbRN3Cjsg__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__MuoIiho4tXsD6GNyCC5loToVJ2DU7Ury3W9OL-q0MYI__Zd1Th3FyAzZMsKET3nZSYW5geMB7PSo5Gx_wJsdYz48__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__Irf_gwb-Pq8mHOWu1TP1HcgM0-G_n2aM6hh2T7HrP9w__wq2cMTqH2xzpUaajNK-ntVjmRA-Umb0bp3Uq5h5tINo__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__kg7S0dNHB51gTPALGAOAOThnISlBjTi_y7Sso2n2qOg__BTWp3W9drSse25DdWVDqOTveyoc3yVq9LWdACeGI4Aw__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__lZGhIwMcLJmGzrGi_Kx7oidp5H1JefpeU6zOcuGL0-0__l3gwM278_O7JQKCg-XXwG4JndbBcixnLJAm1zCBypT0__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__gnTxjyLmYMdFCiDMEL9uoui8CsA9M4HQEiVJ32IliSI__N-sgj3gjwRIJ84mmqGmwZbPIouhmzEHRk2p6hWUWdP8__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__hB0lgZPD11z0nHUVJvgdrOPIAu8i8BLtTgWBEb5pD3U__pMQX6Jdfd0ky191ydsrThjPk9UahkSt2aJi7fzFbS3Q__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />

<!--[if lt IE 8]>
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__8nh7ZZMpsZIXQKyk-b7qmtKChIgGUlgt0fMfe6P8kDc__WwdPWtQ37n5PhTUzshsj-X27EbYTSfnbXn6keNZjecY__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__BnvO0WlhgMlDJPZNN0hFztjI38qT4NYvgyYFAOudy2o__ly_iVEt0zPmy2eqbJgO_YV9ULMjQKrp7l1wEI1D3HtQ__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat:400,700|Open+Sans+Condensed:300,700italic,700" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/default/files/advagg_css/css__1Mi24oee0UoAzNDrrSdsPna8pRu3bAFtVviKVhmc6Yc__ewyVyH8CphzwY1EGhyilUI_o-FgmmzlRSx5KAx_NbzE__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.css" media="all" />
<script type="text/javascript" src="/sites/default/files/advagg_js/js__SlxZR0T0y0knhPGspoKKlEQqbk_RdNNsHwLrlCQRTSo__J-uYUEz5R6JBvrH_XB90DPHvh4o7_ckJSz2wp2rnC5o__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__gpBHymPy0cZtGflAX-HtnXpqjdz3SFOq1ifLomZkVgI__dpraG3ksIfWtSoV_HQmrLzw-0oyXIBaj27mKny_LovU__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.migrateMute=true;jQuery.migrateTrace=false;
//--><!]]>
</script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__sUQejFh5_mWnisJMnqxy1UIUGVixyv9rzsPIOkUTWyI__euCyFfbtQJUX7G1SYLzMGtrIsRYOW63455e0P4xPntg__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__P3ER6aBJWRT0gwCuCwxJJBGcRpyoPxvBTwmExELajfg__6lirxbTdH7loCG7BGjvM9lYACQY3pzS-55Nwvn6e3jo__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__3vwOA0BwlnyBkt9H4CLg6FgNyKAh--OmfOxFOIu_5S4__14jAFRiS2WG9seuuVvkrazGaW7kLmmXyNFKpx92Mnko__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__dcZDfpBdRmjCW0vKa_r5K07i0bhzXpAke8IwZrpL92Y__xruSkbHzxgPSpx1WPgV8Fv4M2ONWi_CbIi779Jl3wfM__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__eLavzkA9tsn6kZ-1iuFHxosydwMf_h328_C0pSaT0CM__Syn3HHsUrWR7asnv8UtQ8klhA0UbDC4RUiOTgIXSf0c__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="//native.sharethrough.com/assets/tag.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__liWFgt5FcZCFKSk8Ncvc4nUpgLsqOb-kiDgNBwR-pY4__bc40W1oW3qjMsCB3Hyp4_wHB7ZJO5pRbwwPwYficDTk__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__VwdETPizwyNK0wkgGTdMfB01HAlBYkI6Ek-nE-lbIok__D8QiP_LAUw_WWh9S2FdH1oCmQsOySoYxDdaRJ2OI9E4__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__I7mzR88JMssw6YRzO_eVKtE7IfE-SUsyMkNwL7GgMMQ__iVXJOOzEeZ3JZiPwtmkDVdEgw27FqQ_hs9n_8mSWWFY__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__lMCIO_gwoENlBigI2UOzOKkyG-EeUqOHrxnTec1I-HQ__C389Vc_zjTfBmrTqoRNGUK0zY_nSOyzn-bjDheR_WiY__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__Tf-78NpoVoLlLaIMdFd4t-zj2WpBD71T_6QZ95etiGk__aAB7ynASdOCrMltPnfPuB7BO5GCisjBTWt1yr1Ag4_8__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var this_site=window.location.hostname.split(".");this_site=this_site[this_site.length-2];var sites={advocate:{pageID:13011},out:{pageID:13016},pride:{pageID:13047},outtraveler:{pageID:13022},hivplusmag:{pageID:13037},chill:{pageID:80857}},site_ttf=sites[this_site];(function(d,p){var js,s=d.getElementsByTagName('script')[0];js=d.createElement('script');js.async=true;js.defer=true;js.setAttribute("class","teads");js.src='//a.teads.tv/page/'+p+'/tag';s.parentNode.insertBefore(js,s)})(window.document,site_ttf.pageID);
//--><!]]>
</script>
<script type="text/javascript" async="async" src="https://sadmin.brightcove.com/js/BrightcoveExperiences.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__eZU2j1BNsp_jBUWhrUXPY31KbSTg7_oLmO0sU8lNeDY__V2_qhRZSGNcxlBV1RynyOlSM8PdWaBkO6M81VT7t6X4__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__MjXNtxGz98fuedHhhBBsE2yr69DCMvIjOfcWk2bVDxA__S8W8hkV4Vwgr_qDC9AQbTPiXDRzuPqSYzqmFuZkeTDU__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">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</script>
<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!--[if lt IE 9]>
    <script type="text/javascript" src="/sites/www.pride.com/themes/pride/js/html5shiv.js"></script>
    <script type="text/javascript" src="/sites/www.pride.com/themes/pride/js/respond.js"></script>
  <![endif]-->
  <!-- Start Cookie Consent -->
  <link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.css" />
  <script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.js"></script>
  <script type="text/javascript">
    window.addEventListener("load", function(){
      window.cookieconsent.initialise({
        "palette": {
          "popup": {
            "background": "#000000",
            "text": "#ffffff"
          },
          "button": {
            "background": "#980000",
            "text": "#ffffff"
          }
        },
        "content": {
          "message": "By continuing to use our site, you agree to our <a href=\"https://www.pridemedia.com/privacy-policy\" target=\"_blank\" class=\"cc-link\">Private Policy</a> and",
          "dismiss": "Accept",
          "link": "Terms of Use.",
          "href": "https://www.pridemedia.com/terms-of-use"
        }
      })});
  </script>
  <!-- End Cookie Consent -->
  <!-- Facebook Pixel Code Old-->
  <script type="text/javascript">
    !function (f, b, e, v, n, t, s) {
      if (f.fbq) return;
      n = f.fbq = function () {
        n.callMethod ?
          n.callMethod.apply(n, arguments) : n.queue.push(arguments)
      };
      if (!f._fbq) f._fbq = n;
      n.push = n;
      n.loaded = !0;
      n.version = '2.0';
      n.queue = [];
      t = b.createElement(e);
      t.async = !0;
      t.src = v;
      s = b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t, s)
    }(window,
      document, 'script', 'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1586530151593576');
    fbq('track', "PageView");
  </script>
  <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1586530151593576&ev=PageView&noscript=1"/></noscript>
  <!-- End Facebook Pixel Code -->
  <!-- Facebook Pixel Code -->
  <script type="text/javascript">
    !function (f, b, e, v, n, t, s) {
      if (f.fbq) return;
      n = f.fbq = function () {
        n.callMethod ?
          n.callMethod.apply(n, arguments) : n.queue.push(arguments)
      };
      if (!f._fbq) f._fbq = n;
      n.push = n;
      n.loaded = !0;
      n.version = '2.0';
      n.queue = [];
      t = b.createElement(e);
      t.async = !0;
      t.src = v;
      s = b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t, s)
    }(window, document, 'script',
      'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '259124211325942');
    fbq('track', 'PageView');
  </script>
  <noscript><img height="1" width="1" src="https://www.facebook.com/tr?id=259124211325942&ev=PageView&noscript=1"/></noscript>
  <!-- End Facebook Pixel Code -->
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-186314 node-type-article"  >
<noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-K5RNFPW" height="0" width="0" style="display:none;visibility:hidden" title="Google Tag Manager">Google Tag Manager</iframe></noscript> <div class="navmenu navmenu-default navmenu-fixed-left offcanvas"> <ul class="nav navmenu-nav out"><li class="0 first"><a href="/gay-celebrities">#Celebs</a></li>
<li class="1"><a href="/geek">#Geek</a></li>
<li class="2"><a href="/gay-tv">#TV</a></li>
<li class="3"><a href="/gay-movies">#Movies</a></li>
<li class="4"><a href="/gay-music">#Music</a></li>
<li class="5"><a href="/coming-out">#ComingOut</a></li>
<li class="6"><a href="/love-and-sex">#Love&amp;Sex</a></li>
<li class="7"><a href="/first-person">#FirstPerson</a></li>
<li class="8 last"><a href="/gay-activist">#Activism</a></li>
</ul><ul class="nav navmenu-nav sites"><li class="0 first"><a href="https://www.advocate.com" target="_blank">Advocate</a></li>
<li class="1"><a href="https://www.out.com" target="_blank">Out</a></li>
<li class="2"><a href="https://www.outtraveler.com" target="_blank">Out Traveler</a></li>
<li class="3 last"><a href="https://www.hivplusmag.com" target="_blank">Plus</a></li>
</ul><ul class="nav navmenu-nav order"><li class="0 first"><a href="https://subscribe.herepublishing.com/" target="_blank">Subscribe</a></li>
<li class="1"><a href="https://service.qfie.com/HERE/clsOUTLookup.asp?strAspReason=106&amp;strLookFormControl=1" target="_blank">Subscriber Services</a></li>
<li class="2 last"><a href="/signup" class="order">Email Newsletter Signup</a></li>
</ul><ul class="nav navmenu-nav terms"><li class="0 first"><a href="/contact">Contact</a></li>
<li class="1"><a href="https://www.pridemedia.com/careers/" target="_blank">Career Opportunities</a></li>
<li class="2"><a href="https://www.pridemedia.com/sales/" target="_blank">Advertise With Us</a></li>
<li class="3"><a href="https://www.pridemedia.com/privacy-policy" target="_blank">Privacy Policy</a></li>
<li class="4"><a href="https://www.pridemedia.com/terms-of-use" target="_blank">Terms of Use</a></li>
<li class="5 last"><a href="https://www.pridemedia.com/legal-notice" target="_blank">Legal Notice</a></li>
</ul>  <ul class="nav navmenu-nav copyright">
    <li>&copy; 2020 Pride Publishing Inc.<br>
      All Rights Reserved
    </li>
  </ul>
</div>
<div class="desktopHeader">
  <div class="container topHeader">
    <div class="magazines">
          </div>
    <div class="navbar navbar-default">
      <button type="button" class="navbar-toggle" data-toggle="offcanvas" data-target=".navmenu" data-canvas="body" aria-label="Menu" name="Menu" title="Menu">
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </button>
      <div class="topLogoHeader"><a href="/">
          <img src="https://www.pride.com/sites/www.pride.com/themes/pride/logo.png" class="mainLogo" alt="">
                      <img src="/sites/www.pride.com/themes/pride/images/pride-mobile.svg" class="mobileLogo" style="display:none;" alt="PRIDE">
                  </a></div>
    </div>
    <div class="expand-trending">
      <a class="icon-flame collapsed" href="#"><img src="/sites/www.pride.com/themes/pride/images/pride-logo-icon.gif" alt="Pride Expand"></a>
    </div>
    <div class="socialButtons">
      <ul class="socialList">
        <li class="searchBox">
          <a href="javascript: void(0);"><img src="/sites/www.pride.com/themes/pride/images/social-search.svg" width="29" height="20" alt="Search" class="search">
          </a>
          <div class="searchForm"> <form action="/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-Mcl37KHZ4dBTe0-FOW9P4mnXRxaNTUdUaamXdyUcv1I" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form> </div>
        </li>
        <li class="fbButton">
          <a href="https://www.facebook.com/pridesite" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-facebook.gif" width="29" height="20" alt="Facebook"></a>
        </li>
        <li class="twButton">
          <a href="https://twitter.com/pride_site" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-twitter.gif" width="29" height="20" alt="Twitter"></a>
        </li>
        <li class="instaButton">
          <a href="https://www.instagram.com/pride_site/" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-instagram.gif" width="29" height="20" alt="Instagram"></a>
        </li>
        <li class="tumblrButton">
          <a href="http://pridesite.tumblr.com/" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-tumblr.gif" width="29" height="20" alt="Tumblr"></a>
        </li>
        <li class="youtubeButton">
          <a href="https://www.youtube.com/channel/UCCB-yLpR8jydfUM9rquJcnA" target="_blank"><img src="/sites/www.pride.com/themes/pride/images/social-youtube.gif" width="29" height="20" alt="YouTube"></a>
        </li>
        <li class="mailButton">
          <a href="/signup"><img src="/sites/www.pride.com/themes/pride/images/social-mail.gif" width="29" height="20" alt="Mail"></a>
        </li>
      </ul>
    </div>
  </div>
  <div class="band">
    <div class="container">
      <!--TREND NAV BAR-->
      <div class="trendBar">
  <ul>
    <li class="trend"><span>Editor's Pick</span></li>
        <li id="" class="black" style=""> <a href="/black-lives-matter">#BlackLivesMatter</a> </li>
        <li id="" class="yellow" style=""> <a href="/geek">#Geek</a> </li>
        <li id="" class="red" style=""> <a href="/gay-movies">#Movies</a> </li>
        <li id="" class="orange" style=""> <a href="/gay-tv">#TV</a> </li>
        <li id="" class="teal" style=""> <a href="/interviews">#Interviews</a> </li>
        <li id="" class="purple" style=""> <a href="/gay-music">#Music</a> </li>
        <li id="" class="green" style=""> <a href="/coming-out" class="black" target="_blank">#ComingOut</a> </li>
        <li id="" class="teal" style=""> <a href="/gay-activist">#Activism</a> </li>
        <li id="" class="blue" style=""> <a href="/gay-celebrities">#Celebs</a> </li>
      </ul>
</div>

 </div>
  </div>
</div>
<div class="container adWindow">
      <div class="leaderboard">    <div id="block-heremedia-ads-article-leaderboard" class="block block-heremedia-ads">

      
  <div class="content">
    <div id="dfp-ad-article_leaderboard-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_leaderboard" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_leaderboard");
    });
  </script>
</div>
</div>  </div>
</div>
 </div>
  </div>
<div class="trendbar-overlay" style="display:none;">
  <ul>
  </ul>
</div>
<div id="body-inner" class="container"><a href="#" class="scrollToTop" title="Scroll To Top">Scroll To Top</a>
  <div class="row">
    <div class="col-xs-12 col-sm-12 col-md-12">                           <div class="tabs"></div>
                          <div class="page articleDetailSection" >
          <div class="row">
            <div class="col-md-8 col-sm-12 col-xs-12">    <div class="articleStatus node node-article purple">
  <div class="articleCategory"><a href="/gay-music">#Music</a></div>
    <h1 class="articleTitle"><p>Brandy Talks New Music, a Moesha Reboot, &amp; Loving Her Gay Fans</p>
</h1>
  <div class="leadImageArticle">
    <div class="articleImg ">
            <img src="https://www.pride.com/sites/default/files/brandy-pride-interview-display.jpg" alt="brandy-pride-interview-display.jpg" title="Brandy Talks New Music, a Moesha Reboot, &amp;amp; Loving Her Gay Fans
" />    </div>
        <div class="authorBox">
      <div class="box">
                        <div class="articleTeaser"><p>The R&amp;B legend is back on the scene with <em>B7</em>, her first studio album in eight years. (And yes, she knows about the memes!)</p>
</div>
                <div class="articledivder"></div>
                <div class="authorAvatar"> <a href="/authors/taylor-henderson-and-raffy-ermac"><img src="https://www.pride.com/sites/default/files/pride-logo-1000x1000-profile-2_0.jpg" alt="Taylor Henderson &amp; Raffy Ermac" title="Taylor Henderson &amp; Raffy Ermac" /></a> </div>
                <div class="articleAuthor"> By <span><a href="/authors/taylor-henderson-and-raffy-ermac">Taylor Henderson &amp; Raffy Ermac</a></span>
                  </div>
        <div class="articleDate"> <span class="date">July 31 2020 1:02 PM EDT</span>
                  </div>
      </div>
    </div>
  </div>
    <div class="shareArticleButtons"> <div class="tableDiv">
  <div class="tableRow">
   <span class="tableCell share-count article-only" data-url="https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans"></span>
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Brandy+Talks+New+Music%2C+a+Moesha+Reboot%2C+%26+Loving+Her+Gay+Fans&url=https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans&title=Brandy+Talks+New+Music%2C+a+Moesha+Reboot%2C+%26+Loving+Her+Gay+Fans" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
    <div class="textArticle" id="article-content"> <p>After an eight-year wait, R&amp;B fans were finally blessed with some new music from Brandy. </p>
<p>
</p><blockquote id="instagram-widget" class="instagram-media" data-instgrm-captioned="" data-instgrm-version="6" style="width:100%;max-width:460px; ">
  <a href="https://www.instagram.com/p/CCsfZx8jK86/" rel="nofollow" target="_blank"></a>
</blockquote>
<p>The Grammy-winning singer-songwriter calls <em>B7 </em>(her seventh full-length studio album and the first on her own music imprint Brand Nu) one of her most personal projects to date, chronicling her life, her love, her ups and downs, and what she's been up to since we last heard from her. </p>
<p>
</p><div style="position: relative; display: block; max-width: 960px;">
<div style="padding-top: 56.25%;">
    <video id="brightcove-body-embed-6177057998001" data-video-id="6177057998001" data-account="6001673517001" data-player="ENExWs4xJg" data-embed="default" data-application-id="" class="video-js" controls="" style="position: absolute; top: 0px; right: 0px; bottom: 0px; left: 0px; width: 100%; height: 100%;"></video></div>
</div>
<script type="text/javascript" src="//players.brightcove.net/6001673517001/ENExWs4xJg_default/index.min.js"></script><script type="text/javascript">
<!--//--><![CDATA[// ><!--

    var playerBrightcoveEmbed = bc('brightcove-body-embed-6177057998001');
    playerBrightcoveEmbed.on('ready', function(){
      playerBrightcoveEmbed.ima3.settings.serverUrl = "https://pubads.g.doubleclick.net/gampad/ads?iu=/6850/here.pride/video/large_player&description_url={window.location.href}&env=vp&impl=s&correlator={random}&tfcd=0&npa=0&gdfp_req=1&output=vast&sz=480x360%7C640x480&unviewed_position_start=1&cust_params=cat%3Dmusic%2Centertainment%2C90skids%2Cwomen%2Cactivism%2Clgbtq%26title%3Dbrandy_talks_new_music_moesha_reboot_loving_her_gay_fans%26aid%3D186314&cmsid=2493821&vid={mediainfo.id}";
    });
  
//--><!]]>
</script><p>"<em>B7</em> is just a compilation of songs that expresses where I've been over the last eight years, just my ups and downs with love," she told <em>PRIDE</em>'s <a href="https://twitter.com/cornbreadsays" target="_blank">Taylor Henderson</a> and <a href="https://twitter.com/byraffy" target="_blank">Raffy Ermac</a>. "It's a very personal, authentic album, a vibey album that I feel like you can press play and listen to from top to bottom. It has been very, very long for me to come back to music, it's been such a long time. But I feel like I haven't lost my passion and I absolutely love music. I'm just in a great place right now to share and I feel very strong and confident about the album, and just happy that I was able to put together a body of work that I could be proud of that represents me and so many others." </p>
<p>Throughout her long and legendary career (she released her debut self-titled record back in 1994), Brandy has also amassed a huge and loyal following of LGBTQ+ listeners, and the proud ally is still grateful for all of the support her queer fans have given her over the years.</p>
<p>"Some of my best moments are performing at Pride," she said. "The love that you guys have shown me has just been unmatched and I just absolutely love the energy and love being around just. You can't beat the love that you guys have given me. So I wanna do more Pride, I wanna do more performances. I wanna see everybody and I'm just glad that I'm loved the way I'm loved."</p>
<p>During <em>PRIDE</em>'s chat, Brandy also dove into some of her favorite deep cuts, whether or not she'd be down for a reboot of <em>Moesha</em>, and being an influence for R&amp;B's current generation of hitmakers like SZA, H.E.R., and Daniel Caesar. </p>
<p>And yes, she also knows about those iconic memes of her.</p>
<p>
</p><blockquote class="twitter-tweet" data-lang="en">
  <a href="https://twitter.com/cornbreadsays/status/1288576870972235777"></a>
</blockquote>
<p>
</p><blockquote class="twitter-tweet" data-lang="en">
  <a href="https://twitter.com/cornbreadsays/status/1288578067867160576?s=20"></a>
</blockquote>
<p>
</p><blockquote class="twitter-tweet" data-lang="en">
  <a href="https://twitter.com/byraffy/status/1288575252738400256?s=20"></a>
</blockquote>
<p><strong><em>B7</em> is available wherever you stream music. </strong></p>
<p><iframe allow="encrypted-media" allowtransparency="true" frameborder="0" height="380" src="https://open.spotify.com/embed/album/09jppw0ufVFDiotrHDMK1w" width="300"></iframe></p>
      </div>
</div>

<div class="tags"> <span>Tags:</span> <a href="/gay-music" class="purple">#Music</a>, <a href="/gay-entertainment" class="green">#Entertainment</a>, <a href="/90s-kids" class="red">#90sKids</a>, <a href="/women" class="blue">#Women</a>, <a href="/gay-activist" class="teal">#Activism</a>, <a href="/lgbtq" class="teal">#LGBTQ+</a> </div>

  <div class="magazine-subscription-promo-banner">
    <div class="entity entity-bean bean-house-promo clearfix">
  <div class="subscription content">
          <a href="https://service.qfie.com/HERE/clsOUTNewOrdForm.asp?straspreason=210&pubcode=out&trackcode=JPO6XD"  target="_blank">
        <img src="https://www.pride.com/sites/default/files/outsubbanner_mr_750x211_pride.jpg" alt="Out Subscription Banner" />      </a>
      </div>
</div>
  </div>

<h2 class="col-xs-12 ourSponsors">
  <span>From our Sponsors</span>
</h2>
<div class="row nativeCustomAds">
  <div class="col-md-6 col-sm-6 col-xs-12">
    <div id="dfp-ad-article_native_1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_native_1" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_native_1");
    });
  </script>
</div>
</div>  </div>
  <div class="col-md-6 col-sm-6 col-xs-12">
    <div id="dfp-ad-article_native_2-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_native_2" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_native_2");
    });
  </script>
</div>
</div>  </div>
</div>

    <div class="pubexchange_module" id="pubexchange_below_content" data-pubexchange-module-id="2849"></div>



<div id="comments" class="facebookComments">
    <h5>READER COMMENTS (<fb:comments-count href='https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans'></fb:comments-count>)</h5>
    <fb:comments class="fb-comments" data-href="https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans" data-numposts="10" data-width="auto"></fb:comments>
</div>
 </div>
            <div class="col-md-4 col-sm-12 col-xs-12">    <div id="block-heremedia-ads-article-bigbox-top" class="block block-heremedia-ads">

      
  <div class="content">
    <div id="dfp-ad-article_bigbox_top-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_bigbox_top" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_bigbox_top");
    });
  </script>
</div>
</div>  </div>
</div>
<div id="block-bean-single-video-embed" class="block block-bean">

    
  <div class="content">
    <div class="entity entity-bean bean-video-embed clearfix">
        <div class="content">
    <div class="field field-name-field-kaltura-video field-type-heremedia-kaltura-field field-label-hidden"><div class="field-items"></div></div><link href="https://players.brightcove.net/videojs-pip/1/videojs-pip.css" rel="stylesheet">
<div class="vjs-pip-container">
  <div style="position: relative; display: block; max-width: 100%;">
    <div style="padding-top: 56.25%;">
      <video id="brightcove-rightrail-6055361165001" data-account="6001673517001" data-player="wGC05d5pG" data-embed="default" data-playlist-id="6055361165001" width="425" height="350" class="video-js" controls style="position: absolute; top: 0; right: 0; bottom: 0; left: 0; width: 100%; height: 100%;"></video>
    </div>
  </div>
</div>
  <ol class="vjs-playlist"></ol>
<script type="text/javascript" src="//players.brightcove.net/6001673517001/wGC05d5pG_default/index.min.js"></script>
  <script type="text/javascript">
    var playerBrightcove = bc('brightcove-rightrail-6055361165001');
    playerBrightcove.on('ready', function(){
            playerBrightcove.ima3.settings.serverUrl = "https://pubads.g.doubleclick.net/gampad/ads?iu=/6850/here.pride/video/rightrail_player&description_url={window.location.href}&env=vp&impl=s&correlator={random}&tfcd=0&npa=0&gdfp_req=1&output=vast&sz=480x360%7C640x480&unviewed_position_start=1&cust_params=cat%3Dmusic%2Centertainment%2C90skids%2Cwomen%2Cactivism%2Clgbtq%26title%3Dbrandy_talks_new_music_moesha_reboot_loving_her_gay_fans%26aid%3D186314&cmsid=2493821&vid={mediainfo.id}";
                  // Initialize the picture-in-picture plugin
      playerBrightcove.pip({scale: 1});
          });
  </script>
<!-- Script for the picture-in-picture plugin -->
<script type="text/javascript" src="https://players.brightcove.net/videojs-pip/1/videojs-pip.min.js"></script>
  </div>
</div>
  </div>
</div>
<div id="block-heremedia-ads-article-bigbox-mid" class="block block-heremedia-ads">

      
  <div class="content">
    <div id="dfp-ad-article_bigbox_mid-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_bigbox_mid" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_bigbox_mid");
    });
  </script>
</div>
</div>  </div>
</div>
 </div>
          </div>
        </div>
               <div id="block-heremedia-article-3" class="block block-heremedia-article">

    
  <div class="content">
    <h2 class="col-xs-12 latestNewsTitle"><span>Latest News</span></h2>
<div class="row latestNewsSection" id="columns" data-columns>
  <div class="panel panel-primary node node-article node-teaser icon-video icon-article yellow">
      <div class="panel-image"> <a href="/geek/2020/7/31/moms-reaction-she-ras-catradora-kiss-so-wholesome-pure" ><picture  title="This Mom&amp;#039;s Reaction to &amp;#039;She-Ra&amp;#039;s Catradora Kiss Is So Wholesome &amp;amp; Pure">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/mom-reaction-gay-kiss-she-ra-catra-adora-catradora-netflix-queer-lesbian-kiss.jpg?itok=IlDiFzQ6&amp;timestamp=1596219634 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/mom-reaction-gay-kiss-she-ra-catra-adora-catradora-netflix-queer-lesbian-kiss.jpg?itok=XB629HQq&amp;timestamp=1596219634 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/mom-reaction-gay-kiss-she-ra-catra-adora-catradora-netflix-queer-lesbian-kiss.jpg?itok=IlDiFzQ6&amp;timestamp=1596219634 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/mom-reaction-gay-kiss-she-ra-catra-adora-catradora-netflix-queer-lesbian-kiss.jpg?itok=IlDiFzQ6&amp;timestamp=1596219634 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/mom-reaction-gay-kiss-she-ra-catra-adora-catradora-netflix-queer-lesbian-kiss.jpg?itok=IlDiFzQ6&amp;timestamp=1596219634" alt="mom-reaction-gay-kiss-she-ra-catra-adora-catradora-netflix-queer-lesbian-kiss.jpg" title="This Mom&amp;#039;s Reaction to &amp;#039;She-Ra&amp;#039;s Catradora Kiss Is So Wholesome &amp;amp; Pure" />
</picture></a>
        <div class="imgText"><a href="/geek">#Geek</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/geek/2020/7/31/moms-reaction-she-ras-catradora-kiss-so-wholesome-pure" >This Mom&#039;s Reaction to &#039;She-Ra&#039;s Catradora Kiss Is So Wholesome &amp; Pure</a></div>
        <div class="timeShare"> <span class="time">1 hour 17 min ago</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=This+Mom%27s+Reaction+to+%27She-Ra%27s+Catradora+Kiss+Is+So+Wholesome+%26+Pure&url=https://www.pride.com/geek/2020/7/31/moms-reaction-she-ras-catradora-kiss-so-wholesome-pure" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/geek/2020/7/31/moms-reaction-she-ras-catradora-kiss-so-wholesome-pure&title=This+Mom%27s+Reaction+to+%27She-Ra%27s+Catradora+Kiss+Is+So+Wholesome+%26+Pure" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-video icon-article purple">
      <div class="panel-image"> <a href="/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans" ><picture  title="Brandy Talks New Music, a Moesha Reboot, &amp;amp; Loving Her Gay Fans">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/brandy-pride-interview-lead.jpg?itok=BbdAa_iz&amp;timestamp=1596212902 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/brandy-pride-interview-lead.jpg?itok=SLrrxNOz&amp;timestamp=1596212902 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/brandy-pride-interview-lead.jpg?itok=BbdAa_iz&amp;timestamp=1596212902 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/brandy-pride-interview-lead.jpg?itok=BbdAa_iz&amp;timestamp=1596212902 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/brandy-pride-interview-lead.jpg?itok=BbdAa_iz&amp;timestamp=1596212902" alt="brandy-pride-interview-lead.jpg" title="Brandy Talks New Music, a Moesha Reboot, &amp;amp; Loving Her Gay Fans" />
</picture></a>
        <div class="imgText"><a href="/gay-music">#Music</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans" >Brandy Talks New Music, a Moesha Reboot, &amp; Loving Her Gay Fans</a></div>
        <div class="timeShare"> <span class="time">1:02 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Brandy+Talks+New+Music%2C+a+Moesha+Reboot%2C+%26+Loving+Her+Gay+Fans&url=https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/music/2020/7/31/brandy-talks-new-music-moesha-reboot-loving-her-gay-fans&title=Brandy+Talks+New+Music%2C+a+Moesha+Reboot%2C+%26+Loving+Her+Gay+Fans" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="adBox">
  <div id="dfp-ad-article_latest_initial_right" class="centerUnit">
  </div>
</div><div class="panel panel-primary node node-article node-teaser icon-article blue">
      <div class="panel-image"> <a href="/celebrities/2020/7/30/ellen-degeneres-apologizes-talk-show-staff-hostile-workplace" ><picture  title="Ellen DeGeneres Apologizes to Talk Show Staff for Hostile Workplace">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/ellen-degeneres-apology-letter-workplace-conditions-investigation-v3.jpg?itok=_dQNlLY_&amp;timestamp=1596147749 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/ellen-degeneres-apology-letter-workplace-conditions-investigation-v3.jpg?itok=mJi3DYfo&amp;timestamp=1596147749 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/ellen-degeneres-apology-letter-workplace-conditions-investigation-v3.jpg?itok=_dQNlLY_&amp;timestamp=1596147749 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/ellen-degeneres-apology-letter-workplace-conditions-investigation-v3.jpg?itok=_dQNlLY_&amp;timestamp=1596147749 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/ellen-degeneres-apology-letter-workplace-conditions-investigation-v3.jpg?itok=_dQNlLY_&amp;timestamp=1596147749" alt="ellen-degeneres-apology-letter-workplace-conditions-investigation-v3.jpg" title="Ellen DeGeneres Apologizes to Talk Show Staff for Hostile Workplace" />
</picture></a>
        <div class="imgText"><a href="/gay-celebrities">#Celebrities</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/celebrities/2020/7/30/ellen-degeneres-apologizes-talk-show-staff-hostile-workplace" >Ellen DeGeneres Apologizes to Talk Show Staff for Hostile Workplace</a></div>
        <div class="timeShare"> <span class="time">July 30 2020 6:30 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Ellen+DeGeneres+Apologizes+to+Talk+Show+Staff+for+Hostile+Workplace&url=https://www.pride.com/celebrities/2020/7/30/ellen-degeneres-apologizes-talk-show-staff-hostile-workplace" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/celebrities/2020/7/30/ellen-degeneres-apologizes-talk-show-staff-hostile-workplace&title=Ellen+DeGeneres+Apologizes+to+Talk+Show+Staff+for+Hostile+Workplace" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article green">
      <div class="panel-image"> <a href="/news/2020/7/30/1-4-lgbtq-youth-use-gender-neutral-pronouns-new-study-shows" ><picture  title="1 in 4 LGBTQ+ Youth Use Gender Neutral Pronouns, New Study Shows">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/struggles-of-they-them-pronouns-genderfluid-nonbinary.jpg?itok=0g7Qg8_V&amp;timestamp=1596143083 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/struggles-of-they-them-pronouns-genderfluid-nonbinary.jpg?itok=OzEm01B9&amp;timestamp=1596143083 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/struggles-of-they-them-pronouns-genderfluid-nonbinary.jpg?itok=0g7Qg8_V&amp;timestamp=1596143083 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/struggles-of-they-them-pronouns-genderfluid-nonbinary.jpg?itok=0g7Qg8_V&amp;timestamp=1596143083 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/struggles-of-they-them-pronouns-genderfluid-nonbinary.jpg?itok=0g7Qg8_V&amp;timestamp=1596143083" alt="struggles-of-they-them-pronouns-genderfluid-nonbinary.jpg" title="1 in 4 LGBTQ+ Youth Use Gender Neutral Pronouns, New Study Shows" />
</picture></a>
        <div class="imgText"><a href="/gay-news">#News</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/news/2020/7/30/1-4-lgbtq-youth-use-gender-neutral-pronouns-new-study-shows" >1 in 4 LGBTQ+ Youth Use Gender Neutral Pronouns, New Study Shows</a></div>
        <div class="timeShare"> <span class="time">July 30 2020 5:10 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=1+in+4+LGBTQ%2B+Youth+Use+Gender+Neutral+Pronouns%2C+New+Study+Shows&url=https://www.pride.com/news/2020/7/30/1-4-lgbtq-youth-use-gender-neutral-pronouns-new-study-shows" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/news/2020/7/30/1-4-lgbtq-youth-use-gender-neutral-pronouns-new-study-shows&title=1+in+4+LGBTQ%2B+Youth+Use+Gender+Neutral+Pronouns%2C+New+Study+Shows" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-media-gallery node-teaser icon-media_gallery  mg-gallery mg-teaser"><div class="panel-image"><a href="/geek/2020/7/30/here-are-crunchyrolls-most-popular-anime-lgbtq-characters"><picture  title="Here Are Crunchyroll&amp;#039;s Most Popular Anime With LGBTQ+ Characters">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/2019/07/16/lgbtq-anime-2019.jpg?itok=4c7q3kMN&amp;timestamp=1563306924 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/2019/07/16/lgbtq-anime-2019.jpg?itok=c4tF2o0l&amp;timestamp=1563306924 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/2019/07/16/lgbtq-anime-2019.jpg?itok=4c7q3kMN&amp;timestamp=1563306924 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/2019/07/16/lgbtq-anime-2019.jpg?itok=4c7q3kMN&amp;timestamp=1563306924 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/2019/07/16/lgbtq-anime-2019.jpg?itok=4c7q3kMN&amp;timestamp=1563306924" alt="lgbtq-anime-2019.jpg" title="Here Are Crunchyroll&amp;#039;s Most Popular Anime With LGBTQ+ Characters" />
</picture></a><div class="imgText yellow"><a href="/geek" class="yellow">#Geek</a></div></div><div class="panel-body"><div class="title"><a href="/geek/2020/7/30/here-are-crunchyrolls-most-popular-anime-lgbtq-characters">Here Are Crunchyroll&#039;s Most Popular Anime With LGBTQ+ Characters</a></div><div class="timeShare"><span class="time">July 30 2020 4:43 PM</span></div><div class="shareHomeButtons"><div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Here+Are+Crunchyroll%27s+Most+Popular+Anime+With+LGBTQ%2B+Characters&url=https://www.pride.com/geek/2020/7/30/here-are-crunchyrolls-most-popular-anime-lgbtq-characters" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/geek/2020/7/30/here-are-crunchyrolls-most-popular-anime-lgbtq-characters&title=Here+Are+Crunchyroll%27s+Most+Popular+Anime+With+LGBTQ%2B+Characters" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
</div></div></div><div class="adBox">
  <div id="dfp-ad-article_latest_initial_left" class="centerUnit">
  </div>
</div><div class="panel panel-primary node node-article node-teaser icon-article orange">
      <div class="panel-image"> <a href="/tv/2020/7/30/riverdales-bernadette-beck-says-she-was-hired-diversity-quota" ><picture  title="&amp;#039;Riverdale&amp;#039;s Bernadette Beck Says She Was Hired for &amp;#039;Diversity Quota&amp;#039;">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/riverdale-bernadette-beck-diversity-quota-fails-black-characters.jpg?itok=j2N5ivD5&amp;timestamp=1596135451 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/riverdale-bernadette-beck-diversity-quota-fails-black-characters.jpg?itok=pVickTjX&amp;timestamp=1596135451 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/riverdale-bernadette-beck-diversity-quota-fails-black-characters.jpg?itok=j2N5ivD5&amp;timestamp=1596135451 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/riverdale-bernadette-beck-diversity-quota-fails-black-characters.jpg?itok=j2N5ivD5&amp;timestamp=1596135451 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/riverdale-bernadette-beck-diversity-quota-fails-black-characters.jpg?itok=j2N5ivD5&amp;timestamp=1596135451" alt="riverdale-bernadette-beck-diversity-quota-fails-black-characters.jpg" title="&amp;#039;Riverdale&amp;#039;s Bernadette Beck Says She Was Hired for &amp;#039;Diversity Quota&amp;#039;" />
</picture></a>
        <div class="imgText"><a href="/gay-tv">#TV</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/tv/2020/7/30/riverdales-bernadette-beck-says-she-was-hired-diversity-quota" >&#039;Riverdale&#039;s Bernadette Beck Says She Was Hired for &#039;Diversity Quota&#039;</a></div>
        <div class="timeShare"> <span class="time">July 30 2020 3:26 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=%27Riverdale%27s+Bernadette+Beck+Says+She+Was+Hired+for+%27Diversity+Quota%27&url=https://www.pride.com/tv/2020/7/30/riverdales-bernadette-beck-says-she-was-hired-diversity-quota" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/tv/2020/7/30/riverdales-bernadette-beck-says-she-was-hired-diversity-quota&title=%27Riverdale%27s+Bernadette+Beck+Says+She+Was+Hired+for+%27Diversity+Quota%27" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-article node-teaser icon-article purple">
      <div class="panel-image"> <a href="/comedy/2020/7/30/barbie-fans-meet-kens-handsome-buddy-allan" ><picture  title="Barbie Fans, Meet Ken&amp;#039;s Handsome &amp;#039;Buddy&amp;#039; Allan">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/barbie-gay-ken-doll-allan.jpg?itok=3pPChQSM&amp;timestamp=1596131674 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/barbie-gay-ken-doll-allan.jpg?itok=2Q5TMHXt&amp;timestamp=1596131674 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/barbie-gay-ken-doll-allan.jpg?itok=3pPChQSM&amp;timestamp=1596131674 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/barbie-gay-ken-doll-allan.jpg?itok=3pPChQSM&amp;timestamp=1596131674 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/barbie-gay-ken-doll-allan.jpg?itok=3pPChQSM&amp;timestamp=1596131674" alt="barbie-gay-ken-doll-allan.jpg" title="Barbie Fans, Meet Ken&amp;#039;s Handsome &amp;#039;Buddy&amp;#039; Allan" />
</picture></a>
        <div class="imgText"><a href="/comedy">#Comedy</a></div>
          </div>
      <div class="panel-body">
    <div class="title"><a href="/comedy/2020/7/30/barbie-fans-meet-kens-handsome-buddy-allan" >Barbie Fans, Meet Ken&#039;s Handsome &#039;Buddy&#039; Allan</a></div>
        <div class="timeShare"> <span class="time">July 30 2020 2:22 PM</span>
          </div>
    <div class="shareHomeButtons"> <div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Barbie+Fans%2C+Meet+Ken%27s+Handsome+%27Buddy%27+Allan&url=https://www.pride.com/comedy/2020/7/30/barbie-fans-meet-kens-handsome-buddy-allan" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/comedy/2020/7/30/barbie-fans-meet-kens-handsome-buddy-allan&title=Barbie+Fans%2C+Meet+Ken%27s+Handsome+%27Buddy%27+Allan" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="panel panel-primary node node-media-gallery node-teaser icon-media_gallery  mg-gallery mg-teaser"><div class="panel-image"><a href="/lovesex/2020/7/30/10-lessons-bottoming-teaches-you-about-life"><picture  title="10 Lessons Bottoming Teaches You About Life">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/2018/06/12/00-bottom-lessons.jpg?itok=jhfEHogT&amp;timestamp=1528829895 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/2018/06/12/00-bottom-lessons.jpg?itok=ghvpNqER&amp;timestamp=1528829895 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/2018/06/12/00-bottom-lessons.jpg?itok=jhfEHogT&amp;timestamp=1528829895 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/2018/06/12/00-bottom-lessons.jpg?itok=jhfEHogT&amp;timestamp=1528829895 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/2018/06/12/00-bottom-lessons.jpg?itok=jhfEHogT&amp;timestamp=1528829895" alt="10 Lessons Bottoming Teaches You about Life" title="10 Lessons Bottoming Teaches You About Life" />
</picture></a><div class="imgText red"><a href="/love-and-sex" class="red">#Love&amp;Sex</a></div></div><div class="panel-body"><div class="title"><a href="/lovesex/2020/7/30/10-lessons-bottoming-teaches-you-about-life">10 Lessons Bottoming Teaches You About Life</a></div><div class="timeShare"><span class="time">July 30 2020 8:00 AM</span></div><div class="shareHomeButtons"><div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=10+Lessons+Bottoming+Teaches+You+About+Life&url=https://www.pride.com/lovesex/2020/7/30/10-lessons-bottoming-teaches-you-about-life" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/lovesex/2020/7/30/10-lessons-bottoming-teaches-you-about-life&title=10+Lessons+Bottoming+Teaches+You+About+Life" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
</div></div></div><div class="panel panel-primary node node-media-gallery node-teaser icon-media_gallery  mg-gallery mg-teaser"><div class="panel-image"><a href="/geek/2020/7/29/crema-gorgeous-lesbian-graphic-novel-weve-been-waiting"><picture  title="&amp;#039;CREMA&amp;#039; Is the Gorgeous Lesbian Graphic Novel We&amp;#039;ve Been Waiting For">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/cream-comixology-originals-lesbian-graphic-novel-cover-reveal-pride.jpg?itok=QX-upR2q&amp;timestamp=1596050492 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/cream-comixology-originals-lesbian-graphic-novel-cover-reveal-pride.jpg?itok=dzro_-KF&amp;timestamp=1596050492 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/cream-comixology-originals-lesbian-graphic-novel-cover-reveal-pride.jpg?itok=QX-upR2q&amp;timestamp=1596050492 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/cream-comixology-originals-lesbian-graphic-novel-cover-reveal-pride.jpg?itok=QX-upR2q&amp;timestamp=1596050492 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/cream-comixology-originals-lesbian-graphic-novel-cover-reveal-pride.jpg?itok=QX-upR2q&amp;timestamp=1596050492" alt="cream-comixology-originals-lesbian-graphic-novel-cover-reveal-pride.jpg" title="&amp;#039;CREMA&amp;#039; Is the Gorgeous Lesbian Graphic Novel We&amp;#039;ve Been Waiting For" />
</picture></a><div class="imgText yellow"><a href="/geek" class="yellow">#Geek</a></div></div><div class="panel-body"><div class="title"><a href="/geek/2020/7/29/crema-gorgeous-lesbian-graphic-novel-weve-been-waiting">&#039;CREMA&#039; Is the Gorgeous Lesbian Graphic Novel We&#039;ve Been Waiting For</a></div><div class="timeShare"><span class="time">July 29 2020 3:56 PM</span></div><div class="shareHomeButtons"><div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=%27CREMA%27+Is+the+Gorgeous+Lesbian+Graphic+Novel+We%27ve+Been+Waiting+For&url=https://www.pride.com/geek/2020/7/29/crema-gorgeous-lesbian-graphic-novel-weve-been-waiting" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/geek/2020/7/29/crema-gorgeous-lesbian-graphic-novel-weve-been-waiting&title=%27CREMA%27+Is+the+Gorgeous+Lesbian+Graphic+Novel+We%27ve+Been+Waiting+For" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
</div></div></div><div class="panel panel-primary node node-media-gallery node-teaser icon-media_gallery  mg-gallery mg-teaser"><div class="panel-image"><a href="/tv/2020/7/29/heres-your-first-look-ratched-ryan-murphys-new-netflix-series"><picture  title="Here&amp;#039;s Your First Look at &amp;#039;Ratched,&amp;#039; Ryan Murphy&amp;#039;s New Netflix Series">
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/ratched-netflix.jpg?itok=9k2FoNZL&amp;timestamp=1596048230 1x" media="(min-width:992px) and (max-width: 9999px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_750x422_1x/public/ratched-netflix.jpg?itok=YD-Jdjtv&amp;timestamp=1596048230 1x" media="(min-width:768px) and (max-width: 991px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/ratched-netflix.jpg?itok=9k2FoNZL&amp;timestamp=1596048230 1x" media="(min-width: 481px) and (max-width: 767px)" />
<source srcset="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/ratched-netflix.jpg?itok=9k2FoNZL&amp;timestamp=1596048230 1x" media="(min-width: 1px) and (max-width: 480px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.pride.com/sites/default/files/styles/image_style_360x203_1x/public/ratched-netflix.jpg?itok=9k2FoNZL&amp;timestamp=1596048230" alt="ratched-netflix-first-look-premiere-trailer-watch-stream-ryan-murphy-sarah-paulson.jpg" title="Here&amp;#039;s Your First Look at &amp;#039;Ratched,&amp;#039; Ryan Murphy&amp;#039;s New Netflix Series" />
</picture></a><div class="imgText orange"><a href="/gay-tv" class="orange">#TV</a></div></div><div class="panel-body"><div class="title"><a href="/tv/2020/7/29/heres-your-first-look-ratched-ryan-murphys-new-netflix-series">Here&#039;s Your First Look at &#039;Ratched,&#039; Ryan Murphy&#039;s New Netflix Series</a></div><div class="timeShare"><span class="time">July 29 2020 3:08 PM</span></div><div class="shareHomeButtons"><div class="tableDiv">
  <div class="tableRow">
    <div class="tableCell tw"><a href="https://twitter.com/share?text=Here%27s+Your+First+Look+at+%27Ratched%2C%27+Ryan+Murphy%27s+New+Netflix+Series&url=https://www.pride.com/tv/2020/7/29/heres-your-first-look-ratched-ryan-murphys-new-netflix-series" target="_blank" class="twittershare"> <img src="/sites/all/modules/custom/heremedia_fb/images/twitter-share-button.jpg" class="twitter-share-button-track" width="75" height="30" alt="Share on Twitter"/> </a> </div>
    <div class="tableCell fb"><a href="http://www.facebook.com/sharer.php?u=https://www.pride.com/tv/2020/7/29/heres-your-first-look-ratched-ryan-murphys-new-netflix-series&title=Here%27s+Your+First+Look+at+%27Ratched%2C%27+Ryan+Murphy%27s+New+Netflix+Series" target="_blank" class="facebookshare"> <img src="/sites/all/modules/custom/heremedia_fb/images/facebook-share-button.jpg" class="facebook-share-button-track" width="75" height="30" alt="Share on Facebook"/> </a> </div>
  </div>
</div>
</div></div></div>1</div>
  </div>
</div>
 </div>
  </div>
</div>
<div class="deviceClass"></div>
 <div id="dfp-ad-article_wallpaper-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-article_wallpaper" class="dfp-tag-wrapper">
    <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-article_wallpaper");
    });
  </script>
</div>
</div><script type="text/javascript" src="/sites/default/files/advagg_js/js__GM3GJPR36rRIz0TRkjC5OQwrioSyN9aoYRivDhCO_AM__qAl84FcCv2jyN22yFGS5Oc85cjd9zKX6p_cFNLGhe-M__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js" async="async"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__Eqf_L4jATush8Oiw9PYt_w0McxJRNkcQcfy1vROG49A__kcaiFCI8Riwi_7JyowXqpfOFh6N4KZamP6lwSrLz2H8__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__KPSt-urSQiSdSfo6ZIX0JX3kMxVvknnSZtkg8F99hHc__Hl5txn8dILj58RpnF2S6jjS74WP8ODqYiji3kywo-QM__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript" async="async" src="//platform.instagram.com/en_US/embeds.js"></script>
<script type="text/javascript" async="async" src="//platform.twitter.com/widgets.js"></script>
<script type="text/javascript" src="/sites/default/files/advagg_js/js__lPz9A8965eWTWsE0Z2Yb_VBnEPQoLe-AERI2pgpwaS0__cEEVK7augXHoCQY632L4QiMkzZ5KJ1ZaR0knC1bEtEU__jj4kY1mC4btJqX0_qX-waAdOb8teN3thkC7p1I19-4Q.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.fbAsyncInit=function(){FB.init({appId:'1660320884278138',cookie:true,xfbml:true,version:'v5.0'});FB.AppEvents.logPageView()};(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="https://connect.facebook.net/en_US/sdk.js";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'));
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(w,d,s,id){w.PUBX=w.PUBX||{pub:"pride",discover:false,lazy:true};var js,pjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.async=true;js.src="//main.pubexchange.com/loader.min.js";pjs.parentNode.insertBefore(js,pjs)}(window,document,"script","pubexchange-jssdk"));
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"NRJS-69c0f434b8e77d4bb92","applicationID":"811104645","transactionName":"Z10EbEoDXxFZAERZC14XJ1tMC14MFwdDbwFITBRZSz1fDVwGb0AFV105TlEHRg==","queueTime":0,"applicationTime":1234,"atts":"SxoHGgIZTB8=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
